在线检测未来函数

飞狐黑马强牛指标公式

来源:Internet,编辑:股旁网,2013-06-23

Var3:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4;
Var4:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),44)/4;
Var5:=EMA(CLOSE,1)-EMA(CLOSE,1297);
Var6:=EMA(Var5,715);
Var7:=2*(Var5-Var6);
Var8:=POW(Var7,3)*0.1+POW(Var7,2);
VarA:=EMA(CLOSE,2)-EMA(CLOSE,34);
VarB:=EMA(VarA,33);
VarC:=2*(VarA-VarB);
VarD:=POW(VarC,3)*0.1+POW(VarC,3);
VarF:=EMA(CLOSE,2)-EMA(CLOSE,89);
Var10:=EMA(VarF,30);
Var11:=2*(VarF-Var10)*10;
Var12:=POW(Var11,3)*0.1+POW(Var11,2);
Var13:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
Var14:=EMA(Var13*0.97,3);
Var15:=(HIGH+LOW+CLOSE)/3;
Var16:=(Var15-MA(Var15,14))/(0.015*AVEDEV(Var15,14));
Var17:=IF(Var11>0.015,Var12,0)*100;
Var18:=(CLOSE-LLV(CLOSE,95))/(HHV(CLOSE,95)-LLV(CLOSE,95))*100;
Var19:=VOL/240>MA(VOL,6)/240 AND CLOSE>OPEN*1.003;
Var1A:=Var19 AND CLOSE<MA(CLOSE,10)*1.05 AND CLOSE<MA(CLOSE,10)*1.3;
Var1B:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),0-VOL,0)),0)/1000;
Var1C:=MA(Var1B,13);
Var1D:=Var1B-Var1C;
Var1E:=EMA(Var1D,3);
Var1F:=CROSS(Var1D,Var1E);
强马: IF(FILTER(CROSS(EMA(CLOSE,6),EMA(CLOSE,11)) AND Var3<10 AND VarD>0 AND Var17>0 AND Var18<30 AND Var1F,90)=1,20,0),stick , COLORRED;
强牛: IF(FILTER(CROSS(EMA(CLOSE,3),EMA(CLOSE,13)) AND Var17>0 AND Var4<5 AND Var8>0 AND Var18<30 AND Var1A,5)=1,20,0),stick , COLOR6699cc;
强龙: IF(FILTER(强马 AND 强牛 AND Var1A,5)=1,20,0),stick , COLORYELLOW;
红马线: (CLOSE-MA(CLOSE,42))/MA(CLOSE,42)*100, , COLORstick;
见底: IF(HHV(CLOSE,20)/CLOSE>1.15 AND HIGH/LOW>1.05 AND CROSS(-28,红马线)*1/2,20,0),stick , COLORff0000;
强势必行: IF(FILTER(红马线>0 AND 强马 AND 红马线>0 AND 强牛 OR 红马线>0 AND 强龙,5)=1,30,0),linethick2 , COLORYELLOW;
当日强势预警: (强马 OR 强牛) AND DYNAINFO(14)>=0.02 AND DYNAINFO(17)>=0.5, , COLORff6600;
DRAWTEXT(强马>0,5,'马'), , ;
DRAWTEXT(强牛>0,13,'牛'), , COLOR6699cc;
DRAWTEXT(强龙>0,18,'龙'), , COLORYELLOW;
DRAWTEXT(见底>0,-7,'见底'), , COLORMAGENTA;

飞狐黑马强牛指标公式

 

相关文章