在线检测未来函数

通达信王氏MACD+均线思路主图指标公式

来源:Internet,编辑:股旁网,2013-06-23

MA8:EMA(CLOSE,8),COLORLIBLUE,LINETHICK1;
MA25:EMA(CLOSE,25),COLORBLUE,LINETHICK1;
MA55:EMA(CLOSE,55),COLORLICYAN,LINETHICK1;
IF(EMA(C,8)>=REF(EMA(C,8),1),EMA(C,8),DRAWNULL),COLORRED;
IF(EMA(C,25)>=REF(EMA(C,25),1),EMA(C,25),DRAWNULL),COLORRED;
IF(EMA(C,55)>=REF(EMA(C,55),1),EMA(C,55),DRAWNULL),COLORRED;
X3:=EMA(CLOSE,55);
STICKLINE(((C >= X3) AND (C >= O)),H,L,0,1),COLOR0000AA;
STICKLINE(((C >= X3) AND (C >= O)),O,C,3,0),COLOR0000AA;
STICKLINE(((C >= X3) AND (C >= O)),O,C,2.3,0),COLOR0000CC;
STICKLINE(((C >= X3) AND (C >= O)),O,C,1.8,0),COLOR0000FF;
STICKLINE(((C >= X3) AND (C >= O)),O,C,1,0),COLORCC66FF;
STICKLINE(((C >= X3) AND (C <= O)),H,L,0,1),COLOR0000AA;
STICKLINE(((C >= X3) AND (C <= O)),O,C,3,0),COLOR0000AA;
STICKLINE(((C >= X3) AND (C <= O)),O,C,2.3,0),COLOR0000CC;
STICKLINE(((C >= X3) AND (C <= O)),O,C,1.8,0),COLOR0000FF;
STICKLINE(((C >= X3) AND (C <= O)),O,C,1,0),COLORCC66FF;
STICKLINE(((C <= X3) AND (C >= O)),H,L,0,1),COLORFF6600;
STICKLINE(((C <= X3) AND (C >= O)),O,C,3,0),COLORFF6600;
STICKLINE(((C <= X3) AND (C >= O)),O,C,2.3,0),COLORFF9900;
STICKLINE(((C <= X3) AND (C >= O)),O,C,1.8,0),COLORFFCC00;
STICKLINE(((C <= X3) AND (C >= O)),O,C,1,0),COLORFFFF00;
STICKLINE(((C <= X3) AND (C <= O)),H,L,0,0),COLORFF6600;
STICKLINE(((C <= X3) AND (C <= O)),O,C,3,0),COLORFF6600;
STICKLINE(((C <= X3) AND (C <= O)),O,C,2.3,0),COLORFF9900;
STICKLINE(((C <= X3) AND (C <= O)),O,C,1.8,0),COLORFFCC00;
STICKLINE(((C <= X3) AND (C <= O)),O,C,1,0),COLORFFFF00;
Z1:=REF(H,8)=HHV(H,2*8+1);
Y1:=FILTER(Z1,8);
X1:=BACKSET(Y1,8+1);
W1:=FILTER(X1,8);{高点}
R11:=BACKSET(ISLASTBAR,BARSLAST(W1)+1); S11:=R11>REF(R11,1);
DRAWLINE(W1,H,S11,H,1),COLORBLACK,LINETHICK2;
Z2:=REF(L,8)=LLV(L,2*8+1);
Y2:=FILTER(Z2,8);
X2:=BACKSET(Y2,8+1);
W2:=FILTER(X2,8);{低点}
T11:=BACKSET(ISLASTBAR,BARSLAST(W2)+1); U11:=T11>REF(T11,1);
DRAWLINE(W2,L,U11,L,1),COLORBLACK,LINETHICK2;
M:=INTPART(3*8/5);
Z12:=REF(H,M)=HHV(H,2*M+1);
Y12:=FILTER(Z12,M);
X12:=BACKSET(Y12,M+1);
W12:=FILTER(X12,M);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(W12)+1); S112:=R112>REF(R112,1);
DRAWLINE(W12,H,S112,H,1),COLORRED,LINETHICK2;
Z22:=REF(L,M)=LLV(L,2*M+1);
Y22:=FILTER(Z22,M);
X22:=BACKSET(Y22,M+1);
W22:=FILTER(X22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(W22)+1); U112:=T112>REF(T112,1);
DRAWLINE(W22,L,U112,L,1),COLORRED,LINETHICK2;
VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2222:=CROSS(VAR1111,0.9);
VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4444:=CROSS(VAR3333,0.9);
压力:= REF(HIGH,BARSLAST(VAR2222));
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF
(HIGH,BARSLAST(VAR2222)),0.5,1),COLORBLACK,LINETHICK2;
支撑:= REF(LOW,BARSLAST(VAR4444));
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4444)),REF
(LOW,BARSLAST(VAR4444)),0.5,1),COLORBLACK,LINETHICK2;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10);
C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10);
C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
AZ1:=REF(C,BARSLAST(HD)); B:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD);
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
前期高点:IF(T1,AZ1,AZ1),POINTDOT,COLOR0000FF,LINETHICK2;
STICKLINE(T1,AZ1,AZ1,9,0),COLOR0000FF,LINETHICK2;
前期低点:IF(T2,B,B),COLOR80FF00,POINTDOT,LINETHICK2;
STICKLINE(T2,B,B,9,0),COLORFF0000,LINETHICK2;
DIFF:=EMA(CLOSE,9)-EMA(CLOSE,21);
DEA:=EMA(DIFF,6);
STICKLINE(DIFF>DEA,C,O,1.2,0),COLOR0000FF;
STICKLINE(DIFF>DEA,C,O,0.6,0),COLORCC66FF;
STICKLINE(DIFF<=DEA,C,O,1.2,0),COLORFFCC00;
STICKLINE(DIFF<=DEA,C,O,0.6,0),COLORFFFF00;

通达信王氏MACD+均线思路主图指标公式

 

相关文章