在线检测未来函数

通达信程韬主图指标公式

来源:Internet,编辑:股旁网,2013-06-27

MA1: MA(CLOSE,5),colorwhite;
MA2: MA(CLOSE,10),coloryellow;
MA3: MA(CLOSE,30),colormagenta;
Var1:=(2*CLOSE+HIGH+4*LOW)/7;
Var2:=EMA(Var1,5)*0.85;
MAHG:FORCAST(MA1,13),colorred,linethick2;
VAR5: STICKLINE(Var2>=REF(Var2,1) ,Var2,REF(Var2,1),13,1), COLORRED;
VAR6: STICKLINE(Var2<REF(Var2,1) ,Var2,REF(Var2,1),13,1), , COLORGREEN;
DRAWICON(CROSS(MA2,MA3),MA2-0.05,1);
DRAWICON(CROSS(MA3,MA2),MA2+0.1,2);
WS:=MOD(REF(C,1)*100,10)/100; { 昨收价的分数位 }
FD:=REF(C,1)/10-IF(WS<0.05,WS,WS-0.10)/10; { 涨停跌停的幅度 }
drawtext(C=ref(C,1)+FD,C,'涨停'),colorred;
drawtext(C=ref(C,1)-FD,C,'跌停'),colorgreen;
b1:=SUMBARS(v ,CAPITAL );
百分百换手:sum(AMOUNT,b1)/sum(v,b1)/100,coloryellow,linethick2;
SFF:=H/REF(H,1)<1 AND REF(h,1)/REF(h,2)<1 AND L/REF(L,1)>1 and REF(L,1)/REF(L,2)>1 ;
drawtext(SFF,l*0.95,'大鲨鱼:关注')coloryellow;
c1:=(CLOSE+LOW+HIGH)/3;
c2:=EMA(c1,6);
c3:=EMA(c2,5);
c4:=CROSS(c2,c3);
DRAWTEXT(c4,LOW/1.01,'△!!'),,COLORRED;
c5:=CROSS(c3,c2);
DRAWTEXT(c5,HIGH*1.03,'▽!!'),,COLORGREEN;
c11:=ref(c,1);
c21:=hhv(c11,2);
c31:=llv(c11,1);
et:=hhv(c11,2);
et1:=ref(et,1);
xb:=llv(c1,1);
xb1:=ref(xb,1);
m:=BARSLAST(c<xb and c1>=xb1);
m11:=ref(m,1);
n9:=BARSLAST(c>et and c1<=et1);
n1:=ref(n9,1);
m21:=BARSLAST(m-n9>0 and m11<=n1)+1;
n2:=BARSLAST(n9-m>0 and n1<=m11)+1;
et2:=hhv(et,m21);
xb2:=llv(xb,n2);
a:=if(m-n9>0 and m11<=n1,1,if(n9-m>0 and n1<=m11,0,2));
h1:=if(m-n9>0,c,et2);
h2:=if(a=1,c,c21);
h3:=if(m-n9<0,c,xb2);
h4:=if(a=1,c,xb2);
h5:=if(m-n9>0 or a=1,c,h3);
明关键价位:ref(h5,1);

通达信程韬主图指标公式

 

相关文章