在线检测未来函数

通达信双龙会指标公式

来源:Internet,编辑:股旁网,2013-07-02

该指标长短结合,波段操作,波段其实很清楚,红色持有,绿色抛出,如果红色从20起步,可一跟持有,当中可根据C1\C2红箭头及绿箭头做一起短红操作,当红色超出80后,结合C1下穿C2的绿箭头进行抛出。

VAR1:=1;
VAR2:=((((2*CLOSE)+HIGH)+LOW) / 4);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
C1:(EMA((((VAR2-VAR4)/(VAR5-VAR4))*100),4)*VAR1),COLORFF00FF;
C2:(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR1),COLORFFFFFF;
DRAWICON(CROSS(C1,C2) AND C2>0,C2,1);
DRAWICON(CROSS(C2,C1) AND C2<-100,C1,2);
DRAWICON(CROSS(C1,C2) AND C2<0,C2,1);
DRAWICON(CROSS(C2,C1) AND C2>-100,C1,2);
条件:=CROSS(C1,C2) AND C1<40;
条件0:=CROSS(C2,C1) AND C1>90;
TJ1:=CROSS(C1,C2);
TJ2:=CROSS(C2,C1);
TJ3:=CROSS(C1,C2) AND REF(C1,1)<20;
TJ4:=CROSS(C2,C1) AND REF(C1,1)>80;
DRAWTEXT(FILTER((REF(条件,1) AND (REF(LOW,1)>LOW OR TJ2)) OR (REF(条件,2) AND (REF(LOW,2)>LLV(LOW,3) OR TJ2))
OR (REF(条件,3) AND (REF(LOW,3)>LLV(LOW,4) OR TJ2)),4),50,'止'),COLORGREEN;
DRAWTEXT(TJ3,65,'安全'),COLORRED;
P1:=LLV(LOW,34);
P2:=HHV(HIGH,34);
P3:=EMA((C-P1)/(P2-P1)*100,8);
P4:=EMA(P3,5);
STICKLINE(P3>=P4,P3,P4,6,1),COLORRED;
STICKLINE(P3<P4,P3,P4,6,1),COLORGREEN;
VAR22:=(2*CLOSE+HIGH+LOW)/4;
VAR33:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR44:=LLV(LOW,5);
VAR55:=HHV(HIGH,4);
散户: EMA((VAR22-VAR44)/(VAR55-VAR44)*100,4)*VAR33;
庄家: EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR33;
DRAWICON(CROSS(散户,庄家) AND 散户<30,10,23);

通达信双龙会指标公式

 

相关文章