在线检测未来函数

通达信八指金叉指标公式

来源:Internet,编辑:股旁网,2013-07-08

1.当某指标出现金叉、拐点画买入红箭头,当某指标出现死叉、拐点画一绿箭头; 2.一排为一个指标公式,共八个买卖指标; 3.少数服从多数原理,当个八指标都提示买,还能错么?还不守仓么? 4.全绿箭头,空仓,出现四红箭头积极买入,全红箭头守仓,出现四个绿箭头时间,逢高卖出; 5.用日K线看长线,用十五分钟线做短线; 如果认为某一指标对应你的股票较准确提前,单独关注这指标也佳。

N1:=3;
N2:=5;
N3:=8;
N4:=13;
DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);
DEA:=EMA(DIFF,N2);
DRAWICON(DIFF>DEA,1,1);
DRAWICON(DIFF<DEA,1,2);
A1:=DIFF>DEA;
RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
K:=SMA(RSV1,N1,1);
D:=SMA(K,N1,1);
DRAWICON(K>D,2,1);
DRAWICON(K<D,2,2);
A2:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;
DRAWICON(RSI1>RSI2,3,1);
DRAWICON(RSI1<RSI2,3,2);
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;
LWR1:=SMA(RSV,N1,1);
LWR2:=SMA(LWR1,N1,1);
DRAWICON(LWR1>LWR2,4,1);
DRAWICON(LWR1<LWR2,4,2);
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;
DRAWICON(CLOSE>BBI,5,1);
DRAWICON(CLOSE<BBI,5,2);
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);
MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);
DRAWICON(MMS>MMM,6,1);
DRAWICON(MMS<MMM,6,2);
A6:=MMS>MMM;
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘:=(V9+V8);
卖盘:=(V6+V7);
买卖差:=买盘-卖盘;
DDX:=买卖差;
DX:=MA(买卖差,5)*20;
DDX1:=SMA(DX,3,1);
DDX2:=SMA(DDX1,3,1);
DDX3:=(5*DDX2+4*REF(DDX2,1)+3*REF(DDX2,2)+2*REF(DDX2,3)+REF(DDX2,4))/15;
DRAWICON(DDX1>DDX2,7,1);
DRAWICON(DDX1<DDX2,7,2);
A7:=DDX1>DDX2;
量:=V;
换手:=V/CAPITAL*100;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘1:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
卖盘1:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2));
DLX:=(买盘1-(-卖盘1))/量*换手;
DLX1:=SUM(DLX,6);
DLX2:=MA(DLX1,5);
DRAWICON(DLX1>DLX2,8,1);
DRAWICON(DLX1<DLX2,8,2);
A8:=DLX1>DLX2;
(A1 AND A2 AND A3 AND A4 AND A5 AND A6 AND A7 AND A8),COLORFFFF00;
买入:A1 AND A2 AND A3 AND A4 AND A5 AND A6 AND A7 AND A8=1
AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6 AND A7 AND A8,1)=0,COLORFFFF00;猎狼指导线: (A1+A2+A3+A4+A5+A6+A7+A8),LINETHICK2,COLOR00FF00;
动力线1:0;
DDX02:0;
ZLMM3:0;
BBI4:0;
LW&R5:0;
RSI6:0;
KDJ7:0;
MACD8:0;

通达信八指金叉指标公式

 

相关文章