在线检测未来函数

大智慧走势衰弱指标公式

来源:Internet,编辑:股旁网,2013-07-15

VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
a:=vol/capital;
n:=(a>2.5*ref(a,1) or a>3*ma(a,20));
ma5:=ma(c,5);
ma25:=ma(c,25);
ma60:=ma(c,60);
VAR1:=EMA(EMA(CLOSE,13),13);
KP:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*10000;
清仓卖出: if(n,if(kp>=0,3.5*1.3,3.5),3.5),DASHLINE,COLOR082e54;
DLX:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);
Dt:DLX-ref(DLX,1),linethick0;
关注:0.5,dotline,COLOR082e54;
1.75,dashline,COLORwhite;
3,dashline,color082e54;
数值:DLX,linethick0,COLORYELLOW;
m:=(dt+ref(dt,1)+ref(dt,2)+ref(dt,3));
bb:=(a<2 and hhv(a,7)<1.5*ema(a,7) and ma(a,10)<ref(ma(a,10),1));
k:=if(kp<0,if(bb,0.55,0.85),if(n,1,0.85));
t:=if(c<ref(c,1),if((1.5*ma(a,20)<=a=hhv(a,3) or dt<-0.5),if((ma25>ma60 or ma5>ma25),0.85,0.35),if(dt<0.05 and ref(dt,1)<0,0.85,1)),1);
t1:=if(ma(c,60)>ref(ma(c,60),1),if(ma(c,5)>ma(c,60),1,0.85),0.65);
p:DLX*k*t,linethick0;
partline(p,(1.75>p and p>ref(p,1)),rgb(139,69,19),(1.75<p and p>ref(p,1)),rgb(255,0,255),(1.75<p and p<ref(p,1)),rgb(61,89,171),(p<1.75 and p<ref(p,1)),rgb(107,142,35)),linethick3;
DRAWTEXT(CROSS(p,1.75),1.75*0.97,'▲'),COLORred;
DRAWTEXT(CROSS(p,1.2),1.2*0.97,'↑起'),COLORred;
DRAWTEXT(CROSS(1.2,p),1.2*1.05,'↓衰'),COLORyellow;
DRAWTEXT(CROSS(1.75,p),1.75*1.05,'↓弱'),COLORyellow;
DRAWTEXT(CROSS(p,3.2),3.2,'◆小心'),COLORyellow;

大智慧走势衰弱指标公式

 

相关文章