在线检测未来函数

通达信赛狮会主图指标公式

来源:Internet,编辑:股旁网,2013-07-16

VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2222:=CROSS(VAR1111,0.9);
VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4444:=CROSS(VAR3333,0.9);
压力:= REF(HIGH,BARSLAST(VAR2222));
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222))*1.0005,REF(HIGH,BARSLAST(VAR2222))*0.9995,2,0),COLOREA91B5,LINETHICK3;
支撑:= REF(LOW,BARSLAST(VAR4444));
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4444))*1.0005,REF(LOW,BARSLAST(VAR4444))*0.9995,2,0),COLOR00B4FF,LINETHICK3;
GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L),LINETHICK0;
明日支撑:=L+(C-GJ),LINETHICK0;
今日阻力:REF(明日阻力 , 1),LINETHICK0;
今日支撑:REF(明日支撑 , 1),LINETHICK0;
STICKLINE(ISLASTBAR AND C>=今日阻力,今日阻力*1.001,今日阻力*0.999,10,0),LINETHICK2,COLOR0000FF;
STICKLINE(ISLASTBAR AND C<今日阻力,今日阻力*1.001,今日阻力*0.999,10,0),LINETHICK2,COLOR00FF00;
STICKLINE(ISLASTBAR AND C>=今日支撑,今日支撑*1.001,今日支撑*0.999,10,0),LINETHICK2,COLORFF00FF;
STICKLINE(ISLASTBAR AND C<今日支撑,今日支撑*1.001,今日支撑*0.999,10,0),LINETHICK2,COLORFF8800;
CLOSE3:=REF(CLOSE,3);
CLOSE5:=REF(CLOSE,5);
CLOSE7:=REF(CLOSE,7);
CLOSE8:=REF(CLOSE,8);
CLOSE13:=REF(CLOSE,13);
CLOSE21:=REF(CLOSE,21);
JC:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;
参考价:SMA(JC,5,1), CIRCLEDOT,COLORGREEN;
价:IF(C>=参考价,参考价,参考价*0.98 ), CIRCLEDOT,COLOR0000FF;
AA:=IF(C>=REF(C,3),1,0);
BB:=IF(C>=REF(C,5),1,0);
CC:=IF(C>=REF(C,7),1,0);
DD:=IF(C>=REF(C,8),1,0);
EE:=IF(C>=REF(C,13),1,0);
FF:=IF(C>=REF(C,21),1,0);
GZ2:=AA+BB+CC+DD+EE+FF;
KK:=0;
KK1:=KK+REF(GZ2,1)+REF(GZ2,2)+REF(GZ2,3)+REF(GZ2,4);
KKK:=KK1/4;
DRAWICON(KKK=6 AND GZ2<6 ,H*1.02,5),COLORRED;
AAF:LLV(LOW,34),LINETHICK1,COLORFFFFCC;
BBF:MA(AAF,4),LINETHICK1,COLORYELLOW;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
DRAWICON(CROSS(RSI,11) OR (KKK=0 AND GZ2>0 AND C>REF(C,1)),L*0.99,1);
VARA:=((AMOUNT)/(VOL))/(100);
VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC:=((SUM(AMOUNT,7))/(VARA))/(100);
VARD:=DMA(VARB,(VOL)/(VARC));
VARE:=((CLOSE-VARD)/(VARD))*(100);
VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
AA1:=SMA(VARF,3,1);
SS:=(REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (AA1>79);
DRAWICON((REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND
(AA>SS),H*1.02,2),LINETHICK7,COLORGREEN;

通达信赛狮会主图指标公式

 

相关文章