在线检测未来函数

大智慧抄底组合选股指标公式

来源:Internet,编辑:股旁网,2013-07-17

短趋价:=MA(C,10) ;
趋界:=100*(LOW/MA(C,10))-100 ;
LL趋界:=100*(L/短趋价)-100 ;
CC趋界:=100*(C/短趋价)-100 ;
M1R:=AMOUNT/VOL/100 ;
M10R:=SUM(AMOUNT,10)/SUM(VOL,10)/100 ;
LL抄底:=(L-M10R)/M10R*100 ;
CC抄底:=(C-M10R)/M10R*100 ;
抄底2:=(M1R-M10R)/M10R*100 ;
价幅:=(M1R-短趋价)/短趋价*100 ;
幅差:=(价幅-HHV(价幅,10))/2 ;
LLBBB:=(L-MA(L,10))/MA(L,10)*100 ;
LLHHH:=(LLBBB+MA(LLBBB,10)) ;
LL短线:=LLHHH ;
CCBBB:=(C-MA(C,10))/MA(C,10)*100 ;
CCHHH:=(CCBBB+MA(CCBBB,10)) ;
CC短线:=CCHHH ;
L抄底:=(LOW-DMA((3*HIGH+LOW+OPEN+2*LOW)/7,VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7)))/DMA((3*HIGH+LOW+OPEN+2*LOW)/7,VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7))*100;
H抄底:=(H-DMA(((3*HIGH+LOW+OPEN+2*H)/7),VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7)))/DMA(((3*HIGH+LOW+OPEN+2*H)/7),VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7))*100;
C抄底:=(CLOSE-DMA(((3*HIGH+LOW+OPEN+2*CLOSE)/7),VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7)))/DMA(((3*HIGH+LOW+OPEN+2*CLOSE)/7),VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7))*100;
抄底:=(L抄底+H抄底+C抄底)/3 ;
L短线:=IF(((MA(((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10)),2)*3+((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10))*13)/16)>13,MA(((MA(((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10)),2)*3+((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10))*13)/16),2),((MA(((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10)),2)*3+((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10))*13)/16));
H短线:=IF(((MA(((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10)),2)*3+((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10))*13)/16)>13,MA(((MA(((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10)),2)*3+((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10))*13)/16),2),((MA(((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10)),2)*3+((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10))*13)/16));
C短线:=IF(((MA(((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10)),2)*3+((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10))*13)/16)>13,MA(((MA(((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10)),2)*3+((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10))*13)/16),2),((MA(((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10)),2)*3+((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10))*13)/16));
短线:=(L短线+H短线+C短线)/3 ;
短买:=(L-REF(C,10))-MA((L-REF(C,10)),5) ;
J:= 3*SMA(((C-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100),3,1)-2*SMA(SMA(((C-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100),3,1),3,1) ;
LJ:=3*SMA(((L-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100),3,1)-2*SMA(SMA(((L-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100),3,1),3,1) ;
D3:=(100*(L-LLV(L,3))/(HHV(L,3)-LLV(L,3))+100*(H-LLV(H,3))/(HHV(H,3)-LLV(H,3))+100*(C-LLV(L,3))/(HHV(C,3)-LLV(L,3)))/3 ;
D5:=(100*(L-LLV(L,5))/(HHV(L,5)-LLV(L,5))+100*(H-LLV(H,5))/(HHV(H,5)-LLV(H,5))+100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)))/3 ;
D10:=(100*(L-LLV(L,10))/(HHV(L,10)-LLV(L,10))+100*(H-LLV(H,10))/(HHV(H,10)-LLV(H,10))+100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)))/3 ;
D20:=(100*(L-LLV(L,20))/(HHV(L,20)-LLV(L,20))+100*(H-LLV(H,20))/(HHV(H,20)-LLV(H,20))+100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20)))/3 ;
D30:=(100*(L-LLV(L,30))/(HHV(L,30)-LLV(L,30))+100*(H-LLV(H,30))/(HHV(H,30)-LLV(H,30))+100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)))/3 ;
D60:=(100*(L-LLV(L,60))/(HHV(L,60)-LLV(L,60))+100*(H-LLV(H,60))/(HHV(H,60)-LLV(H,60))+100*(C-LLV(L,60))/(HHV(C,60)-LLV(L,60)))/3 ;
D120:=(100*(L-LLV(L,120))/(HHV(L,120)-LLV(L,120))+100*(H-LLV(H,120))/(HHV(H,120)-LLV(H,120))+100*(C-LLV(L,120))/(HHV(C,120)-LLV(L,120)))/3 ;
D250:=(100*(L-LLV(L,250))/(HHV(L,250)-LLV(L,250))+100*(H-LLV(H,250))/(HHV(H,250)-LLV(H,250))+100*(C-LLV(L,250))/(HHV(C,250)-LLV(L,250)))/3 ;
CD:=短买<0 AND 抄底<=-2 AND LJ<2 AND ((L短线=0 AND L抄底<=-2 ) AND (H短线<0.5 AND H抄底<=-1)) AND (100*(L-LLV(L,3))/(HHV(L,3)-LLV(L,3))=0 AND 100*(L-LLV(L,5))/(HHV(L,5)-LLV(L,5))=0 );
DD:=短线<4.2 AND (L短线<1 OR H短线<1 OR C短线<1) AND L短线<2 AND 抄底<-0.9 AND L抄底<-1.99 AND H抄底<7.2 AND 趋界<-1.5 AND J<45;
DD1:=((D5+ D10+ D20+D30+D3+D60+D120+D250)/8<8 ) AND 短线<0.2 AND (L短线=0) AND (H短线=0) AND (D3<20 AND D5<20 AND D10<20 AND D20<20 AND D30<20 AND D60<20 AND D120<20 AND D250<20) ;
DD0:=(100*(L-LLV(L,3))/(HHV(L,3)-LLV(L,3))<0.2 OR 100*(H-LLV(H,3))/(HHV(H,3)-LLV(H,3))<0.2 OR 100*(C-LLV(L,3))/(HHV(C,3)-LLV(L,3))<0.2) AND D3>0 AND (H短线=0 AND L短线=0 )AND (H抄底<-8 OR L抄底<-8 OR L抄底<-8) ;
DD3:=(D3=0 AND D5>0) AND 短线<2.5 AND J<20 AND H短线<4 AND L短线<1 AND L抄底<-2 AND C短线<7 AND ((趋界-抄底)<1.5 AND (趋界<-18 OR 趋界>-4));
DD5:=(D3=0 AND D5=0 AND D10>0) AND 短线<2 AND ((H短线-0.3)<=C短线 AND (L短线+1.2)>=C短线 AND (H短线-0.3)<=L短线) AND J<20 AND H短线<3 AND L短线<5.5 AND C短线<5.5 AND ((趋界-抄底)<1.5 AND (趋界<-18 OR 趋界>-4));
DD10:=(D3=0 AND D5=0 AND D10=0 AND D20>0) AND 短线<2 AND ((H短线-0.3)<=C短线 AND (L短线+1.2)>=C短线 AND (H短线-0.3)<=L短线) AND J<20 AND H短线<3 AND L短线<5.5 AND C短线<5.5 AND ((趋界-抄底)<1.5 AND (趋界<-18 OR 趋界>-4));
DD20:=(D3=0 AND D5=0 AND D10=0 AND D20=0 AND D30>0) AND 短线<2 AND ((H短线-0.3)<=C短线 AND (L短线+1.2)>=C短线 AND (H短线-0.3)<=L短线) AND J<20 AND H短线<3 AND L短线<5.5 AND C短线<5.5 AND ((趋界-抄底)<1.5 AND (趋界<-18 OR 趋界>-5));
DD30:=(D3=0 AND D5=0 AND D10=0 AND D20=0 AND D30=0 AND D60>0) AND 短线<2 AND ((H短线-0.3)<=C短线 AND (L短线+1.2)>=C短线 AND (H短线-0.3)<=L短线) AND J<20 AND H短线<3 AND L短线<5.5 AND C短线<5.5 AND ((趋界-抄底)<1.5 OR 趋界<-18);
DD60:=(D3=0 AND D5=0 AND D10=0 AND D20=0 AND D30=0 AND D60=0 AND D120>0) AND 短线<2 AND ((H短线-0.3)<=C短线 AND (L短线+1.2)>=C短线 AND (H短线-0.3)<=L短线) AND J<20 AND H短线<3 AND L短线<5.5 AND C短线<5.5 AND ((趋界-抄底)<2 OR 趋界<-18);
DD120:=(D3=0 AND D5=0 AND D10=0 AND D20=0 AND D30=0 AND D60=0 AND D120=0 AND D250>0) AND 短线<2 AND ((H短线-0.3)<=C短线 AND (L短线+0.2)>=C短线 AND (H短线-0.3)<=L短线) AND J<20 AND H短线<3 AND L短线<5.5 AND C短线<5.5;
DD250:=(D3=0 AND D5=0 AND D10=0 AND D20=0 AND D30=0 AND D60=0 AND D120=0 AND D250=0) AND 短线<2 AND ((H短线-0.2)<=C短线 AND (L短线+0.2)>=C短线 AND H短线<=L短线) AND J<20 AND H短线<3 AND L短线<5.5 AND C短线<5.5;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
K1:=3.2*SLOPE(EMA(CLOSE,3),2);
支撑价:=REF(V2,1) ;
反弹价:= EMA(EMA(EMA(HIGH+K1,3),4),4)*0.90 ;
安全价:= EMA(EMA(EMA(HIGH+K1,3),4),4)*0.85 ;
价位抄底:=if(C<反弹价 and C<支撑价,1,0) ;
现排名:=INTPART(CC抄底*100) ;
前排名:=INTPART(REF(CC抄底*100,1)) ;
排名差:=现排名-前排名 ;
十日排名差:=sum(排名差,10) ;
排名抄底:=if(现排名<0 AND 前排名<0 AND 排名差<0 AND 十日排名差<-2100,1,0);
L极品底:=if(LL抄底<LL趋界 AND LL趋界<抄底2 AND 抄底2<价幅 AND LL抄底<-2 AND LL短线<-4 AND 幅差<-8 AND 价幅<-8,1,0);
L底背入:=IF(CROSS(抄底2,价幅) AND LL抄底<-2 AND 幅差<-5 and c<o*0.98,1,0);
C极品底:=if(CC抄底<CC趋界 AND CC趋界<抄底2 AND 抄底2<价幅 AND CC抄底<-2 AND CC短线<-4 AND 幅差<-8 AND 价幅<-8,1,0);
C底背入:=IF(CROSS(抄底2,价幅) AND CC抄底<-2 AND 幅差<-5 and c<o*0.98,1,0);
准备抄底:=IF(DD OR CD,1,0) ;
可以抄底1:=DD AND CD ;
可以抄底:=IF(可以抄底1 OR (可以抄底1 AND (D5+ D10+ D20+D30+D3+D60+D120+D250=0)) OR (可以抄底1 AND 趋界<-20),1,0) ;
立即抄底:=IF(可以抄底 AND (DD0 OR DD1 OR DD3 OR DD5 OR DD10 OR DD20 OR DD30 OR DD60 OR DD120 OR DD250),1,0) ;
ST:=STRFIND(stkname,'ST',1)>0;
S:=STRFIND(stkname,'S',1)>0;
停牌:=(DYNAINFO(4)=0);
M10R:=SUM(AMOUNT,10)/SUM(VOL,10)/100;
抄底:=(C-M10R)/M10R*100;
组合抄底1:=FINANCE2(3)>=0 and FINANCE2(36)<15*10000 AND not(ST) AND NOT(S) AND NOT(停牌) AND ma(c,10)<12 AND (c-ref(c,1))/ref(c,1)*100<2 and 抄底<-3 AND
价位抄底+排名抄底+L极品底+L底背入+C极品底+C底背入+立即抄底>0;
组合抄底:ref(组合抄底1,1) and not(组合抄底1);

大智慧抄底组合选股指标公式

 

相关文章