在线检测未来函数

通达信波段机会指标公式

来源:Internet,编辑:股旁网,2013-07-20

VAR1:=LLV(LOW,5);
VAR2:=HHV(HIGH,5);
买:EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,4), COLORWHITE;
卖:EMA(0.667*REF(买,1)+0.333*买,2),COLORMAGENTA;
VAR3:=(2*CLOSE+HIGH+LOW)/4;
VAR4:=LLV(LOW,34);
VARA:=HHV(HIGH,34);
方:EMA((VAR3-VAR4)/(VARA-VAR4)*100,12),COLORRED;
向:EMA(0.667*REF(方,1)+0.333*方,2), COLORGREEN;
DRAWTEXT(CROSS(78.89, 7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1)) AND 买>35,方,'跑'),COLOR00FF00;
VAR01:=EMA(((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25)))*100,5);
VAR02:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);
VAR03:=CROSS(VAR02,VAR01);
VAR04:=REF(VAR02,2)<REF(VAR02,1) AND VAR02<REF(VAR02,1);
VAR05:=COUNT(VAR03,7)>0 AND VAR04;
VAR06:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR07:=SMA(ABS(LOW-VAR06),13,1)/SMA(MAX(LOW-VAR06,0),10,1);
VAR08:=EMA(VAR07,10);
VAR09:=EMA(C,5);
VAR10:=LLV(LOW,33);
VAR11:=EMA(IF(LOW<=VAR10,VAR09,0),3)*40;
VAR12:=IF(VAR11>100,VAR11*0.312,VAR11);
VAR13:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR14:=SMA(VAR13,3,1);
VAR15:=SMA(VAR13,3,1);
VAR16:=3*VAR14-2*VAR15;
VAR17:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR19:=REF(CLOSE,1);
VAR20:=SMA(MAX(CLOSE-VAR19,0),6,1)/SMA(ABS(CLOSE-VAR19),6,1)*100;
VAR21:=CROSS(VAR20,11);DRAWTEXT(VAR21,5,'★'),COLORYELLOW;
VAR22:=REF(LOW,1);
VAR23:=SMA(ABS(LOW-VAR22),3,1)/SMA(MAX(LOW-VAR22,0),3,1)*100;
VAR24:=EMA(IF(CLOSE*1.3,VAR23*10,VAR23/10),3);
VAR25:=LLV(LOW,30);
VAR26:=HHV(VAR24,30);
VAR27:=IF(MA(CLOSE,58),1,0);
VAR28:=EMA(IF(LOW<=VAR25,(VAR24+VAR26*2)/2,0),3)/618*VAR27;
VAR29:=IF(VAR28>100,100,VAR28);
VAR30:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR31:=(20*VAR30+19*REF(VAR30,1)+18*REF(VAR30,2)+17*REF(VAR30,3)+16*REF(VAR30,4)+15*REF(VAR30,5)+14*REF(VAR30,6)
+13*REF(VAR30,7)+12*REF(VAR30,8)+11*REF(VAR30,9)+10*REF(VAR30,10)+9*REF(VAR30,11)+8*REF(VAR30,12)
+7*REF(VAR30,13)+6*REF(VAR30,14)+5*REF(VAR30,15)+4*REF(VAR30,16)+3*REF(VAR30,17)+2*REF(VAR30,18)+
REF(VAR30,20))/211;
VAR32:= EMA(EMA(EMA(VAR31,2),2),2);
STICKLINE(VAR05 AND COUNT(VAR05,5)=1 AND VAR16<80 ,0,20,2,0),COLORRED;
短线搞:IF(CROSS(VAR17,8) ,30,0),STICK,COLORYELLOW;
吸货:STICKLINE(VAR29>-120,0,VAR29/2,0,0),COLORAA9728;
DRAWTEXT(CROSS(VAR31, VAR32),10,'▲'),COLOR0099FF;
VARA5:=IF(( (SMA(SMA(((C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100),3,1),3,1)+100)-(SMA(((HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70),9,1)+100))>60, ( (SMA(SMA(((C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100),3,1),3,1)+100)-(SMA(((HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70),9,1)+100))-60,0);
波段机会:VARA5*0.1819,COLORRED;
机会大于0参与:MA(波段机会,3),COLOR196829;
平衡位:50,COLORGRAY,POINTDOT;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
0,COLORFF00FF;
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
STICKLINE((阶段底部 < 0),0,-10,0.8,1),LINETHICK6,COLORYELLOW;
趋势线:=LLV(阶段底部,1),COLORWHITE,LINETHICK0;
STICKLINE(CROSS(阶段底部,0),0,-10,0.8,1),LINETHICK6,COLORRED;
STICKLINE((趋势线 >230 ),100,90,0.3,1),LINETHICK6,COLORGREEN;
LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
K:EMA(RSV,3);
D:MA(K,3);
STICKLINE(K>D , K,D ,2.5,0),COLORRED,LINETHICK2;
STICKLINE(D>K,K,D,2.5,0),COLORGREEN,LINETHICK2;
逃顶线:90,COLORGREEN;
中轴线: 50,COLORRED;
抄底线:10,COLORGREEN;
DRAWICON(CROSS(K,D),12,1)COLORRED;
DRAWICON(CROSS(D,K),88,2)COLORGREEN;
警戒:阶段底部 < 0,LINETHICK0,COLORYELLOW;
出击:CROSS(阶段底部,0),LINETHICK0,COLORRED;

通达信波段机会指标公式

 

相关文章