在线检测未来函数

同花顺四档观望指标公式

来源:Internet,编辑:股旁网,2013-07-20

本指标从四个维度来研判股票的走势。 指标用法:红灯停、绿灯行、黄灯等待。 使用时配合其他分析手段效果更佳,指标已经公布源码,大家可以下载优化。

C15:=C;
A15:=MAX(MA(C15,4),MA(C15,8));
B15:=MIN(MA(C15,4),MA(C15,8));
绿灯行15:C15>A15,colorgreen;
红灯停15:C15<B15,colorred;
黄灯观望15:A15>=C15 AND C15>=B15,coloryellow ;
STICKLINE(C15>A15,17,20,8,0),colorgreen,LINETHICK2;
STICKLINE(C15<B15,17,20,8,0),colorred,LINETHICK2;
STICKLINE(A15>=C15 AND C15>=B15,17,20,8,0),coloryellow,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,19,'【15日线】'),colorblue;
C30:=C;
A30:=MAX(MA(C30,8),MA(C30,15));
B30:=MIN(MA(C30,8),MA(C30,15));
绿灯行30:C30>A30,colorgreen;
红灯停30:C30<B30,colorred;
黄灯观望30:A30>=C30 AND C30>=B30,coloryellow ;
STICKLINE(C30>A30,12,15,8,0),colorgreen,LINETHICK2;
STICKLINE(C30<B30,12,15,8,0),colorred,LINETHICK2;
STICKLINE(A30>=C30 AND C30>=B30,12,15,8,0),coloryellow,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,14,'【30日线】'),colorblue;
C60:=C;
A60:=MAX(MA(C60,15),MA(C60,30));
B60:=MIN(MA(C60,15),MA(C60,30));
绿灯行60:C60>A60,colorgreen;
红灯停60:C60<B60,colorred;
黄灯观望60:A60>=C60 AND C60>=B60,coloryellow ;
STICKLINE(C60>A60,7,10,8,0),colorgreen,LINETHICK2;
STICKLINE(C60<B60,7,10,8,0),colorred,LINETHICK2;
STICKLINE(A60>=C60 AND C60>=B60,7,10,8,0),coloryellow,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,9,'【60日线】'),colorblue;
CC:=C;
A:=MAX(MA(CC,60),MA(CC,120));
B:=MIN(MA(CC,60),MA(CC,120));
绿灯行:C>A,colorgreen;
绿灯停:C<B,colorred;
黄灯观望:A>=C AND C>=B,coloryellow ;
STICKLINE(C>A,2,5,8,0),colorgreen,LINETHICK2;
STICKLINE(C<B,2,5,8,0),colorred,LINETHICK2;
STICKLINE(A>=C AND C>=B,2,5,8,0),coloryellow,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,4,'【120日线】'),colorblue;

同花顺四档观望指标公式

 

相关文章