在线检测未来函数

通达信金牌中长线主图指标公式

来源:Internet,编辑:股旁网,2013-07-21

MA13:=MA(CLOSE,13);
EMA30:EMA(CLOSE,30),COLORFFCCCC;
EMA60:EMA(CLOSE,60),COLORFF00FF;
EMA90:EMA(CLOSE,90),COLOR00FFFF;
EMA120:EMA(CLOSE,120),COLORFFCC66;
EMA250:EMA(CLOSE,250),COLORFF0000;
AA:=((((EMA30 + EMA60) + EMA90) + EMA120) / 4);
SX:=((AA * (1 / 100)) + AA);
XX:=(AA - (AA * (1 / 100)));
中粘A:=COUNT(((BETWEEN(EMA60,EMA90,XX) AND BETWEEN(EMA90,AA,EMA60)) AND BETWEEN(EMA120,EMA30,AA)),5);
UA:=((中粘A AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA30));
中粘B:=COUNT((((BETWEEN(EMA30,EMA60,XX) AND BETWEEN(EMA60,AA,EMA30)) AND BETWEEN(EMA90,EMA120,AA)) AND BETWEEN(EMA120,SX,EMA90)),5);
UB:=((中粘B AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,SX));
中粘C:=COUNT((((BETWEEN(EMA120,AA,XX) AND BETWEEN(EMA90,EMA60,AA)) AND BETWEEN(EMA30,EMA60,AA)) AND BETWEEN(EMA60,SX,EMA30)),5);
UC:=((((中粘C AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA30)) AND CROSS(CLOSE,EMA90)) AND CROSS(CLOSE,EMA60));
中粘D:=COUNT((((BETWEEN(EMA90,EMA120,XX) AND BETWEEN(EMA60,AA,EMA90)) AND BETWEEN(EMA120,AA,EMA90)) AND BETWEEN(SX,EMA30,AA)),5);
UD:=(((中粘D AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,AA));
中粘E:=COUNT((((BETWEEN(EMA30,EMA120,XX) AND BETWEEN(EMA120,EMA30,AA)) AND BETWEEN(EMA90,EMA60,AA)) AND BETWEEN(EMA60,SX,EMA90)),5);
UE:=(((中粘E AND CROSS(CLOSE,EMA30)) AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA90));
中粘F:=COUNT((((BETWEEN(EMA90,EMA60,XX) AND BETWEEN(EMA60,AA,EMA90)) AND BETWEEN(EMA120,AA,EMA90)) AND BETWEEN(EMA30,SX,AA)),5);
UF:=(((中粘F AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA30));
中粘G:=COUNT(((((BETWEEN(XX,AA,EMA30) AND BETWEEN(AA,EMA120,XX)) AND BETWEEN(EMA120,EMA60,AA)) AND BETWEEN(EMA60,EMA90,EMA120)) AND BETWEEN(EMA90,SX,EMA60)),5);
UG:=((中粘G AND CROSS(CLOSE,EMA30)) AND CROSS(CLOSE,EMA120));
中粘H:=COUNT((((BETWEEN(EMA120,EMA30,XX) AND BETWEEN(EMA30,AA,EMA120)) AND BETWEEN(EMA90,EMA60,AA)) AND BETWEEN(EMA60,SX,EMA90)),5);
UH:=(((中粘H AND CROSS(CLOSE,EMA30)) AND CROSS(CLOSE,EMA90)) AND CROSS(CLOSE,EMA60));
中粘Y:=COUNT(((((BETWEEN(EMA60,XX,EMA30) AND BETWEEN(XX,AA,EMA60)) AND BETWEEN(AA,SX,XX)) AND BETWEEN(SX,EMA90,AA)) AND BETWEEN(EMA90,EMA120,SX)),5);
UY:=((中粘Y AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA90));
中粘T:=COUNT((((BETWEEN(XX,EMA90,EMA120) AND BETWEEN(EMA90,EMA30,XX)) AND BETWEEN(EMA30,EMA60,EMA90)) AND BETWEEN(EMA60,SX,EMA30)),5);
UT:=(中粘T AND CROSS(CLOSE,XX));
中粘R:=COUNT(((BETWEEN(EMA60,SX,AA) AND BETWEEN(EMA90,SX,EMA60)) AND BETWEEN(EMA120,SX,EMA60)),5);
UR:=(((中粘R AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA90)) AND CROSS(CLOSE,EMA120));
中粘W:=COUNT((((BETWEEN(EMA30,AA,XX) AND BETWEEN(EMA120,EMA60,EMA30)) AND BETWEEN(EMA60,EMA90,EMA120)) AND BETWEEN(EMA90,SX,EMA60)),5);
UW:=(中粘W AND CROSS(CLOSE,EMA120));
中粘J:=COUNT(((BETWEEN(EMA90,SX,EMA120) AND BETWEEN(EMA60,SX,EMA120)) AND BETWEEN(SX,EMA30,EMA60)),5);
UJ:=((中粘J AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,SX));
中线粘:=((((((((((((UA OR UB) OR UC) OR UD) OR UE) OR UF) OR UG) OR UH) OR UY) OR UT) OR UR) OR UW) OR UJ);
STICKLINE(中线粘,LOW,(LOW - 0.09),4,0),COLOR00FFFF;
DRAWTEXT(中线粘,(LOW - 0.11),'中线粘'),COLOR00FFFF;
AAL:=((((EMA60 + EMA90) + EMA120) + EMA250) / 4);
SXL:=((AAL * (1 / 100)) + AAL);
XXL:=(AAL - (AAL * (1 / 100)));
长粘A:=COUNT((((BETWEEN(EMA60,XXL,EMA90) AND BETWEEN(EMA90,EMA60,AAL)) AND BETWEEN(EMA120,AAL,EMA250)) AND BETWEEN(EMA250,SXL,EMA120)),5);
WA:=((长粘A AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA250));
长粘B:=COUNT((((BETWEEN(EMA90,AAL,XXL) AND BETWEEN(AAL,EMA90,EMA60)) AND BETWEEN(EMA60,AAL,EMA250)) AND BETWEEN(SXL,EMA60,EMA250)),5);
WB:=(((长粘B AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA90)) AND CROSS(CLOSE,EMA250));
长粘C:=COUNT((((BETWEEN(EMA120,EMA90,XXL) AND BETWEEN(EMA90,AAL,EMA120)) AND BETWEEN(EMA60,EMA250,AAL)) AND BETWEEN(EMA250,SXL,EMA60)),5);
WC:=((长粘C AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA90));
长粘D:=COUNT((((BETWEEN(EMA120,AAL,XXL) AND BETWEEN(EMA90,AAL,XXL)) AND BETWEEN(EMA60,SXL,AAL)) AND BETWEEN(EMA250,SXL,AAL)),5);
WD:=((长粘D AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA250));
长粘E:=COUNT(((BETWEEN(EMA60,EMA90,XXL) AND BETWEEN(EMA90,EMA120,EMA60)) AND BETWEEN(SXL,EMA250,AAL)),5);
WE:=((长粘E AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA250));
长粘F:=COUNT((((BETWEEN(XXL,EMA60,AAL) AND BETWEEN(EMA90,EMA250,AAL)) AND BETWEEN(EMA250,EMA120,EMA90)) AND BETWEEN(EMA120,SXL,EMA250)),5);
WF:=((长粘F AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA250));
长粘G:=COUNT((((BETWEEN(EMA250,EMA60,XXL) AND BETWEEN(EMA60,EMA250,AAL)) AND BETWEEN(EMA90,EMA250,SXL)) AND BETWEEN(EMA120,SXL,EMA250)),5);
WG:=(((长粘G AND CROSS(CLOSE,EMA250)) AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA120));
长粘H:=COUNT(((BETWEEN(EMA60,EMA90,EMA30) AND BETWEEN(EMA90,EMA120,EMA60)) AND BETWEEN(EMA120,AAL,EMA90)),5);
WH:=(((长粘H AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA90)) AND CROSS(CLOSE,EMA120));
长粘:=(((((((WA OR WB) OR WC) OR WD) OR WE) OR WF) OR WG) OR WH);
STICKLINE(长粘,LOW,(LOW - 0.08),4,0),COLORFFCC66;
DRAWTEXT(长粘,(LOW - 0.1),'长线粘'),COLORFFCC66;

通达信金牌中长线主图指标公式

 

相关文章