在线检测未来函数

大智慧四项参考指标公式

来源:Internet,编辑:股旁网,2013-07-22

MA6:=MA(CLOSE,3);{数字可自行调整}
MA18:=MA(CLOSE,18);
波段:(3)*(MA6) - (2)*(MA18),LINETHICK1,COLOR87B08B;
{PARTLINE(cg,cg=fs and cg=fl,RGB(241,225,22)),linethick1;}
PARTLINE(小波段,小波段<REF(小波段,1),RGB(0,225,255),小波段>REF(小波段,1),RGB(255,0,0)),linethick2;
PARTLINE(小波段,小波段>REF(小波段,1),RGB(255,0,0)),linethick3;{上升段}
PARTLINE(小波段,小波段<REF(小波段,1),RGB(0,225,255)),linethick1;{下降段}
AAAA:3*C-FORCAST(C,10)*2,COLORYellow,LINETHICK1,DOTLINE;{黄色细线!!!};
VAR0317:=REF(CLOSE,1);
VAR0318:=((SMA(MAX(CLOSE-VAR0317,0),7,1))/(SMA(ABS(CLOSE-VAR0317),7,1)))*(100);
VAR0319:=CROSS(69,VAR0318);
T0317:=IF((DATE<=1341231),1,0);
VARA0317:=(FILTER(VAR0319,4))*(T0317);
DRAWTEXT(VARA0317,(HIGH)*(1.025),'★卖'),COLORWhite,LINETHICK3;
N101:=5;
VAR0101:=4*SMA((CLOSE-LLV(LOW,n101))/(HHV(HIGH,n101)-LLV(LOW,n101))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,n101))/(HHV(HIGH,n101)-LLV(LOW,n101))*100,5,1),3.2,1);
VAR0202:=8;
DRAWTEXT(CROSS(VAR0101,VAR0202),H*0.96,'★买'),COLORYELLOW,LINETHICK3;{买入--文字};
CC1:=CROSS(VAR0101,VAR0202);
VERTLINE(CC1,1),COLORred;{低点--红色垂直线};
N11:=9;M11:=3;
快线01:=(CLOSE-LLV(LOW,N11))/(HHV(HIGH,N11)-LLV(LOW,N11))*100;
慢线01:=SMA(快线01,M11,1);
BB01:=IF(BARSLAST(CROSS(慢线01,快线01))>=3 AND CROSS(快线01,慢线01) AND 慢线01<30,20,0);
AA01:=IF(BARSLAST(CROSS(快线01,慢线01))>=4 AND CROSS(慢线01,快线01) AND 快线01>50,20,0);
{抄底:}VERTLINE(BB01,2),COLORYellow;{抄底--黄色垂直线};
{逃顶:}VERTLINE(AA01,3),COLORE8E800;{高顶--青色垂直线};
DRAWTEXT(BB01,H*0.98,'B'),COLORWhite,LINETHICK6;

大智慧四项参考指标公式

 

相关文章