在线检测未来函数

大智慧量价上下主图指标公式

来源:Internet,编辑:股旁网,2013-07-24

ww1:=SMA(((C-LLV(c,10))/(HHV(c,10)-LLV(c,10))),3,1);
ww2:=SMA(((ww1-LLV(ww1,3))/(HHV(ww1,3)-LLV(ww1,3))),3,1)*100;
zz:=SMA(((v-LLV(v,10))/(HHV(v,10)-LLV(v,10))),3,1);
zz1:=SMA(((zz-LLV(zz,3))/(HHV(zz,3)-LLV(zz,3))),3,1)*100;
价快:eMA(ww2,1),colorred,LINETHICK2;
价慢:eMA(价快,2),color33CC99,LINETHICK2;
量快:=eMA(zz1,1);
量:eMA(量快,2),COLORWHITE,LINETHICK2;
背离:=IF(价快<=价慢 AND 量快<量,1,0);
上背离:=IF(价快>=价慢 AND 量快>量 ,1,0);
量价向下:VERTLINE( 下背离,1),COLORGREEN;
量价向上:VERTLINE( 上背离,1),COLORRED;
{量价共振}
上除权:=SPLITBARS(1);
本除权:=BARSLAST(IF(SPLITBARS(0)=1,SPLITBARS(0)+1,0))+1;
比例:SPLIT(1),LINETHICK0;
J0:=(HIGH+LOW)/2;
QJ:=WMA(J0,3);
J1:=IF(CLOSE>QJ,VOL,0);
J2:=IF(CLOSE<QJ,VOL,0);
RV:=(qj-LLV(qj,144))/(HHV(qj,144)-LLV(qj,144))*100;
统计:=SUM(J1-J2,5);
差:EMA(统计,10)-EMA(统计,34),COLORFFFFFF;
趋势:EMA(差,5),COLOR00FFFF;
结:2*(差-趋势),COLORSTICK;
GZ:=cross(差,趋势);
GG:=cross(趋势,差);
KZ:=cross(RV,5);
复权价:=C*(1+比例);
KD:=if(CAPITAL<1,cross(90,RV),cross(99,RV));
DRAWICON(KZ,差,10),ALIGN1,VALIGN0;{向上小红旗}
DRAWICON(GZ,差,12),ALIGN1,VALIGN1;{笑脸【原来为12】}
DRAWICON(KD,趋势,8),ALIGN1,VALIGN1;{向下绿箭头}
DRAWICON(GG,趋势,2),ALIGN1,VALIGN1;{哭脸【原来为13】}
DRAWTEXT(GZ and KZ,差,'底共振'),COLORYELLOW,LINETHICK4;
DRAWTEXT(GG and KD,趋势,'顶共振'),COLORCYAN,LINETHICK4;
VERTLINE(GZ and KZ,1),COLORYELLOW;
VERTLINE(GG and KD,1),COLOR00FF00;
DRAWTEXTREL(10,0,'上次除权距今:'+NUMTOSTRN(上除权,0)+' 天'),COLOREE8899;
DRAWTEXTREL(10,150,'本次除权距今:'+NUMTOSTRN(本除权,0)+' 天'),COLOREE8899;
DRAWTEXTREL(710,0,'当前复权价格:'+NUMTOSTRN(复权价,2)+' 元'),COLOREE8899;

大智慧量价上下主图指标公式

 

相关文章