在线检测未来函数

通达信日周月全景KDJ指标公式

来源:Internet,编辑:股旁网,2013-07-26

N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D,COLOR00FFFF;
月K线:MA("KDJ.K#MONTH"(9,3,3),20),COLORGREEN,NODRAW;
月D线:MA("KDJ.D#MONTH"(9,3,3),20),COLORRED,NODRAW;
DRAWBAND(月K线,RGB(165,87,16),月D线,RGB(120,120,120));
周K线:MA("KDJ.K#WEEK"(9,3,3) ,5),COLOR00FFFF,NODRAW;
周D线:MA("KDJ.D#WEEK"(9,3,3) ,5),COLOR00FF00,NODRAW;
周J线:MA("KDJ.J#WEEK"(9,3,3) ,5),COLORFF00FF,NODRAW;
DRAWBAND(周K线,RGB(180,0,180),周D线,RGB(0,120,0));
周KD差:=周K线-周D线;
STICKLINE(周K线>=REF(周K线,WEEKDAY),8,10,2,0),COLOR0000FF;
STICKLINE(周K线<REF(周K线,WEEKDAY),8,10,2,0),COLORFFFF00;
STICKLINE(周KD差>=REF(周KD差,WEEKDAY),4,6,2,0),COLOR0000FF;
STICKLINE(周KD差<REF(周KD差,WEEKDAY),4,6,2,0),COLORFFFF00;
K1:"KDJ.K"(9,3,3),COLORFFFFFF;
D1:"KDJ.D"(9,3,3),COLOR00FFFF;
J1:"KDJ.J"(9,3,3),COLOR800080;
{J1:IF("KDJ.J"(9,3,3)>=100,100,IF("KDJ.J"(9,3,3)<=0,0,"KDJ.J"(9,3,3))),COLOR00FFFF}{COLOR888888};
ZJ:=MA("KDJ.J#WEEK"(9,3,3) ,1);

通达信日周月全景KDJ指标公式

 

相关文章