在线检测未来函数

通达信投机资金指标公式

来源:Internet,编辑:股旁网,2013-07-30

DRAWTEXT_FIX(1,0.05,0.04,0,'【每个波均由两个阶段构成:同步涨跌阶段(主升主跌阶段)
与惯性涨跌阶段(背离阶段)】'),COLORLIMAGENTA;
分水岭:50,POINTDOT;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26),NODRAW;
DEA:=EMA(DIF,9),NODRAW;
MACD:=(DIF-DEA)*2;
周DIF:=("MACD.DIF#WEEK");
周DEA:=("MACD.DEA#WEEK");
周MACD:=2*(周DIF-周DEA);
STICKLINE(周MACD>REF(周MACD,1) AND 周MACD>0,48,54,15,0),COLORRED;
STICKLINE(周MACD<REF(周MACD,1) AND 周MACD>0,48,54,15,0),COLORYELLOW;
STICKLINE(周MACD>REF(周MACD,1) AND 周MACD<0,48,54,15,0),COLORLIRED;
STICKLINE(周MACD<REF(周MACD,1) AND 周MACD<0,48,54,15,0),COLORBLUE;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,49,53,2,1),COLORRED;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,49,53,2,1),COLORLIRED;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,49,53,2,1),COLORYELLOW;
STICKLINE(MACD<REF(MACD,1) AND MACD<0,49,53,2,1),COLORBLUE;
XVAR1:=(HHV(H,13)-LLV(L,13));
XVAR2:=(HHV(H,13)-C);
XVAR3:=(C-LLV(L,13));
XVAR4:=XVAR2/XVAR1*100-70;
XVAR5:=(C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100;
XVAR6:=(2*C+H+L)/4;
XVAR7:=SMA((XVAR3/XVAR1*100),3,1);
XVAR8:=LLV(L,34);
XVAR9:=SMA(XVAR7,3,1)-SMA(XVAR4,9,1);
XVAR10:=IF(XVAR9>100,XVAR9-100,0);
XVARA:=HHV(H,34);
防线:=EMA((XVAR6-XVAR8)/(XVARA-XVAR8)*100,8);
M1:EMA(防线,5);
M2:HHV(M1,5),COLORFF00FF;
DRAWBAND(M2,RGB(100,100,200),M1,0);
M3:IF(M1>REF(M1,1),M1,DRAWNULL),LINETHICK1,COLORRED;

通达信投机资金指标公式

 

相关文章