在线检测未来函数

飞狐买股均线主图指标公式

来源:Internet,编辑:股旁网,2013-07-31

M5: MA(CLOSE,5);
M10: MA(CLOSE,10);
M20: MA(CLOSE,20);
M30: MA(CLOSE,30);
M60: MA(CLOSE,60);
M125: MA(CLOSE,125);
M250: MA(CLOSE,250), , colorred;
Var2:=REF(CLOSE,1);
Var3:=SMA(MAX(CLOSE-Var2,0),6,1)/SMA(ABS(CLOSE-Var2),6,1)*100;
DRAWTEXT(CROSS(84,Var3),HIGH,'见顶↓'), , coloryellow;
Var4:=SMA(MAX(CLOSE-Var2,0),12,1)/SMA(ABS(CLOSE-Var2),12,1)*100;
DRAWTEXT(CROSS(Var4,20),LOW-(HIGH-LOW),'见底↑'), , colorred;
Var8:=MA(CLOSE,12);
Var9:=MA(CLOSE,26);
VarA:=REF(Var8,1);
VarB:=REF(Var9,1);
VarC:=(Var8-Var9)/Var8*100;
VarD:=ABS(Var8-VarA)/Var8*100;
VarE:=REF(Var9,1);
VarF:=REF(VarD,1);
Var10:=REF(M5,1);
Var11:=REF(M10,1);
Var12:=REF(CLOSE,1);
Var13:=COUNT(CLOSE>REF(CLOSE,1),5)/5*100;
Var14:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
Var15:=SMA(Var14,5,1);
Var16:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
Var17:=SMA(Var16,2,1);
Var18:=MA(VOL/CAPITAL,30)*MA(VOL,60)/10000+MA(CLOSE,30)*8;
Var19:=REF(Var15,1);
Var1A:=REF(Var17,1);
Var1B:=REF(Var18,1);
Var1C:=MA(Var17,5);
Var1D:=MA(Var17,12);
Var1E:=MA(Var17,26);
Var1F:=REF(Var13,1);
Var20:=(Var18-Var1B)/Var18*100;
Var21:=SMA(Var14,5,1);
Var22:=REF(Var21,1);
Var23:=SMA(Var16,2,1);
Var24:=REF(Var23,1);
Var25:=IF(CLOSE>OPEN,1,0);
Var26:=IF(M5>Var10,1,0);
Var27:=IF(M10>Var11,1,0);
Var28:=IF(VarD>VarF,1,0);
Var29:=IF(Var17>Var1A,5,0);
Var2A:=IF(Var19>Var15,5,0);
Var2B:=IF(Var18>Var1B,2,0);
Var2C:=IF(VarC>2.25,10,0);
Var2D:=IF(Var17>60,6,0);
Var2E:=IF(Var17>80,8,0);
Var2F:=IF(Var17>Var15,10,0);
Var30:=IF(Var17>Var15,Var1D-Var1E,0);
Var31:=IF(Var17>Var15 AND Var15<20,5,0);
Var32:=IF(CLOSE>Var8 AND Var8>Var9,5,0);
Var33:=IF(Var8>Var9,5,0);
Var34:=IF(Var9>VarE,5,0);
Var35:=IF(Var15<18,Var1C-Var15,0);
Var36:=IF(Var15>Var17 AND Var15>50,8,0);
Var37:=(Var25+Var26+Var27+Var28+Var29+Var2A+Var2B+Var2C+Var2D+Var2E+Var2F+Var30+Var31+Var32+Var33+Var34+Var35-Var36);
Var38:=REF(Var37,1);
Var39:=MA(Var37,6);
Var3A:=MA(Var37,12);
Var3B:=MA(Var37,26);
Var3C:=MA(Var37,13);
Var3D:=REF(Var3A,1);
Var3E:=REF(Var3A,2);
DRAWTEXT(Var19>Var1B AND Var15<Var18 AND Var3A<25 AND Var17>Var15,M5,'最佳时机 '), , colorred;
DRAWTEXT(Var18>30 AND Var17>Var18 AND Var3A>30 AND Var3A<60 AND CROSS(Var18,Var15),M5,'追涨 '), , coloryellow;
DRAWTEXT(Var3A>60 AND CROSS(Var3C,Var3A) AND Var17<60 AND Var15>20,M5,'等死吗? '), , colorgreen;
DRAWTEXT(Var3A>60 AND Var3E<Var3D AND Var3D>Var3A,M5,'逃命! '), , colorgreen;
DRAWTEXT(Var18>66 AND CROSS(Var15,Var18) OR Var13=0 AND Var1F>0 AND Var17<15 OR Var13=0 AND Var1F=0 AND Var1A>15,LOW-(HIGH-LOW)/2,'还要跌'), , colorgreen;
DRAWTEXT(Var20>0.4 AND Var18>97 AND Var17>86 AND Var15<10,M5,'还要涨'), , colorred;
DRAWTEXT(Var20>0.65 AND Var15<9,M5,'还要涨'), , colorred;

飞狐买股均线主图指标公式

 

相关文章