在线检测未来函数

通达信金钱手主图指标公式

来源:Internet,编辑:股旁网,2013-08-01

{金,};
{钱.};
{手.};
生命线:FORCAST(FORCAST(金钱手,34),13),LINETHICK3,COLORBLUE{钱};
生命线:EMA(SLOPE(C,22)*23+C,48),LINETHICK2,COLORYELLOW;
止损:EMA(C,5),COLORRED,LINETHICK1;
减仓:EMA(C,9),COLOR00CC00,LINETHICK1;
参买:IF(止损>=REF(止损,1),止损,DRAWNULL),LINETHICK1,COLORRED;
顶:BBI+3*STD(BBI,13),COLORWHITE;
底:BBI-3*STD(BBI,13),COLORWHITE;
HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高压:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DRAWICON(CC1,L*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低支:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK1;
ZGSTAR:=(高压+低支)/2;
ZGEND:=CONST((高压+低支)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
STICKLINE((VAR2 < MA(VAR3,6)) AND O<=C,O,C,-1,1),COLORCYAN;
STICKLINE((VAR2 < MA(VAR3,6)) AND O<=C,O,L,0,1),COLORCYAN;
STICKLINE((VAR2 < MA(VAR3,6)) AND O<=C,C,H,0,1),COLORCYAN;
STICKLINE((VAR2 > MA(VAR3,6)) AND O>=C,C,O,-1,0),COLORRED;
STICKLINE((VAR2 > MA(VAR3,6)) AND O>=C,L,H,0,0),COLORRED;
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW - (LOW*0.04)),7);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH+(HIGH*0.03)),8);

通达信金钱手主图指标公式

 

相关文章