在线检测未来函数

飞狐牛熊通用指标公式

来源:Internet,编辑:股旁网,2013-08-05

VAR1:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;
VAR2:=SMA(VAR1,2,1);VAR3:=SMA(VAR2,2,1);
VAR4:=VOL/CAPITAL*34;VAR5:=REF(VAR4,1);
主力建仓提醒:STICKLINE(VAR3<8.5 AND VAR2<11,0,20,5,0),COLORFF00FF;
大户减仓:STICKLINE(VAR5>50 AND VAR5<4.2,0,20,5,0),COLOR00FF00;
机构出货:STICKLINE(VAR3>89.5 AND VAR2>91,0,20,5,0),COLORFFFFFF;
主力出货:STICKLINE(VAR3>88.5 AND VAR2>94.6,0,20,5,0),COLORFFFF00;
VAR13:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K1:SMA(VAR13,3,1),COLORFFFFFF;
D1:SMA(K1,3,1),COLORFFFFFF,LINETHICK2;
VAR21:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
K2:SMA(VAR21,3,1),COLOR0000FF;
D2:SMA(K2,3,1),COLOR0000FF,LINETHICK2;
VAR34:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K3:SMA(VAR34,3,1),COLORFF8800;
D3:SMA(K3,3,1),COLORFF8800,LINETHICK2;
VAR55:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K55:=SMA(VAR55,3,1),COLOR00FF00;
D55:=SMA(K55,3,1),COLOR008000;
DIBU:=K1<20 AND D1<20 AND K2<20 AND D2<20 AND K3<20 AND D3<20 AND D55<20;
STICKLINE(DIBU=1,-2,5,1,0),COLORRED;
TOBU:=K3>80 AND K2>80 ;
STICKLINE(TOBU=1,100,95,1,0) ,COLORGREEN;
V1:=LLV(LOW,10);V2:=HHV(H,25);
价位线:=EMA((C-V1)/(V2-V1)*4,4);
DRAWTEXT(CROSS(价位线,0.3),d1,'●★'),COLORRED;
DRAWTEXT(CROSS(3.5,价位线),k1,'●逃'),COLORFFFFFF;
VV2:=REF(CLOSE,1);
VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWTEXT(REF(VV3,1)>81 AND VV3<80,d1,' 沽空↓'),COLORYELLOW;
VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VARA>=VARB AND VARA<-17,3)
AND REF(LOW,1)=LLV(LOW,120),1,0),10,'★注意买入');
S:=MA(VOL,5)/MA(VOL,60); A:=MA(S,5);
BIAS:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100; F:=MA(S,121);
RSV:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
K:=SMA(RSV,15,1); D:=SMA(K,15,1); J:=3*K-2*D;LC:=REF(CLOSE,1);
RSI6:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(83,RSI6),90,'逃顶!'),COLORYELLOW ;
S1:=IF((J<11 AND BIAS>-11 AND CROSS( S,F) AND (S-F)>0.010),2,0);
DRAWTEXT(S1=2,0,'关注!'), COLORGREEN;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DRAWTEXT(((LLV(LOW,21) = LOW) AND NOT((LLV(CCI,21)=CCI))),5,'底背离'),COLORRED;
DRAWTEXT(((HHV(HIGH,34) = HIGH) AND
(MA(CCI,3)<REF(MA(CCI,3),1) OR CCI<REF(CCI,1)) AND
NOT((HHV(CCI,34)=CCI))),100,'顶背离'),COLORGREEN;

飞狐牛熊通用指标公式

 

相关文章