在线检测未来函数

通达信金马主图指标公式

来源:Internet,编辑:股旁网,2013-08-09

N1:=3;
M2:=MA(C,20),COLORGREEN;
MA10:=EMA(C,10),COLORWHITE;
MA15:=EMA(C,15),COLORRED;
VAR1:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR3:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR6:=VAR3-VAR1;
Z:=MA(VAR6,N1);
STICKLINE(Z>=0 {AND ZZ=2},O,C,3,1),COLORRED;
STICKLINE(Z>=0 {AND ZZ=2},H,MAX(O,C),0,1),COLORRED;
STICKLINE(Z>=0 {AND ZZ=2},MIN(O,C),L,0,1),COLORRED;
STICKLINE(Z<0 {AND ZZ=1},O,C,3,0),COLORCYAN;
STICKLINE(Z<0 {AND ZZ=1},H,MAX(O,C),0,0),COLORCYAN;
STICKLINE(Z<0 {AND ZZ=1},MIN(O,C),L,0,0),COLORCYAN;
STICKLINE(Z>=0 AND M2>C,O,C,3,0),COLORCYAN;
STICKLINE(Z>=0 AND M2>C,H,MAX(O,C),0,0),COLORCYAN;
STICKLINE(Z>=0 AND M2>C,MIN(O,C),L,0,0),COLORCYAN;
STICKLINE(Z<0 AND M2<C,O,C,3,1),COLORRED;
STICKLINE(Z<0 AND M2<C,H,MAX(O,C),0,0),COLORRED;
STICKLINE(Z<0 AND M2<C,MIN(O,C),L,0,0),COLORRED;
金马日线:IF(MA10<C,MA10,DRAWNULL )COLORWHITE;
金马K线:IF(C>=MA15 AND MA10>MA15 AND CLOSE>MA15 ,MA15,DRAWNULL )COLORRED,LINETHICK1;
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,2.5,0),COLORLIMAGENTA;

通达信金马主图指标公式

 

相关文章