在线检测未来函数

通达信亚当夏娃航母主图指标公式

来源:Internet,编辑:股旁网,2013-08-08

DP:=IF(C=INDEXC,0,1);
GJ:=AMOUNT/V/100;
【明日阻力】:L+(GJ-L)+(C-L),NODRAW;
【明日支撑】:L+(C-GJ),NODRAW;
今日阻力:REF(【明日阻力】 , 1),NODRAW;
今日支撑:REF(【明日支撑】 , 1),NODRAW;
反压线:HHV(FORCAST(C,10),18),COLOREE8FFF,LINETHICK1;
NOTEXT_AB:MA(C,5),COLORFFFFFF;
NOTEXT_AC:MA(C,10),COLOR00FFFF,LINETHICK1;
NOTEXT_AE:MA(C,21),COLORFF00FF,LINETHICK1;
NOTEXT_A4:MA(C,30),COLOR00FF00,LINETHICK1;
NOTEXT_A5:MA(C,60),COLOR208FFF,LINETHICK1;
NOTEXT_A6:MA(C,90),COLOR00FF00,LINETHICK0;
NOTEXT_A7:MA(C,120),COLOR00FFFF,LINETHICK0;
NOTEXT_A8:MA(C,240),COLOR00FF00,LINETHICK0;
指导线: EMA((EMA(C,4)+EMA(C,6)+EMA(C,12)+EMA(C,24))/4,2),LINETHICK0,COLORFFFFFF;
界: MA(CLOSE,21),LINETHICK0,COLOR00FFFF;
上限: 界+3*STD(C,20),LINETHICK0,COLOR00FFFF;
卖: 界+2*STD(C,20),LINETHICK0,COLORFF00FF;
买: 界-2*STD(C,20),LINETHICK0,COLORF0FF00;
下限: 界-2.9*STD(CLOSE,20),LINETHICK0,COLOR00FF00;
年:MA(CLOSE,26),COLOR00FF00,LINETHICK0;
STICKLINE(C>=年 AND C>=O,C,O,4,0),COLOR0000AA;
STICKLINE(C>=年 AND C>=O,C,O,2,0),COLOR0000EE;
STICKLINE(C>=年 AND C>=O,C,O,1,0),COLORRED;
STICKLINE(C>=年 AND C>=O,H,L,0,0),COLORRED;
STICKLINE(C>=年 AND C<O,C,O,4,0),COLOR0000AA;
STICKLINE(C>=年 AND C<O,C,O,2,0),COLOR0000CC;
STICKLINE(C>=年 AND C<O,C,O,1,0),COLORRED;
STICKLINE(C>=年 AND C<O,O,H,0,0),COLORRED;
STICKLINE(C>=年 AND C<O,C,L,0,0),COLORRED;
STICKLINE(C<年 AND C>O,C,O,4,0),COLORAAAA00;
STICKLINE(C<年 AND C>O,C,O,2,0),COLOREEEE00;
STICKLINE(C<年 AND C>O,C,O,1,0),COLORFFFF00;
STICKLINE(C<年 AND C<=O,C,O,4,0),COLORAAAA00;
STICKLINE(C<年 AND C<=O,C,O,2,0),COLORCCCC00;
STICKLINE(C<年 AND C<=O,C,O,1,0),COLORFFFF00;
STICKLINE(C<年 AND C<=O,H,L,0,0),COLORFFFF00;
STICKLINE(C<年 AND C>O,C,H,0,0),COLORFFFF00;
STICKLINE(C<年 AND C>O,O,L,0,0),COLORFFFF00;
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),L*0.99 ,'B'),COLOR208FFF;
DRAWTEXT(CROSS(H,年) AND CROSS(VAR2,MA(VAR3,6)),L*0.99,'B'),COLORYELLOW;
DRAWTEXT(CROSS(年,L) AND C<=年,H*1.01,'S'),COLORGREEN;
DRAWICON(((C>界 AND 指导线>界 AND CROSS(界,L))),L,8);
DRAWTEXT(((C>界 AND 指导线>界 AND CROSS(指导线,界))),L*0.99,'买点');
DRAWTEXT(((C>界 AND 指导线>界 AND CROSS(指导线,界))),L*0.99,'⊕');
DRAWICON(CROSS(H,上限),H*1.01,10);
DRAWICON(CROSS(上限,H),H*1.01,9);
DRAWICON((H>上限 AND CROSS(H,上限)),H*1.01,12);
DRAWTEXT(CROSS(H,上限),H*1.01,' ̄'),COLOR00FFFF;
DRAWICON((H>卖 AND CROSS(上限,H)),H*1.01,9);
DRAWTEXT(CROSS(上限,H),H*1.01,' ̄'),COLORFF00FF;
DRAWTEXT(CROSS(下限,L),L*0.99,'限'),COLOR00FF00;
DRAWTEXT(CROSS(下限,L),L*0.99,' ̄'),COLOR00FF00;
DRAWTEXT(CROSS(买,L),L*0.99,'△'),COLORFFFF00;
DRAWTEXT(CROSS(买,L),L*0.99,' ̄'),COLORFFFF00;
DRAWTEXT(CROSS(买,C),L*0.99,'▲'),COLORFFFF00;
DRAWTEXT(CROSS(买,C),L*0.99,' ̄'),COLORFFFF00;

通达信亚当夏娃航母主图指标公式

 

相关文章