在线检测未来函数

通达信主控成交量指标公式

来源:Internet,编辑:股旁网,2013-08-10

DIIFF:=(EMA(CLOSE,5) - EMA(CLOSE,10));
DEAA:=EMA(DIIFF,3);
K线动能:=(DIIFF-DEAA),COLORYELLOW;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
周DIF:=("MACD.DIF#WEEK");
周DEA:=("MACD.DEA#WEEK");
周MACD:=2*(周DIF-周DEA);
主力控盘度0:=(K线动能+MACD+周MACD);
主力控盘度:EMA(EMA(EMA(主力控盘度0,1),2),3)*100,NODRAW;
DRAWRECTREL(30,205,190,145,RGB(0,140,0));
DRAWRECTREL(30,195,190,155,RGB(0,160,0));
DRAWRECTREL(30,185,190,165,RGB(0,180,0));
DRAWRECTREL(30,175,190,175,RGB(0,210,0));
DRAWRECTREL(30,205,30+CONST(主力控盘度),145,RGB(140,0,0));
DRAWRECTREL(30,195,30+CONST(主力控盘度),155,RGB(160,0,0));
DRAWRECTREL(30,185,30+CONST(主力控盘度),165,RGB(180,0,0));
DRAWRECTREL(30,175,30+CONST(主力控盘度),175,RGB(210,0,0));
DRAWTEXT_FIX(1,0.05,0.01,0,STRCAT(STRCAT('主力控盘度',CON2STR(主力控盘度,2)),'%')),COLORYELLOW;
VOL_AMO:=1;{1~2;1-成交量;2-成交额};
EPSL:=0.0001;
TJ1:=H=L AND C>REF(C,1);{预备简单处理一字涨停};
TJ2:=H=L AND C<REF(C,1);{预备简单处理一字跌停};
量_价:IF(VOL_AMO=1,V,AMOUNT),STICK,COLOREEFFEE;{量或价};
STICKLINE(C>OPEN,0,量_价,1.5,1),COLOR1133FA;{画阴阳量空心柱};
STICKLINE(C<OPEN,0,量_价,1.5,1),COLORDFDF13;
EP:=IF(TJ1,EPSL,IF(TJ2,-EPSL,0));{以下2句属关键改进,版权归属原创者.YFQJ.JLJ};
YFQJ_JLJ_DDX:=(2*C-H-L+EP)/(3*(H-L+ABS(EP)));
买卖差:YFQJ_JLJ_DDX*量_价,COLOR13AADD,NODRAW;{LINETHICK};
买卖比%:买卖差/量_价*100,NODRAW;
主动买:量_价*(1+YFQJ_JLJ_DDX)/2,COLOR1133AA,NODRAW;
主动卖:量_价*(1-YFQJ_JLJ_DDX)/2,COLORDFDF13,NODRAW;
STICKLINE(1,0,主动买,2.2,1),COLOR1133DE;{红色实框空心柱}
差:=ABS(买卖差);
STICKLINE(主动买>主动卖,0,差,2,0),COLOR13BCFF;
STICKLINE(主动买>主动卖,0,差,1,0),COLOR13CDFF;
STICKLINE(主动买>主动卖,0,差,0.5,0),COLOR13DEFF;
STICKLINE(主动买<主动卖,0,差,2,0),COLOR339933;
STICKLINE(主动买<主动卖,0,差,1,0),COLOR33BB33;
STICKLINE(主动买<主动卖,0,差,0.5,0),COLOR33DD33;
{买卖差累积曲线};
短:EMA(SUM(买卖差,5),3),COLORABCCBA,LINETHICK2;
中:=EMA(SUM(买卖差,10),3)/2,COLOR13EFEF,LINETHICK1;
长:=EMA(SUM(买卖差,20),3)/5,COLORFFAA55,LINETHICK1;
中长:=EMA(EMA(EMA(长,1),2),3);
强:IF(短>REF(短,1),短,MA(短,256000)),COLOR1133EF,LINETHICK2;
A:=EMA((EMA(中长,19)+EMA(中长,20)+EMA(中长,21))/3,3),COLORYELLOW;
轴线:=EMA(A,3)COLORWHITE;
AA:=EMA((EMA(中长,1)+EMA(中长,3)+EMA(中长,5))/3,3),COLORWHITE;
AAA:EMA(EMA(EMA(AA,1),2),3)*2;
BB:=EMA((EMA(中长,41)+EMA(中长,42)+EMA(中长,43))/3,3);
CC:=BB-(AA-BB);
CCC:EMA(EMA(EMA(CC,1),2),3)*2;
开口值1:=HHV(AA,1)/LLV(CC,1)*100-100,NODRAW;
开口值2:EMA(开口值1,5),NODRAW;
IF( AAA<轴线 AND AAA>REF(AAA,1),AAA,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF( AAA>轴线 AND AAA>REF(AAA,1),AAA,DRAWNULL),COLORRED,LINETHICK2;
IF( AAA>轴线 AND AAA<REF(AAA,1),AAA,DRAWNULL),COLORYELLOW,LINETHICK2;
IF( AAA<轴线 AND AAA<REF(AAA,1),AAA,DRAWNULL),COLORLIBLUE,LINETHICK2;
IF( CCC<轴线 AND CCC>REF(CCC,1),CCC,DRAWNULL),COLORLIBLUE,LINETHICK2;
IF( CCC>轴线 AND CCC>REF(CCC,1),CCC,DRAWNULL),COLORYELLOW,LINETHICK2;
IF( CCC>轴线 AND CCC<REF(CCC,1),CCC,DRAWNULL),COLORRED,LINETHICK2;
IF( CCC<轴线 AND CCC<REF(CCC,1),CCC,DRAWNULL),COLORMAGENTA,LINETHICK2;

通达信主控成交量指标公式

 

相关文章