在线检测未来函数

通达信黑马营三星板主图指标公式

来源:Internet,编辑:股旁网,2013-08-12

N1:=6;
N2:=12;
N3:=24;
V1:=(C*2+H+L)/4*10;
VV2:=EMA(V1,13)-EMA(V1,34);
VV3:=EMA(VV2,5);
V4:=2*(VV2-VV3)*100;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);VB1:=(V9-VA)/2;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:=EMA(V11,3);
当日成本:=IF(C>REF(C,1),(3*H+4*C+3*OPEN+2*L)/12,(2*H+4*C+3*OPEN+3*L)/12);
疯牛线:EXPMEMA(当日成本,3),LINETHICK1;
龙头线:EXPMEMA(当日成本,8),LINETHICK2;
慢牛线:EXPMEMA(当日成本,25),LINETHICK2;
生命线:EXPMEMA(当日成本,79),LINETHICK3;
牛熊线:EXPMEMA(当日成本,248),LINETHICK3;
V2:=EMA(当日成本,13)-EMA(当日成本,34);
V3:=EMA(V2,5);
CYC13:=0.01*EXPMA(AMOUNT,13)/EXPMA(VOL,13);
CYC34:=0.01*EXPMA(AMOUNT,34)/EXPMA(VOL,34);
CYS13:=(CLOSE-CYC13)/CYC13*100;
CYS34:=(CLOSE-CYC34)/CYC34*100;
CYC5:=0.01*EXPMA(AMOUNT,5)/EXPMA(VOL,5);
CYS5:=(CLOSE-CYC5)/CYC5*100;
DIVE:=0.01*EXPMA(AMOUNT,5)/EXPMA(VOL,5);
CYR5:=(DIVE/REF(DIVE,1)-1)*100;
VAR1:=(UPNDAY(慢牛线,4) AND EXPMEMA(当日成本,3)>EXPMEMA(当日成本,5) AND EXPMEMA(当日成本,5)>EXPMEMA(当日成本,7) AND MA(CLOSE,3)>MA(CLOSE,5) AND
MA(CLOSE,5)>MA(CLOSE,7));
VAR2:=(REF(VAR1,2)<0.5 AND REF(VAR1,3)<0.5 AND MA(C,5)>REF(MA(C,5),1) AND CROSS(VAR1,0.5) AND FILTER(CROSS(VAR1,0.5),7))
OR ((REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),3) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),5) OR
REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),6) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),4) OR
REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),2)) AND NOT(REF(MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7),1))
AND (MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)) AND FILTER((REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),3)
OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),5) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),6) OR
REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),4) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),2)) AND
NOT(REF(MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7),1)) AND (MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),7)
AND 疯牛线>REF(疯牛线,1)) AND MA(VOL,3)>MA(VOL,10) AND V2>=V3;
DRAWICON(EVERY(CLOSE/OPEN<=1,3) AND EVERY(CLOSE/OPEN>=0.96,3) AND UPNDAY(慢牛线,3) AND CLOSE/REF(CLOSE,3)<=1.035 AND CLOSE/REF(CLOSE,3)>=1
AND EVERY(VOL/CAPITAL<0.05,3),LOW,18);
DIVE1:=0.01*EXPMA(AMOUNT,13)/EXPMA(VOL,13);
CYR:=(DIVE1/REF(DIVE1,1)-1)*100;
MACYR:=MA(CYR,5);
RPY10:=(C-LLV(C,10))/(HHV(C,10)-LLV(C,10))*100;
CBW:=100*(COST(99.5)-COST(0.5))/COST(99.5);
ASR10:=(WINNER(C*1.1)-WINNER(C*0.9))/WINNER(HHV(H,0))*100;
ASR20:=(WINNER(C*1.2)-WINNER(C*0.8))/WINNER(HHV(H,0))*100;
ASR30:=(WINNER(C*1.3)-WINNER(C*0.7))/WINNER(HHV(H,0))*100;
DRAWTEXT((CLOSE/REF(CLOSE,1)>1.03 AND VOL/CAPITAL*100>2.5 AND 疯牛线>龙头线 AND 疯牛线>慢牛线 AND C>疯牛线
AND (WINNER(C-C*0.01/100)-WINNER(C-C*20/100))*100>50 AND CYR>1) OR (CYS>11 AND CYS<30 AND CYR>1 AND CLOSE/REF(CLOSE,1)>1.03),LOW,'◆黑'),COLORWHITE;
DRAWTEXT(CROSS(疯牛线,龙头线) AND (CROSS(REF(龙头线,4),REF(疯牛线,4)) OR CROSS(REF(龙头线,3),REF(疯牛线,3)) OR CROSS(REF(龙头线,2),REF(疯牛线,2))
OR CROSS(REF(龙头线,1),REF(疯牛线,1))),L*0.99,'◆二攻'),COLORYELLOW;
早盘追杀:=C>REF(H,1) AND OPEN>REF(C,1)*1.015 AND REF(C,2)/REF(C,1)>1.015 AND CLOSE/REF(CLOSE,1)>1.03;
DRAWTEXT(早盘追杀,H*1.01,'◆追杀'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100;
BIAS1:=(CLOSE-MA(CLOSE,N1))/MA(CLOSE,N1)*100;
BIAS2:=(CLOSE-MA(CLOSE,N2))/MA(CLOSE,N2)*100;
BIAS3:=(CLOSE-MA(CLOSE,N3))/MA(CLOSE,N3)*100;
强牛:=BIAS1>2 AND RSI1>60 AND RSI2>50 AND RSI3>50 AND RSI1>RSI2 AND RSI2>RSI3 AND REF
(RSI1,1)<REF(RSI2,1) AND REF(RSI2,1)<REF(RSI3,1) AND CYR>1 AND CLOSE/REF(CLOSE,1)>1.03;
DRAWTEXT(强牛,L*0.98,'◆涨停'),COLORYELLOW;
YHIGH:=IF((LOW>REF(LOW,1) AND HIGH<REF(HIGH,1)),HIGH,0) OR IF(LOW<REF(LOW,1) AND HIGH>REF
(HIGH,1),REF(HIGH,1),0);
YLOW:=IF ((LOW>REF(LOW,1) AND HIGH<REF(HIGH,1)),REF(LOW,1),0) OR IF(LOW<REF(LOW,1) AND
HIGH>REF(HIGH,1),LOW,0);
孕线:=IF((LOW>REF(LOW,1) AND HIGH<REF(HIGH,1)) OR (LOW<REF(LOW,1) AND HIGH>REF
(HIGH,1)),2,0);
地方:= ((HIGH>REF(HIGH,1) AND REF(HIGH,2)>REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,2)>REF(LOW,1) AND LOW>LLV(LOW,3)
AND MA(CLOSE,5)<MA(CLOSE,10) AND (C>REF(C,1) OR H>REF(H,1))) OR (REF(孕线,1)=2 AND
HIGH>REF(YHIGH,1) AND LOW>REF(YLOW,1)
AND REF(HIGH,3)>REF(YHIGH,1) AND REF(LOW,3)>REF(YLOW,1) AND L>REF(L,1)
AND LOW>LLV(LOW,3) AND MA(CLOSE,5)<MA(CLOSE,10) AND (C>REF(C,1) OR H>REF(H,1))));
天圆:=(HIGH<REF(HIGH,1) AND LOW<REF(LOW,1) AND REF(HIGH,2)<REF(HIGH,1)
AND REF(LOW,2)<REF(LOW,1)
AND MA(CLOSE,5)>MA(CLOSE,10)) OR (REF(孕线,1)=2 AND HIGH<REF(YHIGH,1) AND LOW<REF(YLOW,1)
AND REF(HIGH,3)<REF(YHIGH,1) AND REF(LOW,3)<REF(YLOW,1)
AND MA(CLOSE,5)>MA(CLOSE,10));
DRAWICON(地方 AND (慢牛线>REF(慢牛线,1) ) AND FILTER(地方,2),LOW*0.998,16),COLORYELLOW;
HS:=VOL/CAPITAL*100;
ZDF:=(C-REF(C,1))/REF(C,1);
三日涨跌幅:=SUM(ZDF,3)*100;
鸿博通道上:=MA(CLOSE,34)+2*STD(CLOSE,60),COLORWHITE,POINTDOT,LINETHICK2;
鸿博通道下:=MA(CLOSE,34)-2*STD(CLOSE,60),COLORWHITE,POINTDOT,LINETHICK2;
AA10:=MA(C,9);
BB10:=ATAN((AA10-REF(AA10,1)))*180/3.1416;
VA1:=LLV(LOW,34);
VA2:=HHV(HIGH,30);
VA3:=REF(CLOSE,1);
VA4:=EMA((CLOSE-VA1)/(VA2-VA1),3)*100;
主力:=SMA(MAX(CLOSE-VA3,0),7,1)/SMA(ABS(CLOSE-VA3),7,1)*100,COLORRED;
散户:=VA4;
VAR5:=(VA4-LLV(VA4,21))/(HHV(VA4,21)-LLV(VA4,21))*100;
VY:=SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,5,1);
L2:=SMA(0.618*REF(VY,1)+0.382*VY,3,1), COLORFF9900;
L3:=MA(L2,5);
超买超卖:=MA(L2,5),LINETHICK3;
一号线:=(EXPMA(CLOSE,2)+MA(CLOSE,2*1)+MA(CLOSE,2*3))/3,LINETHICK2;
二号线:=(EXPMA(CLOSE,4)+MA(CLOSE,4*2)+MA(CLOSE,4*3))/3,LINETHICK2;
三号线:=(EXPMA(CLOSE,6)+MA(CLOSE,6*2)+MA(CLOSE,6*3))/3,LINETHICK3;
四号线:=(EXPMA(CLOSE,8)+MA(CLOSE,8*2)+MA(CLOSE,8*3))/3,LINETHICK4;
DRAWICON(MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND L2>L3 AND BB10>=1 AND
AA10>=REF(AA10,1) AND 一号线>=二号线 AND 二号线>=三号线 AND CROSS(MA(CLOSE,8)
,LOW),LOW,9);
DRAWTEXT((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND
CLOSE < MA(CLOSE,5) OR (HIGH = MAX(OPEN,CLOSE) AND
HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5))),LOW,'转'), COLORYELLOW;
DRAWTEXT((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND
CLOSE > MA(CLOSE,5)) OR ((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND
CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND
CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))) OR (REF(CLOSE,1)/REF(OPEN,1)>1.03 AND
CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1)) AND H/REF(L,10)>1.118 AND
C/O<1.04 AND C/REF(C,13)>1.15,HIGH*1.03,'杀'), COLORGREEN;
DRAWTEXT(HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND
CLOSE > MA(CLOSE,5),HIGH,'转');
DRAWTEXT((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND
CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1)) OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND
CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1)) AND
C/O>1.01,LOW*0.97,'涨'),COLORMAGENTA;
DRAWTEXT(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND
OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) ,HIGH*1.015,'跌'), COLORGREEN;
DRAWTEXT(ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND
ABS(CLOSE-OPEN)/CLOSE<0.005 AND MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND
MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1)) ,LOW,'转'),COLORWHITE;
DRAWTEXT(REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)/REF(OPEN,1)>1.02 AND
CLOSE/OPEN>1.03 AND CLOSE>REF(H,4) ,LOW*0.995,'涨'),COLORWHITE;
DRAWTEXT( REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1) < REF(CLOSE,2)*1.02 AND
ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND
CLOSE>REF(CLOSE,2),LOW,'涨'), COLORCYAN;
DRAWTEXT(REF(HIGH,1)/MAX(REF(OPEN,1),REF(CLOSE,1))>1.03 AND MIN(OPEN,CLOSE)/LOW>1.03
AND REF((O-C)/O*100<3,1) AND (C-REF(C,1))/REF(C,1)*100<3 AND (ABS(REF(C,1)/REF(OPEN,1))<1.03
OR ABS(REF(O,1)/REF(C,1))<1.03) AND (MAX(C,O)-L)>ABS(C-O)*2,LOW,'天针'),COLORWHITE;
DRAWTEXT(REF(MIN(REF(OPEN,1),REF(CLOSE,1)),1)/REF(LOW,1)>1.03 AND HIGH/MAX(OPEN,CLOSE)>1.03
AND REF((O-C)/O*100<3,1) AND (C-REF(C,1))/REF(C,1)*100<3 AND REF(ABS((OPEN-CLOSE)/OPEN),1)<1.03
AND (H-MAX(C,O))>ABS(C-O)*2 AND (MIN(C,O)-REF(L,1))>ABS(REF(C,1)-REF(O,1))*2,LOW,'地针'),COLORYELLOW;

通达信黑马营三星板主图指标公式

 

相关文章