在线检测未来函数

通达信偷不到就抢主图指标公式

来源:Internet,编辑:股旁网,2013-08-20

N:=14;
M:=1.5;
TR1:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
UP:=(H+L)/2+MA(TR1,N)*M;
DN:=(H+L)/2-MA(TR1,N)*M;
L1:=REF(UP,BARSLAST(UP<=REF(UP,1)));
L2:=LLV(UP,N*1.5);
LL:=IF(L2!=REF(L2,1) AND L1<REF(L1,1),L1,IF(L1=L2,L1,L2));
S1:=BARSLAST(CROSS(0.5,UP=LL))+1;
S2:=CROSS(COUNT((CROSS(C,LL) OR CROSS(C,REF(LL,2))) AND UP>LL,S1),0.5);
A6:=BARSLAST(S2);
B6:=BARSLAST(CROSS(HHV(DN,A6+1),C));
BY:=CROSS(B6,A6);
SL:=CROSS(A6,B6);
偷抢:IF(B6>A6,HHV(DN,BARSLAST(BY)+1),LLV(UP,BARSLAST(SL)+1)),COLORGREEN,LINETHICK1;
偷不到就抢:IF(C>=偷抢,偷抢,DRAWNULL),COLORRED,LINETHICK2;
CYC:=CYC(5);
DRAWTEXT(ISLASTBAR,CYC*0.97,' 线下持币'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,CYC,'------------'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,CYC*1.03,' 线上持股'),COLORYELLOW;

通达信偷不到就抢主图指标公式

 

相关文章