在线检测未来函数

通达信五股通道主图指标公式

来源:Internet,编辑:股旁网,2013-08-21

N:=9;
重心:=IF(C>(H+L+C)/3,(H*0.618+L*0.382)*0.382,(H*0.382+L*0.618)*0.382)+(O+C)/2*0.618;
均价:=AMOUNT/(VOL*100);
折价:=if(INDEXC=C,(重心+2*c)/3,(重心+均价+c)/3);
DX:(9*折价+8*REF(折价,1)+7*REF(折价,2)+6*REF(折价,3)+5*REF(折价,4)+4*REF(折价,5)+3*REF(折价,6)+2*REF(折价,7)+REF(折价,8))/45,COLORWHITE;
QX:=(折价+2*REF(折价,1)+3*REF(折价,2)+4*REF(折价,3)+5*REF(折价,4)+6*REF(折价,5)+7*REF(折价,6)+8*REF(折价,7)+9*REF(折价,8))/45;
DN:=ema(DX,N);
QN:=ema(QX,N);
DN4:ema(dX,N*4),COLOR00CCCC;
QN4:ema(QX,N*4),COLORAAAA00;
DN8:EMA(DX,N*8),COLORRED;
QN8:EMA(Qx,N*8),COLORGREEN;
DN16:EMA(DX,N*16),COLORMAGENTA;
QN16:EMA(Qx,N*16),COLORFF0080;
CC:=ABS(折价-(DN8+((DN8-QN8)/QN8)))/(DN4+(DN4-QN4)/QN4);
DD:=DMA(折价,CC);
天地通道:=(1+27/1000)*DD,COLORWHITE;
扳道:((天地通道)+(DX+(DN+(DN-QN)/QN)+(DN4+(DN4-QN4)/QN4)+(DN8+(DN8-QN8)/QN8))/4)/2,COLOR6600FF,DOTLINE;
八:=eMA(扳道,2);
七:=eMA(八,2);
六:=eMA(七,2);
五:=eMA(六,2);
if(折价>扳道,扳道,drawnull),COLOR6600FF;
if(扳道>五,五,drawnull),COLORCYAN;
if(扳道>六,六,drawnull),COLORGRAY;
if(扳道>七,七,drawnull),COLORGRAY;
if(扳道>八,八,drawnull),COLORGRAY;

通达信五股通道主图指标公式

 

相关文章