在线检测未来函数

飞狐股海观潮指标公式

来源:Internet,编辑:股旁网,2013-08-23

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
M3:=MA(OBV,3);
KLINE(REF(OBV,1),MAX(M3,OBV),MIN(M3,OBV),OBV,0);
MAV1:SMA(TMA(OBV,0.618,0.382),3,1),ColorFFFFFF,linethick1;
MAV2:MA(MAV1,8),ColorFFFF00,linethick1;
MAV3:MA(MAV2,8),ColorFF00FF,linethick1;
MAV4:MA(MAV3,8),Color00FFFF,linethick1;
kh:=max(MAV4,max(MAV1,max(MAV2,MAV3)))=MAV4;
kl:=min(MAV4,min(MAV1,min(MAV2,MAV3)))=MAV1;
partline(OBV>MA(OBV,5) AND REF(OBV<MAV1,1)and kh and kl,OBV) ,CIRCLEDOT,COLORFF99DD,linethick5;
partline( OBV>MA(OBV,5) AND REF(OBV<MAV1,1)and kh and kl,OBV),CROSSDOT,COLORFFFFFF,linethick3;
STICKLINE(REF(REF(OBV,1)<OBV AND MIN(M3,OBV)<REF(OBV,1),1) AND REF(OBV,1)>OBV,REF(OBV,1),OBV,7.5,0),COLOR00FFFF;
STICKLINE(REF(REF(OBV,1)>OBV AND MAX(M3,OBV)>REF(OBV,1),1) AND REF(OBV,1)<OBV ,REF(OBV,1),OBV,3,0),COLOR00FF00;
STICKLINE(REF(REF(OBV,1)>OBV AND MAX(M3,OBV)>REF(OBV,1),1) AND REF(OBV,1)<OBV AND REF(OBV,1)<MAV2,REF(OBV,1),OBV,7.5,0),COLOR00FF00;

飞狐股海观潮指标公式

 

相关文章