在线检测未来函数

通达信金牛回头选股指标公式

来源:Internet,编辑:股旁网,2013-08-24

周期:=10;
均线:=5;
角度:=20;
P:=周期;
H1:=IF(H=HHV(H,P),H,DRAWNULL);
H2:=CONST(BARSLAST(H1!=DRAWNULL));
H3:=CONST(IF(H2=0,L,REF(L,H2)));
H4:=CONST(REF(BARSLAST(L<H3),H2+1)+H2+1);
H5:=CONST(IF(H4=0,L,REF(L,H4)));
H6:=CONST(REF(BARSLAST(L<H5),H4+1)+H4+1);
止损:=IF(CURRBARSCOUNT<=H2+21,CONST(IF(H6=0,L,REF(L,H6))),
DRAWNULL),COLORYELLOW; {顾比倒数止损位。}
AA:=C>止损; {收盘价在止损位之上,即回踩不破止损位。}
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
MA200:=MA(C,200);
MA20JD:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416;
MA30JD:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
MA60JD:=ATAN((MA60/REF(MA60,1)-1)*100)*180/3.1416;
MA120JD:=ATAN((MA120/REF(MA120,1)-1)*100)*180/3.1416;
MA200JD:=ATAN((MA200/REF(MA200,1)-1)*100)*180/3.1416;
MAN:=MA(C,均线);
BB:=MA20>MA30 AND MA30>MA60 AND MA60>MA120 AND MA120>MA200; {大五线多头排列。}
CC:=CROSS(MAN,L) AND C>MAN; {回踩均线:N日均线穿过当日K线且当日收盘价在N日均线之上,即回踩而不破位。}
DD:=(MIN(OPEN,CLOSE)-LOW)/(HIGH-LOW)>(1/3); {筛选条件:K线下引线必须占K线振幅的1/3以上,尽可能筛选出股价回踩止跌的股票。}
EE:=MA20JD>角度 AND MA120JD>0 AND MA200JD>0; {通过调节均线角度,控制支撑力度。}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26); {要求:MACD位于0轴上方,行情处于多头市场。}
DEA:=EMA(DIF,9);
FF:=BARSLASTCOUNT(DIF>0 AND DEA>0);
XG:AA AND BB AND CC AND DD AND EE AND FF;

通达信金牛回头选股指标公式

 

相关文章