在线检测未来函数

通达信股市风云指标公式

来源:Internet,编辑:股旁网,2013-08-29

WW0:=WINNER(C/1.0382)*100;
WW1:=(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*100-30;
WW2:=SMA(WW1,5,1);
WW3:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
WW4:=SMA(WW3,5,1);
WW6:=WW4-WW2;
WW7:=SMA(WW0,5,1);
乾:IF(WW6>6,WW6,1),LINETHICK2,COLORYELLOW;
坤:1-乾,LINETHICK2,COLORYELLOW;
八:IF(WW7>6,WW7,1),LINETHICK2,COLORWHITE;
卦:1-八,LINETHICK2,COLORWHITE;
VBR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VBR2:=SMA(VBR1,3,1);
VBR3:=SMA(VBR2,4,1)-10;
VBR4:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
VBR5:=SMA(VBR4,3,1);
VBR6:=SMA(VBR5,4,1)-90;
阳:VBR3,COLORRED,LINETHICK1;
阴:VBR6,COLOR00FF00,LINETHICK1;
RSV:=(((CLOSE - LLV(LOW,6)) / (HHV(HIGH,6) - LLV(LOW,6))) * 100);
K:=(POW(SMA(RSV,2,1),5) / POW(10,8));
D:=(POW(SMA(RSV,2,1),5) / POW(10,10));
天:((K+D)/2),COLORMAGENTA,LINETHICK1;
地:(0-天),COLORCYAN,LINETHICK1;
SAT:=(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26);
能:IF(SAT>1,1,SAT)*100,COLORYELLOW,LINETHICK0;
换:V/CAPITAL*100,LINETHICK0;
M5:=MA(C,IF(BARSCOUNT(C)>5,5,0));
M15:=MA(C,IF(BARSCOUNT(C)>15,15,0));
M30:=MA(C,IF(BARSCOUNT(C)>30,30,0));
M60:=MA(C,IF(BARSCOUNT(C)>60,60,0));
A:=IF(M5>=M15,1,0)+IF(M5>=M30,1,0)+IF(M5>=M60,1,0)+IF(M15>=M30,1,0)+IF(M15>=M60,1,0)+IF(M30>=M60,1,0)+IF(M60>=REF(M60,1),1,0);
密码:A,LINETHICK0;
密码个数:IF(A=0,BARSLASTCOUNT(A=0),IF(A=1,BARSLASTCOUNT(A=1),IF(A=2,BARSLASTCOUNT(A=2),IF(A=3,BARSLASTCOUNT(A=3),IF(A=4,BARSLASTCOUNT(A=4),IF(A=5,BARSLASTCOUNT(A=5),IF(A=6,BARSLASTCOUNT(A=6),IF(A=7,BARSLASTCOUNT(A=7),0)))))))),LINETHICK0;
STICKLINE(C>0 AND ISLASTBAR=1,5,100,3,-1),COLORWHITE;
量能≤5:STICKLINE(能<=5 AND ISLASTBAR=1,100,100-能,2,0),COLORRED;
量能5~80:STICKLINE((能>5 AND 能< 80) AND ISLASTBAR=1,100,95-能,2,0),COLOR5290FF;
量能80~97:STICKLINE((能>80 AND 能< 97) AND ISLASTBAR=1,100,102-能,2,0),COLORFFCC00;
量能≥97:STICKLINE(能>=97 AND ISLASTBAR=1,100,105-能,2,0),COLORGREEN;
STICKLINE(C>0 AND ISLASTBAR=1,-5,-70,3,-1),COLORWHITE;
STICKLINE(换<=1 AND ISLASTBAR=1,-70,-60,2,0),COLORCYAN;
STICKLINE(换>1 AND 换<=2 AND ISLASTBAR=1,-60,-50,2,0),COLORGREEN;
STICKLINE(换>2 AND 换<=3 AND ISLASTBAR=1,-50,-40,2,0),COLORYELLOW;
STICKLINE(换>3 AND 换<=5 AND ISLASTBAR=1,-5,-45,2,0),COLORLIMAGENTA;
STICKLINE(换>5 AND 换<=10 AND ISLASTBAR=1,-5,-55,2,0),COLORRED;
STICKLINE(换>10 AND ISLASTBAR=1,-5,-65,2,0),COLORBLUE;
DRAWTEXT(换<3 AND ISLASTBAR=1,-80,'<3'),COLORCYAN;
DRAWTEXT(换>=3 AND 换<=5 AND ISLASTBAR=1,-80,'<=5>=3'),COLORGREEN;
DRAWTEXT(换>5 AND 换<=7 AND ISLASTBAR=1,-80,'<=7>5'),COLORYELLOW;
DRAWTEXT(换>7 AND 换<=10 AND ISLASTBAR=1,-80,'<=10>7'),COLORLIMAGENTA;
DRAWTEXT(换>10 AND 换<=20 AND ISLASTBAR=1,-80,'<=20>10'),COLORRED;
DRAWTEXT(换>20 AND ISLASTBAR=1,-80,'>20'),COLORBLUE;
{均线密码}
DRAWTEXT(A=0,110,'0'),COLORWHITE;
DRAWTEXT(A=1,110,'1'),COLORC0C0C0;
DRAWTEXT(A=2,110,'2'),COLOR00FFFF;
DRAWTEXT(A=3,110,'3'),COLOR00FF00;
DRAWTEXT(A=4,110,'4'),COLOR999900;
DRAWTEXT(A=5,110,'5'),COLORFF0000;
DRAWTEXT(A=6,110,'6'),COLORFF00FF;
DRAWTEXT(A=7,110,'7'),COLORRED;
VAR6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-
LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV
(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR8:=VAR6<REF(VAR7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR8 AND COUNT(VAR8,30)=1,-100,'★吸筹'),COLORRED;
{底部加量能平台}
VARM2:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VARM3:=SMA(SMA(VARM2,9,4),9,4)/7.777777;
VARM4:=EMA(VARM3,5);
VARM5:=3*VARM3-2*VARM4;
AAM:=CROSS(VARM5,VARM3) AND VARM3<1.7777777 AND C>O;
VARM6:=(2*CLOSE+HIGH+LOW)/4;
VARM7:=LLV(LOW,13);
VARM8:=HHV(HIGH,13);
VARM9:=EMA((VARM6-VARM7)/(VARM8-VARM7)*100,13);
VARMA:=EMA(0.667*REF(VARM9,1)+0.333*VARM9,2);
DRAWTEXT(AAM,50,'↗'),COLORMAGENTA;
DRAWTEXT(VOL=HHV(VOL,20),80,'♂'),COLORRED;
STICKLINE(REF(VBR3,1)<VBR3,VBR3,REF(VBR3,1),10,0),COLORRED;
STICKLINE(REF(VBR3,1)>VBR3,VBR3,REF(VBR3,1),5,0),COLORGREEN;
STICKLINE(REF(VBR6,1)>VBR6,VBR6,REF(VBR6,1),10,0),COLORRED;
STICKLINE(REF(VBR6,1)<VBR6,VBR6,REF(VBR6,1),5,0),COLORGREEN;
{量变}
换手率:=((V/CAPITAL)*100);
DRAWTEXT((((V/REF((SUM(V,5)/5),1))>=2) AND (换手率>1)),-80,'L'),COLORLIBLUE;

通达信股市风云指标公式

 

相关文章