在线检测未来函数

通达信杰出均线主图指标公式

来源:Internet,编辑:股旁网,2013-08-28

趋势线:MA(CLOSE,13),COLORRED,LINETHICK3;
中线:=MA(CLOSE,33),LINETHICK1;
中趋势线:MA(CLOSE,55),LINETHICK1,COLORGRAY;
年线:MA(CLOSE,250),LINETHICK1,COLORLIGRAY,POINTDOT;
涨:IF(短趋势线>REF(短趋势线,1),短趋势线,DRAWNULL),COLORRED,LINETHICK3;
平:=IF(短趋势线=REF(短趋势线,1),短趋势线,DRAWNULL),COLOR00FFFF,LINETHICK3;
跌:IF(短趋势线<REF(短趋势线,1),短趋势线,DRAWNULL),COLORGREEN,LINETHICK3;
上极限:=((C-REF(MA(CLOSE,20),1))/20+短趋势线)*1.20;
DRAWTEXT(CROSS(CLOSE,上极限),H*1.02,'减仓'),COLORGREEN;
DRAWTEXT(CROSS(CLOSE,MA(C,13)) AND 短趋势线<REF(短趋势线 ,1) AND 短趋势线<中趋势线 ,H*1.02,'减仓'),COLORGREEN;
DRAWTEXT(CROSS(短趋势线,C) AND INDEXC>MA(INDEXC,13) AND 短趋势线>REF(短趋势线 ,1) AND V<REF(V,1) AND 短趋势线>中趋势线 ,L*0.97,'买入'),COLORRED;
STICKLINE(CROSS(短趋势线,C) AND 短趋势线>REF(短趋势线 ,1) AND V<REF(V,1) AND 短趋势线>中趋势线 ,L,L*0.99,2,0),COLORYELLOW;
VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
DRAWTEXT(VAR1>9 AND V<REF(V,1) AND FILTER(VAR1<REF(VAR1,1),5),H*1.02,'洗盘'),COLORYELLOW;
DRAWTEXT(VAR1>9 AND V>REF(V,1) AND FILTER(VAR1<REF(VAR1,1),5),H*1.02,'减仓'),COLORGREEN;
DRAWTEXT(VAR1>20 AND FILTER(VAR1<REF(VAR1,1),5),H*1.06,'卖出'),COLORYELLOW;
VAR2:=HHV(VAR1>20,10);
DRAWTEXT(FILTER(VAR1<-9 AND VAR1>REF(VAR1,1),18) AND V>REF(V,1),L*0.98,'反弹'),COLORRED;
DRAWTEXT(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),L*0.95,'抄底'),COLORYELLOW;
DRAWTEXT(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),H*1.1,'危险'),COLORYELLOW;
VAR12:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR12) * VOL);
VAR7:=((VAR4 / VAR12) * VOL);
VAR8:=((VAR5 / VAR12) * VOL);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND 短趋势线>REF(短趋势线 ,1) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)) ,L*0.98,'主力介入'),COLORMAGENTA;

通达信杰出均线主图指标公式

 

相关文章