在线检测未来函数

通达信十九波段指标公式

来源:Internet,编辑:股旁网,2013-08-30

VAR6:=(REF(LOW,1) * 0.9);
VAR7:=(LOW * 0.9);
VAR8:=(((VAR7 * VOL) + (VAR6 * (CAPITAL - VOL))) / CAPITAL);
VAR9:=EMA(VAR8,30);
VARA:=(CLOSE - REF(CLOSE,1));
VARB:=MAX(VARA,0);
VARC:=ABS(VARA);
VARD:=((SMA(VARB,7,1) / SMA(VARC,7,1)) * 100);
VARE:=((SMA(VARB,13,1) / SMA(VARC,13,1)) * 100);
VARF:=BARSCOUNT(CLOSE);
VAR10:=((SMA(MAX(VARA,0),6,1) / SMA(ABS(VARA),6,1)) * 100);
VAR11:=((((0 - 200) * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60))) + 100);
VAR12:=(((CLOSE - LLV(LOW,15)) / (HHV(HIGH,15) - LLV(LOW,15))) * 100);
VAR13:=SMA(((SMA(VAR12,4,1) - 50) * 2),3,1);
VAR14:=(((INDEXC - LLV(INDEXL,14)) / (HHV(INDEXH,14) - LLV(INDEXL,14))) * 100);
VAR15:=SMA(VAR14,4,1);
VAR16:=SMA(VAR15,3,1);
VAR17:=(((HHV(HIGH,30) - CLOSE) / CLOSE) * 100);
VAR18:=(((((((((VAR10 <= 25) AND (VAR11 < (0 - 95))) AND (VAR17 > 20)) AND (VAR13 < (0 - 30))) AND (VAR16 < 30)) AND ((VAR9 - CLOSE) >= (0 - 0.25))) AND (VARD < 22)) AND (VARE < 28)) AND (VARF > 50));
VAR19:=(((HIGH + LOW) + CLOSE) / 3);
VAR1A:=((VAR19 - MA(VAR19,14)) / (0.015 * AVEDEV(VAR19,14)));
VAR1B:=((VAR19 - MA(VAR19,70)) / (0.015 * AVEDEV(VAR19,70)));
VAR1C:=IF(((((VAR1A >= 150) AND (VAR1A < 200)) AND (VAR1B >= 150)) AND (VAR1B < 200)),10,0);
VAR1D:=IF(((((VAR1A <= (0 - 150)) AND (VAR1A > (0 - 200))) AND (VAR1B <= (0 - 150))) AND (VAR1B > (0 - 200))),(0 - 10),VAR1C);
VAR1E:=(((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100);
VAR1F:=REVERSE(VAR1E);
VAR20:=SMA(VAR1E,3,1);
VAR21:=SMA(VAR20,3,1);
VAR22:=SMA(VAR21,3,1);
VAR25:=(((HHV(HIGH,14) - CLOSE) / (HHV(HIGH,14) - LLV(LOW,14))) * 100);
VAR26:=SMA(VAR25,15,1);
VAR27:=SMA(VAR26,15,1);
VAR28:=COST(10);
VAR29:=(((CLOSE - VAR28) / VAR28) * 100);
VAR2A:=COUNT((VAR29 < (0 - 2.05)),3);
注意:IF(((VAR2A >= 3) AND (PWINNER(5,CLOSE) < 2)),10,0),LINETHICK1,COLORFFCC99;
先出:STICKLINE(CROSS(5,注意),0,30,3,0),COLORCC99FF;
VAR2B:=IF(CROSS(VAR18,0.5),60,0);
锁住:STICKLINE(CROSS(SMA(VAR27,15,1),85),0,75,3,1),COLOR6666FF;
VAR2C:=(((CROSS(((SMA(MAX((CLOSE - ((CLOSE + REF(CLOSE,1)) / 2)),0),5,1) / SMA(ABS((CLOSE - ((CLOSE + REF(CLOSE,1)) / 2))),5,1)) * 100),((CLOSE + REF(CLOSE,1)) / 2)) AND ((((CLOSE - REF(CLOSE,36)) / REF(CLOSE,36)) * 100) < (0 - 10))) AND ((HHV(HIGH,40) * 0.8) > LLV(LOW,5))) AND (SMA((((HHV(HIGH,9) - CLOSE) / (HHV(HIGH,9) - LLV(LOW,9))) * 100),3,1) > 80));
VAR2D:=(((CLOSE - OPEN) / OPEN) * 100);
VAR2E:=REF(CLOSE,1);
VAR2F:=((SMA(MAX((CLOSE - VAR2E),0),6,1) / SMA(ABS((CLOSE - VAR2E)),6,1)) * 100);
VAR30:=(COUNT((VAR2F < 20),20) >= 1);
VAR31:=IF(((VAR2D > 9) AND VAR30),60,0);
牵手:STICKLINE(((VAR2B OR VAR31) OR (VAR2C * 60)),0,40,2,0),COLOR66CCFF;
VARI2:=((((HIGH + LOW) + OPEN) + (2 * CLOSE)) / 5);
VARI3:=REF(VARI2,1);
VARI4:=((SMA(MAX((VARI2 - VARI3),0),10,1) / SMA(ABS((VARI2 - VARI3)),10,1)) * 100);
VA1:=3;
VA2:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
启动:IF(CROSS(VA2,VA1),35,0);
买点:IF((VA2 <= 3),15,0);
补仓:IF((VA2 < 5),20,0);
VR1:=(HHV(HIGH,9) - LLV(LOW,9));
VR2:=(HHV(HIGH,9) - CLOSE);
VR3:=(CLOSE - LLV(LOW,9));
VR4:=(((VR2 / VR1) * 100) - 70);
VR5:=(((CLOSE - LLV(LOW,60)) / (HHV(HIGH,60) - LLV(LOW,60))) * 100);
VR6:=((((2 * CLOSE) + HIGH) + LOW) / 4);
VR7:=SMA(((VR3 / VR1) * 100),3,1);
VR8:=LLV(LOW,60);
VR9:=(SMA(VR7,3,1) - SMA(VR4,9,1));
VR10:=IF((VR9 > 100),(VR9 - 100),0);
VRA:=HHV(HIGH,60);
防线B:=EMA((((VR6 - VR8) / (VRA - VR8)) * 100),8);
B1:=EMA(防线B,5);
LL:=REF(CLOSE,1);
MM:=((SMA(MAX((CLOSE - LL),0),6,1) / SMA(ABS((CLOSE - LL)),6,1)) * 100);
高位:IF(CROSS(80,MM),60,100),COLORFFCC66;
趋势:B1,COLORYELLOW,LINETHICK2;
守仓:STICKLINE(((防线B - B1) > 0),防线B,B1,4,0),COLORRED;
空仓:STICKLINE(((防线B - B1) < 0),防线B,B1,4,1),COLORBLUE;
V1:=(MA(((100 * (CLOSE - LLV(CLOSE,34))) / (HHV(HIGH,34) - LLV(LOW,34))),5) - 20);
V5:=(((HIGH + LOW) + CLOSE) / 3);
V6:=((V5 - MA(V5,10)) / (0.015 * AVEDEV(V5,10)));
V7:=((V5 - MA(V5,30)) / (0.015 * AVEDEV(V5,30)));
V8:=IF(((((V6 >= 150) AND (V6 < 200)) AND (V7 >= 150)) AND (V7 < 200)),10,0);
V9:=IF(((((V6 <= (0 - 150)) AND (V6 > (0 - 200))) AND (V7 <= (0 - 150))) AND (V7 > (0 - 200))),(0 - 10),V8);
多方:=IF((V1 > 0),V1,0);
预警:(IF((((V7 >= 200) AND (V6 >= 150)) OR CROSS(65,多方)),15,IF(((V7 <= (0 - 200)) AND (V6 <= (0 - 150))),(0 - 15),V9)) + 50),COLORFFFF00;
CC1:=REF(CLOSE,1);
CC2:=((SMA(MAX((CLOSE - CC1),0),6,1) / SMA(ABS((CLOSE - CC1)),6,1)) * 100);
卖出:=CROSS(80,CC2);
STICKLINE(卖出,50,60,4,2),COLORFFFF00;

通达信十九波段指标公式

 

相关文章