在线检测未来函数

通达信纯金MACD指标公式

来源:Internet,编辑:股旁网,2013-08-31

DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);
DEA:EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,4,1),COLORWHITE;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,4,0 ),COLOR00aaff;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,3.3,0 ),COLOR00bbff;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,2.2,0 ),COLOR00ccff;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,1.65,0 ),COLOR00ddff;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,1.1,0 ),COLOR00eeff;
STICKLINE(MACD<ref(MACD,1)and MACD>0,0,MACD,0.55,0 ),COLOR00ffff;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,4 ,0 ),COLOR0000aa;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,3.3 ,0 ),COLOR0011bb;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,2.2,0 ),COLOr0022cc;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,1.65 ,0 ),COLOR0033dd;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,1.1 ,0 ),COLOR0044ee;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,0.55 ,0 ),COLOR0055ff;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,4,0 ),COLOraa00bb;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,3.3 ,0 ),COLORbb11bb;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,2.2,0 ),COLOrcc22bb;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,1.65,0 ),COLORdd33bb;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,1.1,0 ),COLORee44bb;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,0.55 ,0 ),COLORff55bb;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,4,0 ),COLOrffaa00;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,3.3 ,0 ),COLORffbb11;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,2.2,0 ),COLOrffcc22;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,1.65 ,0 ),COLORffdd33;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,1.1 ,0 ),COLORffee44;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,0.55 ,0 ),COLORffff55;
if(diff<0,diff,0),colorred,linethick1;
if(diff<0,0,diff),coloryellow,linethick1;
if(diff<dea,diff,dea),COLOR00ff00,linethick1;
if(diff>dea,dea,dea),COLORwhite,linethick1;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,-0.18,6,0),COLORYELLOW;
DRAWTEXT(低位金叉,-0.1,' 低位金叉'),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-0.18,6,0),ColorFF00FF;
DRAWICON(二次金叉,dea*1.04,13) ;
DRAWTEXT(二次金叉,-0.1,' 二次金叉'),ColorFF00FF;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.13,6,0),Color00FF00;
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,linethick2;
DRAWTEXT(底背离,0.1,' 底背离'),Color00FF00;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,linethick2;

通达信纯金MACD指标公式

 

相关文章