在线检测未来函数

通达信超级波段系数指标公式

来源:Internet,编辑:股旁网,2013-09-12

BBB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
杀盘:=IF(CLOSE>OPEN,BBB*(HIGH-LOW),IF(CLOSE<OPEN,BBB*((HIGH-OPEN)+
(CLOSE-LOW)),VOL/2)),COLORRED;
血盘:=IF(CLOSE>OPEN,0-BBB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,
0-BBB*(HIGH-LOW),0-VOL/2)),COLORGREEN;
VAR1:=MA(杀盘,3);
VAR2:=MA(杀盘,4);
VAR3:=MA(杀盘,5);
VAR4:=MA(杀盘,6);
VAR5:=MA(杀盘,7);
VAR6:=MA(杀盘,8);
VAR7:=MA(杀盘,9);
VAR8:=MA(杀盘,10);
VAR9:=MA(杀盘,11);
VAR10:=MA(杀盘,12);
VAR11:=MA(杀盘,13);
VAR12:=MA(杀盘,14);
VAR13:=MA(杀盘,15);
VAR14:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(VAR1,VAR2),
VAR3),VAR4),VAR5),VAR6),VAR7),VAR8),VAR9),VAR10),VAR11),VAR12),VAR13);
VAR15:=MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(VAR1,VAR2),
VAR3),VAR4),VAR5),VAR6),VAR7),VAR8),VAR9),VAR10),VAR11),VAR12),VAR13);
VAR16:=杀盘/VAR15>=2;
VAR17:=VAR14/杀盘;
VAR18:=BARSLAST(VAR16); {放量以来的天数}
VAR19:=REF(杀盘,VAR18); {最近一次放量的大小}
VAR20:=(VAR18+1)*VAR19/SUM(杀盘,VAR18+1);
坑大小正:HHV(VAR20,1),COLORRED;
VAR1A:=MA(血盘,3);
VAR2A:=MA(血盘,4);
VAR3A:=MA(血盘,5);
VAR4A:=MA(血盘,6);
VAR5A:=MA(血盘,7);
VAR6A:=MA(血盘,8);
VAR7A:=MA(血盘,9);
VAR8A:=MA(血盘,10);
VAR9A:=MA(血盘,11);
VAR10A:=MA(血盘,12);
VAR11A:=MA(血盘,13);
VAR12A:=MA(血盘,14);
VAR13A:=MA(血盘,15);
VAR14A:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(VAR1A,VAR2A),
VAR3A),VAR4A),VAR5A),VAR6A),VAR7A),VAR8A),VAR9A),VAR10A),VAR11A),VAR12A),VAR13A);
VAR15A:=MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(VAR1A,VAR2A),
VAR3A),VAR4A),VAR5A),VAR6A),VAR7A),VAR8A),VAR9A),VAR10A),VAR11A),VAR12A),VAR13A);
VAR16A:=血盘/VAR15A>=2;
VAR17A:=VAR14A/血盘;
VAR18A:=BARSLAST(VAR16A); {放量以来的天数}
VAR19A:=REF(血盘,VAR18A); {最近一次放量的大小}
VAR20A:=(VAR18A+1)*VAR19A/SUM(血盘,VAR18A+1);
坑大小负:HHV(VAR20A,1),COLORGREEN;
准备线:2,DOTLINE;

通达信超级波段系数指标公式

 

相关文章