在线检测未来函数

通达信庄家底势指标公式

来源:Internet,编辑:股旁网,2013-09-12

开盘:OPEN,LINETHICK0;
收盘:CLOSE,LINETHICK0;
最高:HIGH,LINETHICK0;
最低:LOW,LINETHICK0;
50,DOTLINE;
STICKLINE(CLOSE>REF(CLOSE,1), 最高, 最低,0.5,1), COLORRED;
STICKLINE(CLOSE<REF(CLOSE,1), 最高, 最低,0.5,1), COLORGREEN;
STICKLINE(CLOSE>OPEN, 最高, 最低, 0.5, 1), COLORRED;
STICKLINE(CLOSE<OPEN, 最高, 最低, 0.5, 1), COLORGREEN;
STICKLINE(CLOSE>OPEN, 收盘, 开盘, 1, 0), COLORRED;
STICKLINE(CLOSE<OPEN, 收盘, 开盘, 1, 0), COLORGREEN;
STICKLINE(CLOSE=OPEN AND CLOSE>=REF(CLOSE, 1), 收盘, 收盘, 1, 0), COLORRED;
STICKLINE(CLOSE=OPEN AND CLOSE<=REF(CLOSE, 1), 收盘, 收盘, 1, 0), COLORGREEN;
STICKLINE(CLOSE=OPEN AND CLOSE>=REF(CLOSE, 1), 最高, 最低, 0.5, 1), COLORRED;
STICKLINE(CLOSE=OPEN AND CLOSE<=REF(CLOSE, 1), 最高, 最低, 0.5, 1), COLORGREEN;

STICKLINE(CLOSE>REF(CLOSE,1), 100-最高, 100-最低,0.5,1), COLORRED;
STICKLINE(CLOSE<REF(CLOSE,1), 100-最高, 100-最低,0.5,1), COLORGREEN;
STICKLINE(CLOSE>OPEN, 100-最高, 100-最低, 0.5, 1), COLORRED;
STICKLINE(CLOSE<OPEN, 100-最高, 100-最低, 0.5, 1), COLORGREEN;
STICKLINE(CLOSE>OPEN, 100-收盘, 100-开盘, 1, 0), COLORRED;
STICKLINE(CLOSE<OPEN, 100-收盘, 100-开盘, 1, 0), COLORGREEN;
STICKLINE(CLOSE=OPEN AND CLOSE>=REF(CLOSE, 1), 100-收盘, 100-收盘, 1, 0), COLORRED;
STICKLINE(CLOSE=OPEN AND CLOSE<=REF(CLOSE, 1), 100-收盘, 100-收盘, 1, 0), COLORGREEN;
STICKLINE(CLOSE=OPEN AND CLOSE>=REF(CLOSE, 1), 100-最高, 100-最低, 0.5, 1), COLORRED;
STICKLINE(CLOSE=OPEN AND CLOSE<=REF(CLOSE, 1), 100-最高, 100-最低, 0.5, 1), COLORGREEN;
收价:=10000*CLOSE/INDEXC;
高价:=10000*HIGH/INDEXH;
低价:=10000*LOW/INDEXL;
开价:=10000*OPEN/INDEXO;
STICKLINE(收价>=开价 ,开价 ,收价,1,0 ),COLORRED;
STICKLINE(收价>=开价,高价,收价,0 ,0 ),COLORRED;
STICKLINE(收价>=开价 ,开价,低价,0 ,0 ),COLORRED;
STICKLINE(开价>=收价,收价,开价,1,0 ),COLORCYAN;
STICKLINE(开价>=收价,收价,低价,0 ,0 ), COLORCYAN;
STICKLINE(开价>=收价 ,开价,高价,0 ,0 ), COLORCYAN;
STICKLINE(收价>=开价 ,100-开价 ,100-收价,1,0 ),COLORRED;
STICKLINE(收价>=开价,100-高价,100-收价,0 ,0 ),COLORRED;
STICKLINE(收价>=开价 ,100-开价,100-低价,0 ,0 ),COLORRED;
STICKLINE(开价>=收价,100-收价,100-开价,1,0 ),COLORCYAN;
STICKLINE(开价>=收价,100-收价,100-低价,0 ,0 ), COLORCYAN;
STICKLINE(开价>=收价 ,100-开价,100-高价,0 ,0 ), COLORCYAN;
VAR1:=REF(OPEN,1);
VAR2:=MA(MAX(OPEN-VAR1,0),5)/MA(ABS(OPEN-VAR1),5)*100;
VAR3:=REF(CLOSE,1);
VAR4:=MA(MAX(CLOSE-VAR3,0),5)/MA(ABS(CLOSE-VAR3),5)*100;
VAR5:=REF(HIGH,1);
VAR6:=MA(MAX(HIGH-VAR5,0),5)/MA(ABS(HIGH-VAR5),5)*100;
VAR7:=REF(LOW,1);
VAR8:=MA(MAX(LOW-VAR7,0),5)/MA(ABS(LOW-VAR7),5)*100;
STICKLINE(VAR4<VAR2,VAR2,VAR4,1,0),COLORGREEN , ;
STICKLINE(VAR4>VAR2,VAR2,VAR4,1,0),COLORRED , ;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR8>VAR4,VAR4,VAR6,0.5,1),COLORRED , ;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR8<VAR4,VAR4,VAR6,0.5,1),COLORRED ,;
STICKLINE(VAR4>VAR2 AND VAR6<VAR8 AND VAR6>VAR4,VAR4,VAR8,0.5,1),COLORRED , ;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR6<VAR2,VAR2,VAR8,0.5,1),COLORRED , ;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR6>VAR2,VAR2,VAR8,0.5,1),COLORRED , ;
STICKLINE(VAR4>VAR2 AND VAR6<VAR8 AND VAR8<VAR2,VAR2,VAR6,0.5,1),COLORRED , ;
STICKLINE(VAR4>VAR2 AND VAR6<VAR8 AND VAR8>VAR2,VAR2,VAR6,0.5,1),COLORRED , ;
STICKLINE(VAR4<VAR2 AND VAR6>VAR8 AND VAR6<VAR4,VAR4,VAR8,0.5,1),COLORGREEN , ;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR8<VAR4,VAR4,VAR6,0.5,1),COLORGREEN , ;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR6>VAR4,VAR4,VAR8,0.5,1),COLORGREEN , ;
STICKLINE(VAR4<VAR2 AND VAR6>VAR8 AND VAR6<VAR4,VAR2,VAR8,0.5,1),COLORGREEN ,;
STICKLINE(VAR4<VAR2 AND VAR6>VAR8 AND VAR6>VAR4,VAR2,VAR8,0.5,1),COLORGREEN , ;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR8<VAR2,VAR2,VAR6,0.5,1), COLORGREEN , ;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR8>VAR2,VAR2,VAR6,0.5,1),COLORGREEN , ;

通达信庄家底势指标公式

 

相关文章