在线检测未来函数

大智慧KDJ监控主图指标公式

来源:Internet,编辑:股旁网,2013-09-22

本公式特色: 1、可以直观观察kdj走势。 2、通过反推预先给出KDJ、RSI临界值的股价,可预先知道股价的风险区域,方便判断与逃顶。 3、通过KDJ、RSI、CCI三个指标监控及反推,给出三种提示逃顶卖出信号: 第一、J值大于80而且小于昨天,同时R值大于60而且小于昨天,同时C值大于90而且小于昨天,虽然盘中看还在继续上行,但技术上显示有回调要求,公式会给出卖的提示; 第二、C\J\R3个指标都已经超过临界值(CCI大于100,J大于90,R大于70),其中有任何一个指标小于昨天,虽然当日股价尚未回调,亦表示有回调要求,公式会给出应卖的提示; 第三、监控当天盘中指标,股价在高位,三指标处于高点,且当天任一指标超过临界以上后回落到临界点或以下(例如长上影线),表示有较强的回调意愿。这个监控的意义,在于对当天盘中冲高回落提出警示,有利于在收盘前可做出决策。 4、根据指标低位临界点的原理,给出买入信号。

j1:=(100);
RSI预设:=80;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),LINETHICK0,PRECIS1;
D:SMA(K,3,1),LINETHICK0,PRECIS1;
J:3*K-2*D,LINETHICK0,PRECIS1;
RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));
RSV2:=(RSV1-0.5)/5*EMA(C,21);
RSVK:=SMA(RSV2,3,1);
RSVD:=SMA(RSVK,3,1);
RSVJ:=RSVK*3-RSVD*2;
Kj:RSVK+EMA(C,21),COLORWHITE,LINETHICK1,PRECIS0;
Dj:RSVD+EMA(C,21),COLORYELLOW,LINETHICK1;
Jj:RSVJ+EMA(C,21),COLORRED;
LC := REF(CLOSE,1);
Aa1:=SMA(MAX(CLOSE-LC,0),6,1);
Bb1:=SMA(ABS(CLOSE-LC),6,1);
RSI:aa1/bb1*100,LINETHICK0,PRECIS1;
TYP := (HIGH + LOW + CLOSE)/3;
cci:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0,PRECIS1;
买:=(cci<-80 and cci>ref(cci,1)) and (rsi<40 and rsi>ref(rsi,1)) and (j<20) and j>0;
DRAWTEXT(买,L-0.01,'●买'),COLORMAGENTA;
卖:=(cci>90 and cci<ref(cci,1)) and (rsi>60 and rsi<ref(rsi,1)) and (j>80 and j<ref(j,1));
卖21:=ref(cci,1)>100 and ref(rsi,1)>70 and ref(j,1)>90 and (cci>ref(cci,1) or rsi>ref(rsi,1) or j>ref(j,1));
卖22:=cci>100 and j>90 and rsi>70 and (cci<ref(cci,1) or rsi<ref(rsi,1) or j<ref(j,1));
卖2:=卖21 or 卖22;
DRAWTEXT(卖,h+0.1,'●'),colorgreen;
DRAWTEXT(卖2,h+0.05,'●'),Coloryellow;
{j反推}
j11:=j;
j昨:=ref(j,1);
jx:=if(j1=-50,j11,if(j1=-49,j昨,j1));
xxx:=((9/7*jx-2*ref(k,1)+12/7*ref(d,1))/100)*(HHV(HIGH,9)-LLV(LOW,9))+LLV(LOW,9);
YCJ:IF(C>LC,(REF(Aa1,1)*(9-1)-REF(Bb1,1)*(9-1)*RSI预设/100)/(RSI预设/100-1)+LC,LC+REF(Bb1,1)*(9-1)-REF(Aa1,1)*(9-1)/(RSI预设/100)),LINETHICK0,PRECIS1;
rYCJ:=(YCJ-ref(c,1));
rre:=(80-ref(rsi,1));
rzz:=rre/rycj;
rh:=h-ref(c,1);
rhh:rzz*rh+ref(rsi,1),LINETHICK0,PRECIS1;
jxxx:=(xxx-ref(c,1));
jje:=(100-ref(j,1));
jzz:=jje/jxxx;
jhh:jzz*rh+ref(j,1),LINETHICK0,PRECIS1;
xh:=(rhh>70 and jhh>100) or (rhh>80 and jhh>90);
jrhh:=xh and (j<jhh or rsi<rhh);
DRAWTEXT(jrhh,h+0.1,'◆'),colorred;
DRAWTEXTREL(450,30,'预设J值=100 J临界股价: '+NUMTOSTRN(xxx ,2)),LINETHICK1,Coloryellow;
DRAWTEXTREL(450,90,'预设R值=80 R临界股价: '+NUMTOSTRN(YCJ ,2)),LINETHICK1,Coloryellow;
DRAWTEXTABS(10,10,'图示:●=必卖'),LINETHICK1,colorgreen;
DRAWTEXTABS(10,30,'图示:●=指标应卖 '),LINETHICK1,Coloryellow;
DRAWTEXTABS(10,50,'图示:◆=指标超卖 '),LINETHICK1,colorred;

大智慧KDJ监控主图指标公式

 

相关文章