在线检测未来函数

大智慧牛牛主图指标公式

来源:Internet,编辑:股旁网,2013-09-06

MA4:(SUM(CLOSE,4)+c)/5;
MA5:MA(CLOSE,5),COLORFFFFFF,PRECIS2,LAYER0,DOTLINE;
A1:=SUMBARS(VOL,CAPITAL);
CMA:=IF(CAPITAL>0,SUM(AMOUNT,A1)/SUM(VOL,A1)/100,EMA(CLOSE,120));
换手价:CMA,LINETHICK2,precis2;{100%换手平均成本价};
CC:=(SMA(C+O,3,1)+(H+L)*4)/10;
CG:EMA(Sma(CC,5,1),5),PRECIS2,colorffcc66;
FL:hhv(CG,2),PRECIS2,colorffcc66;
FL1:(FL+CG)/2,PRECIS2,colorffcc66;
FS:if(CG<FL,(CG-(FL-CG)),FL),PRECIS2,colorffFF00;
PARTLINE(FS, CG=FS),colorFF6600,LINETHICK3;
PARTLINE(FS, (FS-REF(FS,1))/REF(FS,1)>32.5/10000),color00DDDD,LINETHICK3;
生命线:=MA5-CG;
生命:生命线/CLOSE*100,linethick0,Color00FFFF,PRECIS2;
生命日:"玄机.MA5#DAY",linethick1,ColorFF8000,PRECIS2;
连高:LAST(生命>REF(生命,1)),LINETHICK0,COLOR0030FF,PRECIS0;
角度:ATAN((CG/REF(CG,1)-1)*100)*57.3,precis0,linethick0;
流通盘:=CAPITAL/1000000;
TY:=C;
HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);
A2:=REF(C,BARSLAST(HD));
B2A:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
顶:IF(T1,A2,A2),COLOR00FF00,POINTDOT,LINETHICK2;
STICKLINE(T1,A2,A2,9,0),COLOR00FF00;
底:IF(T2,B2A,B2A),COLORFF00FF,POINTDOT,LINETHICK2;
STICKLINE(T2,B2A,B2A,9,0),COLORFF00FF;
W:=BARSLAST(DISPSTATUS=1);
低涨:(H/LLV(LOW,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;
高跌:(L/HHV(HIGH,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;
天日:BARSLAST(L=LLV(LOW,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
天:BARSLAST(H=HHV(HIGH,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
{以下设置提示文字部分}
DRAWTEXTREL(15,180,'■低点至今日最高点上涨:'+NUMTOSTRN(低涨,2)+'% '+NUMTOSTRN(天日,0)+'天'),COLORFF50FF;
DRAWTEXTREL(15,260,'■高点至今日最低点下跌:'+NUMTOSTRN(高跌,2)+'% '+NUMTOSTRN(天,0)+'天'),COLORFF50FF;
DRAWTEXTREL(15,340,'■目前可见K线:'+NUMTOSTRN(W+1,0)+'天'),COLOR00FF00;
{放在主图左上角的个股基本信息}
DRAWTEXTABS(10,10,'【流通盘】'+流通盘+'亿'+' 【板块】'+BKNAME),ColorC08000,LINETHICK2;
DRAWTEXTABS(10,30,'【行业】'+SelfString('行业')+' 【地域】'+SelfString('地域')
+' 【每股收益】'+FINANCE2(33)/FINANCE2(35)/10+'元'),Color8080FF,LINETHICK2;

大智慧牛牛主图指标公式

 

相关文章