在线检测未来函数

通达信DDX成交K线指标公式

来源:Internet,编辑:股旁网,2013-09-06

DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);
N:=5;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:SMA(V2*240/FROMOPEN*0.9,5,1);
V10:SMA(V5,5,1);
V20:SMA(V10,5,1);
DRAWKLINE(V2*1.01,REF(V2,1),REF(V2,1)*0.99,V2);
当日DDX:DDX,NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND C>=REF(C,1),REF(V2,1),MAX(V2*0.98,V2*240/FROMOPEN*0.8),3,-1),COLORLIMAGENTA;
STICKLINE(CURRBARSCOUNT=1 AND C<REF(C,1),REF(V2,1),MIN(V2,V2*240/FROMOPEN*0.8),3,-1),COLORLIGREEN;
DRAWTEXT(CROSS(V2,REF(V2,1)*1.2) AND LONGCROSS(CLOSE,REF(C,1)*1.025,4) AND DDX/REF(MA(DDX,5),1)>2,REF(V2,1),'★'),COLORMAGENTA;

通达信DDX成交K线指标公式

 

相关文章