在线检测未来函数

通达信大资金流向K线主图指标公式

来源:Internet,编辑:股旁网,2013-09-06

MA21:=MA(CLOSE,21)COLORLIRED,CROSSDOT;
UB:=MA21+2*STD(CLOSE,21)COLORLIRED,LINETHICK2;
LB:=MA21-2*STD(CLOSE,21)COLORLIRED,LINETHICK2;
DRAWBAND(UB,RGB(0,80,60),LB,RGB(0,0,0));
IF(MA21>REF(MA21,5),MA21,DRAWNULL)COLORLIRED,CROSSDOT;
IF(MA21<REF(MA21,5),MA21,DRAWNULL)COLORCYAN,CROSSDOT;
{大资金流向K线}
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
大资金流向:(超B+大B)-(超S+大S)COLORYELLOW,NODRAW;
STICKLINE(大资金流向<0,O,C,2,0),COLORFF3300;
STICKLINE(大资金流向<0,O,C,1.2,0),COLORFF6600;
STICKLINE(大资金流向<0,O,C,0.5,0),COLORFF9900;
STICKLINE(大资金流向>0,O,C,2,0),COLOR0066FF;
STICKLINE(大资金流向>0,O,C,1.2,0),COLOR099FFF;
STICKLINE(大资金流向>0,O,C,0.5,0),COLOR00FFFF;
连续流入天:BARSLASTCOUNT(大资金流向>0)NODRAW COLORYELLOW;
十三日内流入天:COUNT(大资金流向>0,13)NODRAW,COLORRED;
五日净流入:SUM(大资金流向,5),NODRAW,COLORMAGENTA;
重心:=(C+H+L+O)/4;
STICKLINE(重心>0,重心,重心,2,-1),COLORWHITE;
涨幅:=(C-REF(C,1))/REF(C,1)*100;
历史涨幅:SUM(涨幅,0),NODRAW;
一周涨幅:历史涨幅-REF(历史涨幅,5),NODRAW;
一月涨幅:历史涨幅-REF(历史涨幅,20),NODRAW;
一季涨幅:历史涨幅-REF(历史涨幅,60),NODRAW;
半年涨幅:历史涨幅-REF(历史涨幅,120),NODRAW;
一年涨幅:历史涨幅-REF(历史涨幅,240),NODRAW;
MA5:MA(CLOSE,5),LINETHICK2;
趋势:EMA(EMA(EMA(EMA(EMA( C,55),2),2),2),2),COLORYELLOW LINETHICK2;

通达信大资金流向K线主图指标公式

 

相关文章