在线检测未来函数

通达信新量能成交量指标公式

来源:Internet,编辑:股旁网,2013-09-06

用法: 1、成交量超过135均线,为成交量放大。 2、成交量上绿下红,为诱空信号,一般出现在上升通道,出现此形态可多买股票(类似殷保华理论线上阴线买)。   成交量上红下绿,为诱多信号,一般出现在下降通道,出现此形态尽量少买股票(类似殷保华理论线下阳线卖)。   成交量全部红的,为上升通道趋势走好,但是要注意顶部信号的出现。   成交量全部绿的,为下降通道趋势走坏,但是要主要底部信号的出现。 3、当成交量中第一次出现黄色量能柱时为买入点, 黄色量能柱持续期间持股。当成交量中第一次失去黄色量能柱时为卖出点, 无黄色量能柱期间空仓。

{135均线}
VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,5)LINETHICK2,COLORFFFFFF;
MAVOL2:MA(VOLUME,135),LINETHICK2,COLORYELLOW;
{主力量能}
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,COLORSTICK;
STICKLINE(DIF>DEA,0,VOL,3,0),COLORRED;
STICKLINE(DIF<DEA,0,VOL,3,0),COLORGREEN;
N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
STICKLINE(J>D,VOL/2,VOL,3,0),COLORRED;
STICKLINE(J<D,VOL/2,VOL,3,0),COLORGREEN;
{量能潮}
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),VVOL,0,-1,-1),COLOR00C0C0;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,OBV3,2,0),COLORYELLOW;

通达信新量能成交量指标公式

 

相关文章