在线检测未来函数

大智慧金牛K线主图指标公式

来源:Internet,编辑:股旁网,2013-10-06

N:=13;
M:=3;
MA5:EMA(CLOSE,5),COLORWHITE;
MA9:MA(CLOSE,9),COLORCYAN,LINETHICK1;
MA20:MA(CLOSE,20),COLORMAGENTA;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORRED;
JC:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;
参考价:SMA(JC,5,1), CIRCLEDOT,COLORGREEN;
参考价:=SMA(JC,5,1);
价:IF(C>=参考价,参考价,参考价*0.98 ), CIRCLEDOT,COLOR0000FF;
价:=IF(C>=参考价,参考价,参考价*0.98 );
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORGREEN;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
VAR2:=CLOSE*VOL;
MID:=EMA((EMA(VAR2,3)/EMA(VOL,3)+EMA(VAR2,6)/EMA(VOL,6)+EMA(VAR2,12)/EMA(VOL,12)+EMA(VAR2,24)/EMA(VOL,24))/4,N);
趋势线:MID;
MID2:=MID*1.01;
SDN:=MID*0.94;
日期:=1050609;
refdate:REF(C,BARSLAST(DATE=日期));
SUP:1.06*MID,COLORBLUE;
SUP:=1.06*MID;
VAR4:=EMA(CLOSE,9);
B9:=COUNT(HIGH>SUP,5);
VAR1:=MID;
PARTLINE(VAR1,VAR1>REF(VAR1,1),RGB(255,0,0),VAR1<REF(VAR1,1),RGB(0,255,0),1,RGB(0,0,255)),LINETHICK2;
PARTLINE(VAR1,VAR1<REF(VAR1,1),RGB(0,255,0),VAR1>REF(VAR1,1),RGB(0,0,255),1,RGB(0,255,0)),LINETHICK2;

大智慧金牛K线主图指标公式

 

相关文章