在线检测未来函数

通达信突破均线抓牛主图指标公式

来源:Internet,编辑:股旁网,2013-10-06

VAR1Y:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2Y:=(REF(VAR1Y,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3Y:=(REF(VAR2Y,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4Y:=(REF(VAR3Y,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5Y:=(REF(VAR4Y,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6Y:=(REF(VAR5Y,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7Y:=(REF(VAR6Y,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8Y:=(REF(VAR7Y,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9Y:=(REF(VAR8Y,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARAY:=(REF(VAR9Y,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARBY:=(REF(VARAY,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARCY:=(REF(VARBY,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARDY:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VAREY:=(REF(VARDY,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARFY:=(REF(VAREY,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10Y:=(REF(VARFY,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11Y:=(REF(VAR10Y,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12Y:=(REF(VAR11Y,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13Y:=(REF(VAR12Y,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14Y:=(REF(VAR13Y,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15Y:=(REF(VAR14Y,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16Y:=(REF(VAR15Y,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17Y:=(REF(VAR16Y,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18Y:=(REF(VAR17Y,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19Y:=((REF(VARDY OR VAREY OR VARFY OR VAR10Y OR VAR11Y OR VAR12Y OR VAR13Y OR VAR14Y OR VAR15Y OR VAR16Y OR VAR17Y OR VAR18Y,1)) AND VAR1Y);
VAR1AY:=((REF(VAR1Y OR VAR2Y OR VAR3Y OR VAR4Y OR VAR5Y OR VAR6Y OR VAR7Y OR VAR8Y OR VAR9Y OR VARAY OR VARBY OR VARCY,1)) AND VARDY);
红色持股:=VAR1Y OR VAR2Y OR VAR3Y OR VAR4Y OR VAR5Y OR VAR6Y OR VAR7Y OR VAR8Y OR VAR9Y OR VARAY OR VARBY OR VARCY,COLOR0000FF,NODRAW;
青色观望:=IF((VARDY OR VAREY OR VARFY OR VAR10Y OR VAR11Y OR VAR12Y OR VAR13Y OR VAR14Y OR VAR15Y OR VAR16Y OR VAR17Y OR VAR18Y),1,0);
品红离场:=VAR1AY,COLORFF99FF,NODRAW;
短买:=VAR19Y,COLOR33AACC,NODRAW;
急速超跌:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)*100<-12,COLORFFFFFF,NODRAW;
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(红色持股,CLOSE,O,4.8,0),COLOR0000AA;
STICKLINE(红色持股,CLOSE,O,3.5,0),COLOR0000CC;
STICKLINE(红色持股,CLOSE,O,2.5,0),COLOR0000EE;
STICKLINE(红色持股,CLOSE,O,1.5,0),COLOR0000FF;
STICKLINE(青色观望,CLOSE,O,4.8,0),COLORAAAA00;
STICKLINE(青色观望,CLOSE,O,3.5,0),COLORCCCC00;
STICKLINE(青色观望,CLOSE,O,2.5,0),COLOREEEE00;
STICKLINE(青色观望,CLOSE,O,1.5,0),COLORFFFF00;
CO:=(C-O);
STICKLINE(急速超跌,O,C-CO/2,3.0,1),COLOR999999;
STICKLINE(急速超跌,O,C-CO/2,2.0,0),COLORAAAAAA;
STICKLINE(急速超跌,O,C-CO/2,0.9,1),COLORCCCCCC;
STICKLINE(急速超跌,O,C-CO/2,0.0,0),COLOREEEEEE;
STICKLINE(短买,O,O+CO/3,3.0,1),COLOR338888;
STICKLINE(短买,O,O+CO/3,2.0,0),COLOR33AAAA;
STICKLINE(短买,O,O+CO/3,0.9,1),COLOR33CCCC;
STICKLINE(短买,O,O+CO/3,0,0),COLOR33EEEE;
STICKLINE(品红离场,O,O+CO/3,3.0,1),COLOR880088;
STICKLINE(品红离场,O,O+CO/3,2.0,0),COLOR880088;
STICKLINE(品红离场,O,O+CO/3,0.9,1),COLORAA00AA;
STICKLINE(品红离场,O,O+CO/3,0.05,0),COLOREE00EE;
日线:MA(C,4),LINETHICK2;
五日线1:=MA(C,7),LINETHICK2;
二十线:MA(C,17),LINETHICK2;
九十线:MA(C,60),LINETHICK2;
涨:IF(二十线>REF(二十线,1),二十线,DRAWNULL),COLOR00009C,LINETHICK3;
平:=IF(二十线=REF(二十线,1),二十线,DRAWNULL),LINETHICK2;
跌:IF(二十线<REF(二十线,1),二十线,DRAWNULL),COLORGREEN,LINETHICK2;
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,;
VR02:=DIF>DEA AND MACD>0;
VAR1:=EMA(CLOSE,2)-EMA(CLOSE,89)*1;
VAR2:=EMA(VAR1,30)*1;
VAR3:=2*(VAR1-VAR2)*10*1;
VAR4:=POW(VAR3,3)*0.1+POW(VAR3,2)*1;
VAR5:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR6:=EMA(VAR5*0.97,3)*1;
VAR7:=(HIGH+LOW+CLOSE)/3*1;
VAR8:=(VAR7-MA(VAR7,12))/(0.015*AVEDEV(VAR7,12))*1;
VAR9:=IF(VAR3>0.015,VAR4,0)/45*1;
VAR10:=EMA(CLOSE,2)-EMA(CLOSE,150);
增量资金:=VAR9;
VAR11:=EMA(VAR10,100);
VAR12:=2*(VAR10-VAR11);
VAR13:=POW(VAR12,3)*0.1+POW(VAR12,1);
VAR1A:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR1B:=EMA(VAR1A*0.97,3);
VAR1C:=(HIGH+LOW+CLOSE)/3;
VAR1D:=(VAR1C-MA(VAR1C,14))/(0.015*AVEDEV(VAR1C,14));
主力资金:=IF(VAR12>0.1,VAR13,0)*5,LINETHICK2,COLORYELLOW;
VR03:=增量资金>0 AND 主力资金>0;
M1:=5;
M2:=60;VOLUME:=VOL;
MAVOL1:=MA(VOLUME,M1);
MAVOL2:=MA(VOLUME,M2);
VR04:=MAVOL1>MAVOL2;
买点:=VR02 AND VR03 AND VR04;
BT01:=REF(MACD,1)<0 AND MACD>0;
BT02:=REF(MACD,2)<0 AND MACD>0;
BT03:=REF(MACD,3)<0 AND MACD>0;
BT123:=BT01 OR BT02 OR BT03;
VR1:=CROSS(五日线,二十线) AND 二十线>REF(二十线,1) AND 二十线<九十线 AND 买点;
DRAWICON(VR1,二十线*0.99,25),COLOR00FFFF,LINETHICK8;
DRAWTEXT(VR1,二十线*0.94,'基础进入'),COLORFF00FF,LINETHICK8;
VR1X:=CROSS(五日线,五日线1) AND C>O AND H/C<1.025 AND C>REF(C,1);
DRAWICON(VR1X,五日线1*0.98,25),COLOR00FFFF,LINETHICK2;
DRAWTEXT(VR1X,五日线1*0.95,'进入'),COLOR00FFFF,LINETHICK2;
VR2:=CROSS(五日线,九十线) AND 买点;
DRAWICON(VR2,九十线*0.98,26),COLOR00FFFF,LINETHICK8;
DRAWTEXT(VR2,九十线*0.935,'再加点儿'),COLOR00FFFF,LINETHICK2;
VR3:=CROSS(二十线,九十线) AND 买点;
DRAWICON(VR3 AND C>O*0.99,九十线*0.99,27),COLOR00FFFF,LINETHICK8;
DRAWTEXT(VR3 AND C>O*0.99,九十线*0.97,'赌全部'),COLORRED,LINETHICK8;
VR4:=CROSS(五日线,二十线) AND 二十线>REF(二十线,1) AND 二十线>九十线 AND 买点 AND BT123;
DRAWICON(VR4,二十线*0.99,24),COLOR00FFFF,LINETHICK8;
DRAWTEXT(VR4,二十线*0.95,'赌性质'),COLORRED,LINETHICK8;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),0.8,0);
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),0.8,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;

通达信突破均线抓牛主图指标公式

 

相关文章