在线检测未来函数

通达信效果超好组合指标公式

来源:Internet,编辑:股旁网,2013-10-06

估:=(2*CLOSE+LOW+HIGH)/4;
界:=SLOPE(CLOSE,21)*20+CLOSE;
文:=EMA(估,40)*0.85;
快线:=EMA(CLOSE,3),COLORDDDDDD;
慢线:EMA(界,55),COLOR3300FF;
风险区:EMA(估,40)*1.15,POINTDOT,COLORFF33FF;
庄家出货区:EMA(估,55)*1.3,POINTDOT,COLORYELLOW;
机构成本区:EMA(估,55),COLORWHITE,POINTDOT;
庄家成本区:(机构成本区+文)/2,POINTDOT,COLOR00FF33;
N:=5;
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1:=(EMA(VAR1,3)+EMA(VAR1,6)+EMA(VAR1,12)+EMA(VAR1,24))/4;
A2:=EMA(A1,2);
A31:=EMA(A2,2);
A41:=EMA(A31,2);
A5:=EMA(A41,2);
A6:=EMA(A5,2);
A7:=EMA(A6,2);
{*100是为了确保小数点后面四舍五入后相等}
十字星:(ABS(C-O)/(H-L)<0.11 OR C=O) AND C>A1 AND L<A1,NODRAW;
数字相近1:=INTPART(A1*100)=INTPART(A2*100) ;
数字相近2:=INTPART(A2*100)=INTPART(A31*100) ;
数字相近3:=INTPART(A31*100)=INTPART(A41*100) ;
数字相近4:=INTPART(A41*100)=INTPART(A5*100) ;
数字相近5:=INTPART(A5*100)=INTPART(A6*100) ;
数字相近6:=INTPART(A6*100)=INTPART(A7*100) ;
皈依:十字星 AND 数字相近1 AND 数字相近2
AND 数字相近3 AND 数字相近4 AND 数字相近5 AND 数字相近6,NODRAW;
DRAWTEXT(皈依,L*0.98,'↖㊣转向'),COLORRED;
{未来顶底,注意有未来,只是判断趋势,没有它无没判断}
DING:=MAX(O,C);{实顶}
DI:=MIN(O,C);{实底}
SDING:=CURRBARSCOUNT>=N AND DING=HHV(DING,N) AND DING>REFX(HHV(DING,N-1),N-1);
{DRAWLINE(SDING,DING,REF(SDING,1),REF(DING,1),1),COLORDB9370;}
XDING:=CURRBARSCOUNT>=N AND H=HHV(H,N) AND H>REFX(HHV(H,N-1),N-1);
DRAWLINE(XDING,H,REF(XDING,1),REF(H,1),1),COLORGREEN,DOTLINE;
SDI:=CURRBARSCOUNT>=N AND DI=LLV(DI,N) AND DI<REFX(LLV(DI,N-1),N-1);
{DRAWLINE(SDI,DI,REF(SDI,1),REF(DI,1),1),COLORE47833;}
XDI:=CURRBARSCOUNT>=N AND L=LLV(L,N) AND L<REFX(LLV(L,N-1),N-1);
{DRAWLINE(XDI,L,REF(XDI,1),REF(L,1),1),COLORMAGENTA,DOTLINE;}
A188:=EMA(C,14)COLORWHITE,LINETHICK1;
A1X:=(A188-REF(A188,1))/REF(A188,1)*100,NODRAW;
ZF:=100*(C-REF(C,1))/REF(C,1);
STICKLINE((ZF>3.5 AND ZF<=5),O,C,1,0),COLORYELLOW;
STICKLINE((ZF>5),O,C,1,0),COLORRED;
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;
DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;
HD88:=FILTER(BACKSET(FILTER(REF(H,10)=HHV(H,2*10+1),10),10+1),10);
LD88:=FILTER(BACKSET(FILTER(REF(L,10)=LLV(L,2*10+1),10),10+1),10);
A99:=REF(H,BARSLAST(HD88));
B:=REF(L,BARSLAST(LD88));
T188:=BARSLAST(HD88)<BARSLAST(LD88) AND NOT(HD88);
T288:=BARSLAST(HD88)>BARSLAST(LD88) AND NOT(LD88);
波顶:IF(T188,A99,A99),COLORWHITE,POINTDOT,LINETHICK2;
波底:IF(T288,B,B),COLORWHITE,POINTDOT,LINETHICK2;
A10304:=REF(HIGH,3)=HHV(HIGH,2*3+1);
B10304:=FILTER(A10304,3);
C10304:=BACKSET(B10304,3+1);
D10304:=FILTER(C10304,3);{高点}
A20304:=REF(LOW,3)=LLV(LOW,2*3+1);
B20304:=FILTER(A20304,3);
C20304:=BACKSET(B20304,3+1);
D20304:=FILTER(C20304,3);{低点}
E10304:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E20304:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H10304:=(D10304 AND NOT(D20304 AND E10304>=E20304)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
H20304:=D10304 AND NOT(D20304 AND E10304>=E20304);
L10304:=D20304 AND NOT(D10304 AND E10304=E20304);
X10304:=REF(BARSLAST(H10304),1)+1;
F10304:=BACKSET(H10304 AND COUNT(L10304,X10304)>0,LLVBARS(IF(L10304,LOW,10000),X10304));
G10304:=F10304>REF(F10304,1);
I10304:=BACKSET(G10304,2); LD0304:=I10304>REF(I10304,1);{过滤后低点}
L20304:=LD0304 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X20304:=REF(BARSLAST(L20304),1)+1;
F2:=BACKSET(L20304 AND COUNT(H20304,X20304)>0,HHVBARS(IF(H20304,HIGH,0),X20304));
G20304:=F2>REF(F2,1);
I2:=BACKSET(G20304,2);
HD0304:=I2>REF(I2,1);{过滤后高点}
J1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HD0304),BARSLAST(LD0304))+1);
J2:=J1>REF(J1,1);
A3:=H;
B3:=REF(H,REF(BARSLAST(HD0304),1)+1)>REF(H,REF(BARSLAST(HD0304),1)+2+REF(BARSLAST(HD0304),REF(BARSLAST(HD0304),1)+2));
D3:=A3 AND B3 AND HD0304;
E3:=BACKSET(D3,REF(BARSLAST(HD0304),1)+2);
HH:=E3>REF(E3,1);{找出全部长期高点}
A4:=L>REF(L,REF(BARSLAST(LD0304),1)+1);
B4:=REF(L,REF(BARSLAST(LD0304),1)+1);
D4:=A4 AND B4 AND LD0304;
E4:=BACKSET(D4,REF(BARSLAST(LD0304),1)+2);
LL:=E4>REF(E4,1);{找出全部长期低点}
H3:=HH OR ISLASTBAR OR BARSCOUNT(C)=1; {后面进行过滤,方法同前。只是不用考虑高低点出现在同一K线}
X3:=REF(BARSLAST(H3),1)+1;
F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
G3:=F3>REF(F3,1); I3:=BACKSET(G3,2);
LZ:=I3>REF(I3,1); {长期低点,也可供引用}
L4:=LZ OR ISLASTBAR OR BARSCOUNT(C)=1;
X4:=REF(BARSLAST(L4),1)+1;
F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
G4:=F4>REF(F4,1); I4:=BACKSET(G4,2);
HZ:=I4>REF(I4,1);{长期高点,也可供引用}
K1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HZ),BARSLAST(LZ))+1);
K2:=K1>REF(K1,1);
{最后的长期连线,连在收盘价上}
UU:=BACKSET(ISLASTBAR,BARSLAST(LD0304)+1);VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD0304),1)+2);
XX:=WW>REF(WW,1);
UU2:=BACKSET(ISLASTBAR,BARSLAST(HD0304)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD0304),1)+2);
XX20304:=WW2>REF(WW2,1);
前一低:=REF(L,BARSLAST(VV)),COLOR99FF66,LINETHICK2;
前二低:=REF(L,BARSLAST(XX)),COLORFF66FF,LINETHICK2;
前一高:=REF(H,BARSLAST(VV2)),COLOR99FF66,LINETHICK2;
前二高:=REF(H,BARSLAST(XX20304)),COLORFF66FF,LINETHICK2;
短高:=REF(H,BARSLAST(VV2));短低:=REF(L,BARSLAST(VV));
短比:= (C-短低)/(短高-短低),NODRAW;{以下语句为三角形部分}
底:=REF(L,BARSLAST(VV)),COLORRED,LINETHICK2;
顶:=REF(H,BARSLAST(VV2)),COLORGREEN,LINETHICK2;
{下迭三角形:藍色三角形畫完介入}
STICKLINE(VV,顶,底,0,0),COLORFF6633,LINETHICK3;{}
DRAWLINE(VV2,H,VV,L,0),COLORFF6633,LINETHICK3;{斜}
DRAWLINE(VV2,H,VV,顶,0),COLORFF6633,LINETHICK3;
A177:=EMA(C,14)COLORWHITE,LINETHICK1;
A1X77:=(A177-REF(A177,1))/REF(A177,1)*100,NODRAW;
IF(A1X77>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X77,0))+1),DRAWNULL),COLORBLUE,LINETHICK1;

通达信效果超好组合指标公式

 

相关文章