在线检测未来函数

飞狐小桥均线主图指标公式

来源:Internet,编辑:股旁网,2013-10-09

input:P1(5,1,10000),P2(10,1,10000),P3(20,1,10000),P4(30,1,10000);
GD2:=REF(LOW,1);
GD3:=(((SMA(ABS((LOW - GD2)),3,1) * ma(GD2,5)) / SMA(MAX((LOW - GD2),0),3,1)) * 100);
GD4:=EMA(IF((CLOSE * 1.2),((GD3 * 10) / ma(GD2,5)),(GD3 / (ma(GD2,5) * 10))),3);
小桥A:=(ma(((((((4.5 * CLOSE) + (1.5 * LOW)) + (1.5 * OPEN)) + (1.5 * HIGH)) / 9)),10));
GD5:=LLV(LOW,30);
GD6:=HHV(GD4,30);
GD7:=IF(LLV(LOW,58),1,0);
GD8:=((EMA(IF((LOW <= GD5),((GD4 + (GD6 * 2)) / 2),0),3) / 618) * GD7);
DDC:=REF((((GD8 > 1) AND (COUNT((GD8 > 1),10) = 1)) AND (LLV((CLOSE / REF(CLOSE,1)),5) = (CLOSE / REF(CLOSE,1)))),1);
小桥B:=(ma((((((4.5 * CLOSE) + (1.5 * LOW)) + (1.5 * OPEN)) + (1.5 * HIGH)) / 9),20));
小桥C:=MA(小桥B,10);
小桥D:=MA(小桥B,40);
VAR11:=((COUNT((VOL > MAX(MA(VOL,5),MA(VOL,10))),6) > 1) AND (COUNT((CLOSE > REF(CLOSE,1)),6) > 2));
VAR1:=(((((((小桥B > 小桥C) AND (小桥A > REF(小桥A,1))) = 1) AND (小桥D < (1.1 * 小桥C))) AND REF(NOT(((小桥B > 小桥C) = 1)),1)) AND IF((CLOSE >= REF(CLOSE,1)),((VOL > (1.5 * MA(VOL,10))) AND (VOL >= (0.9 * REF(VOL,1)))),(((VOL < MA(VOL,10)) AND (COUNT((VOL > (1.5 * MAX(MA(VOL,5),MA(VOL,10)))),3) > 0)) AND (CLOSE > MIN(REF(CLOSE,1),REF(CLOSE,2)))))) AND VAR11);
VAR2:=(((((COUNT(CROSS(小桥A,小桥B),3) = 1) AND REF((COUNT((小桥B > REF(小桥B,1)),5) = 0),1)) AND (小桥A >= REF(小桥A,1))) AND ((CLOSE >= 小桥A) OR (CLOSE >= 小桥C))) AND VAR11);
MA1:MA(CLOSE,P1),colorFFFFFF;
MA2:MA(CLOSE,P2),colorFFFF;
MA3:MA(CLOSE,P3),colorFF00FF;
MA4:MA(CLOSE,P4),colorFF00;
VARA:=(((((((((((((((((MA(CLOSE,5) / REF(MA(CLOSE,5),2)) > 1.018) AND ((SUM(VOL,3) / FINANCE(7)) > 4)) AND (COUNT((CLOSE > REF(CLOSE,1)),3) >= 2)) AND (COUNT((HIGH > REF(HIGH,1)),3) >= 2)) AND (ma((CLOSE > REF(CLOSE,1)),1) = 1)) AND (HHV(CLOSE,3) = CLOSE)) AND (HHV(VOL,3) = MAX(VOL,REF(VOL,1)))) AND (COUNT(CROSS(MA(VOL,5),MA(VOL,10)),8) >= 0)) AND (COUNT((VOL > MAX(MA(VOL,5),MA(VOL,10))),3) >= 2)) AND (MAX(SUM(VOL,3),REF(SUM(VOL,3),1)) > REF(HHV(SUM(VOL,3),30),5))) AND ((OPEN / REF(CLOSE,1)) > 1)) AND (HHV((OPEN / REF(CLOSE,1)),3) = (OPEN / REF(CLOSE,1)))) AND ((HIGH - REF(CLOSE,1)) > REF(HHV((HIGH - REF(CLOSE,1)),2),1))) AND (COUNT(((HIGH / REF(CLOSE,1)) > REF((HIGH / REF(CLOSE,1)),1)),4) >= 2)) AND (COUNT(((OPEN < MIN(MIN(MA(CLOSE,5),MA(CLOSE,10)),MIN(MA(CLOSE,20),MA(CLOSE,30)))) AND (CLOSE > MAX(MAX(MA(CLOSE,5),MA(CLOSE,10)),MAX(MA(CLOSE,20),MA(CLOSE,30))))),8) = 1)) AND ((OPEN - REF(CLOSE,1)) > ABS((OPEN - CLOSE))));
AA:=(((((ma((CLOSE > REF(CLOSE,1)),2) = 1) AND (VOL > REF(VOL,1))) AND (COUNT((VOL > MAX(MA(VOL,5),MA(VOL,10))),2) = 2)) AND (COUNT(((OPEN < MIN(MIN(MA(CLOSE,5),MA(CLOSE,10)),MIN(MA(CLOSE,20),MA(CLOSE,30)))) AND (CLOSE > MAX(MAX(MA(CLOSE,5),MA(CLOSE,10)),MAX(MA(CLOSE,20),MA(CLOSE,30))))),2) = 1)) AND (COUNT((CLOSE > (1.01 * REF(CLOSE,1))),2) = 2));
VARAA:=(((COUNT(CROSS(MA(VOL,5),MA(VOL,10)),3) = 1) AND (REF(AA,1) OR AA)) AND (COUNT(((MIN(MIN(MA(CLOSE,5),MA(CLOSE,10)),MIN(MA(CLOSE,20),MA(CLOSE,30))) / MAX(MAX(MA(CLOSE,5),MA(CLOSE,10)),MAX(MA(CLOSE,20),MA(CLOSE,30)))) > 0.98),5) > 0));
VARAAA:=((((((((HHV(VOL,5) = VOL) AND (((HIGH - MAX(OPEN,CLOSE)) / (CLOSE - REF(CLOSE,1))) < 0.36)) AND (((MIN(CLOSE,OPEN) - LOW) / (CLOSE - REF(CLOSE,1))) < 0.36)) AND ("foxfunc@xqb"((VOL > MAX(MA(VOL,5),MA(VOL,10))),1) = 1)) AND (OPEN < MIN(MIN(MA(CLOSE,5),MA(CLOSE,10)),MIN(MA(CLOSE,20),MA(CLOSE,30))))) AND (CLOSE > MAX(MAX(MA(CLOSE,5),MA(CLOSE,10)),MAX(MA(CLOSE,20),MA(CLOSE,30))))) AND ((MIN(MIN(MA(CLOSE,5),MA(CLOSE,10)),MIN(MA(CLOSE,20),MA(CLOSE,30))) / MAX(MAX(MA(CLOSE,5),MA(CLOSE,10)),MAX(MA(CLOSE,20),MA(CLOSE,30)))) > 0.972)) AND (VOL < ((SUM(VOL,3) * 3) / 4)));
DRAWICON((((COUNT(VARAAA,3) > 0) AND (COUNT(VARAA,3) > 0)) AND (COUNT((VAR1 OR VAR2),3) > 0)),REF(LOW,1),1),colorFF;
60日线:MA(CLOSE,60),LINETHICK1,colorFF0000;
DMQ1:=(REF((ma((VOL / MA(VOL,5)),1) > 1.5),1) AND IF(REF((CLOSE < OPEN),1),(OPEN > REF(OPEN,1)),(OPEN > REF(CLOSE,1))));
DMQ2:=(REF((ma((VOL / MA(VOL,5)),1) > 1.5),1) AND IF(REF((CLOSE < OPEN),1),(OPEN > REF(OPEN,1)),(OPEN > REF(HIGH,1))));
DMQ4:=(((REF(DMQ1,1) AND REF((CLOSE < OPEN),1)) AND REF((CLOSE > MA(CLOSE,5)),1)) AND REF((((CLOSE + OPEN) / 2) > MA(CLOSE,5)),1));
DMQA1:=CROSS(小桥A,小桥B);
DMQA2:=CROSS(小桥A,小桥C);
DMQA3:=CROSS(小桥B,小桥C);
DMQA4:=(((COUNT(DMQA1,3) + COUNT(DMQA2,3)) + COUNT(DMQA3,3)) = 3);
DMQA5:=(COUNT(DMQA4,10) = 1);
DMQA6:=REF((COUNT((CLOSE > 小桥C),21) < 5),2);
DMQA7:=(DMQA5 AND DMQA6);
DMQA8:=(((COUNT(CROSS(CLOSE,小桥A),3) + COUNT(CROSS(CLOSE,小桥B),3)) + COUNT(CROSS(CLOSE,小桥C),3)) = 3);
DMQA9:=(DMQA7 AND DMQA8);
DMQ555:=(DMQ2 OR DMQ4);
DMQ5:=(DMQ555 AND DMQA9);
STARTJ:=(BARSTATUS = 1);
STAR0:=NUMTOSTR(FINANCE(0),0);
STAR33:=NUMTOSTR(FINANCE(33),2);
STAR35:=NUMTOSTR(FINANCE(35),2);
STAR40:=NUMTOSTR((FINANCE(40) / FINANCE(1)),2);
STAR18:=NUMTOSTR(FINANCE(18),2);
STAR32:=NUMTOSTR(FINANCE(32),2);
DRAWTEXT(STARTJ,HIGH,('更新时间:' + STAR0)),ALIGN5,SHIFT3,colorE7F5F4;
DRAWTEXT(STARTJ,HIGH,('业绩:' + STAR33)),ALIGN4,SHIFT3,colorFF99CC;
DRAWTEXT(STARTJ,HIGH,(' 每股现金流:' + STAR40)),ALIGN4,SHIFT3,colorFF99CC;
DRAWTEXT(STARTJ,HIGH,(' 每股未分配:' + STAR32)),ALIGN4,SHIFT3,colorFFCCCC;
DRAWTEXT(STARTJ,HIGH,(' 每股公积金:' + STAR18)),ALIGN4,SHIFT3,colorFFCCCC;
DRAWTEXT(STARTJ,HIGH,(' 每股资产:' + STAR35)),ALIGN4,SHIFT3,colorFFCCCC;
DRAWTEXT(VAR1,(LOW - 0.05),'←要动'),colorFFFF;
DRAWTEXT(VAR2,(LOW - 0.05),'←转强'),colorFFFFFF;
DRAWTEXT(VARAAA,(LOW - 0.05),'←要买趁早'),colorFF;
DRAWTEXT(FILTER(VARAA,2),(HIGH + 0.08),'←热身运动'),colorFF00FF;
DRAWTEXT(FILTER(VARA,3),(HIGH - 0.05),'←暴涨可能'),colorFFFF;
DRAWICON(FILTER(DMQ5,1),(HIGH + 0.08),10);
DRAWTEXT(FILTER(DMQ5,1),(HIGH + 0.08),' 小桥\n 黑马'),colorFFFFFF;
DRAWTEXT(DDC,(LOW - 0.05),'短抄'),colorFFFFFF;
短抄:DDC,LINETHICK0;

飞狐小桥均线主图指标公式

 

相关文章