在线检测未来函数

大智慧反向推算MACD指标公式

来源:Internet,编辑:股旁网,2013-10-09

input: short (5,1,20), long(26,1,60),M(9,1,30);
DIFF: EMA(CLOSE, short)-EMA(CLOSE, long ),color0066ff,LINETHICK0,LAYER0;
partline(DIFF,DIFF>=ref(DIFF,1),rgb(255,0,0),DIFF<ref(DIFF,1),rgb(0,255,0)),linethick1;
DEA:EMA(DIFF,M),COLOR00BB00,LINETHICK1,LAYER0;
MACD: (DIFF-DEA)*2,COLORSTICK;
partline(DIFF,DIFF>=ref(DIFF,1),rgb(255,0,0),DIFF<ref(DIFF,1),rgb(0,255,0)),linethick2;
FILLRGN(DIFF,DEA,DIFF>DEA,rgb(255,0,0),DIFF<DEA,rgb(0,255,0)),linethick2;
中轴:0,LAYER0,Coloreeeeee,LINETHICK1;
jcsc:=(M-1)/(M+1)*dea/(1-2/(m+1));{计算出金叉死叉时的Diff值}
dd:=(macd/2+(dea*(m-1)/(M+1)))/(1-2/(m+1));{计算出明日macd=macd时的Diff值}
xx:=(diff*(short+1)*(long+1)-(long+1)*(short-1)*ema(c,short)+(short+1)*(long-1)*ema(c,long))/(2*((long+1)-(short+1)));{计算今日Diff=diff的对应股价}
js:=(jcsc*(short+1)*(long+1)-(long+1)*(short-1)*ema(c,short)+(short+1)*(long-1)*ema(c,long))/(2*((long+1)-(short+1)));{计算金叉死叉的对应股价}
ddd:=(dd*(short+1)*(long+1)-(long+1)*(short-1)*ema(c,short)+(short+1)*(long-1)*ema(c,long))/(2*((long+1)-(short+1)));{计算macd柱体变向时的对应股价};
DRAWTEXTABS(3,0,'DIFF拐头股价:'+numtostrn(xx,2)),ColorFFFFFF,LINETHICK3;
DRAWTEXTABS(175,0,'MACD柱体变向对应股价:'+numtostrn(ddd,2)),Color00A5FF,LINETHICK3;
DRAWTEXTABS(410,0,'金叉死叉对应股价:'+numtostrn(js,2)),COLOR00BB00,LINETHICK3;
PARTLINE(DIFF,CROSS(DIFF,DEA) AND DIFF<-0.2,RGB(255,245,12)),CROSSDOT,LINETHICK5;
PARTLINE(DIFF,CROSS(DIFF,DEA) AND DIFF>0,RGB(252,24,212)),CROSSDOT,LINETHICK5;
PARTLINE(DIFF,CROSS(DIFF,DEA) AND DIFF>-0.2 AND DIFF<0,RGB(200,80,20)),CROSSDOT,LINETHICK7;
PARTLINE(DIFF,CROSS(DEA,DIFF) AND DIFF>0,RGB(125,245,252)),CIRCLEDOT,LINETHICK5;

大智慧反向推算MACD指标公式

 

相关文章

股票公式月点击榜

股票公式年点击榜

股票公式总点击榜