在线检测未来函数

飞狐白沙抓涨停指标公式

来源:Internet,编辑:股旁网,2013-10-11

INPUT:N(1000),TT(2);
流通:FINANCE(7)/10000,LINETHICK0,PRECISION2,colorFFFF00;
系数:=IF(流通>=10,1,IF(流通<10,0.75,0));
门限:=流通*系数/10*N;
主动买入:=SUM(BUYVOL,0);
主动卖出:=SUM(SELLVOL,0);
买卖差:=主动买入-主动卖出;
大单买:=IF(BUYVOL>=门限,BUYVOL,0);
大单卖:=IF(SELLVOL>门限,SELLVOL,0);
大单买入:=SUM(大单买,0);
大单卖出:=SUM(大单卖,0);
小单买入:=主动买入-大单买入;
小单卖出:=主动卖出-大单卖出;
DRAWTEXTEX(DYNAINFO(7),1,20,70,'■ 大单买入: '+NUMTOSTR(大单买入,0)),LINETHICK2,colorFF;
DRAWTEXTEX(DYNAINFO(7),1,300,70,'占:'+NUMTOSTR(FLOOR(大单买入/(主动买入+主动卖出)*100),0)+'%'),LINETHICK2,colorFF;
DRAWTEXTEX(DYNAINFO(7),1,20,130,'■ 大单卖出: '+NUMTOSTR(大单卖,0)),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,300,130,'占:'+NUMTOSTR(FLOOR(大单卖出/(主动买入+主动卖出)*100),0)+'%'),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,190,'■ 小单买入: '+NUMTOSTR(小单买入,0)),LINETHICK2,colorFF00FF;
DRAWTEXTEX(DYNAINFO(7),1,300,190,'占:'+NUMTOSTR(FLOOR(小单买入/(主动买入+主动卖出)*100),0)+'%'),LINETHICK2,colorFF00FF;
DRAWTEXTEX(DYNAINFO(7),1,20,240,'■ 小单卖出: '+NUMTOSTR(小单卖出,0)),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,300,240,'占:'+NUMTOSTR(FLOOR(小单卖出/(主动买入+主动卖出)*100),0)+'%'),LINETHICK2,colorFFFF00;
VARA:=IF(BUYVOL<=REF(ASKVOL(1),1)+REF(ASKVOL(2),1)+REF(ASKVOL(3),1) AND CLOSE>=REF(ASKPRICE(3),1),BUYVOL,0);
上扫单:=SUM(INTPART(IF(VARA>100 AND VARA<500 OR VARA>=500,BUYVOL,0)),0);
VARB:=IF(SELLVOL<=REF(BIDVOL(1),1)+REF(BIDVOL(2),1)+REF(BIDVOL(3),1) AND CLOSE<=REF(BIDPRICE(3),1),SELLVOL,0);
下扫单:=SUM(INTPART(IF(VARB>100 AND VARA<500 OR VARB>=500,SELLVOL,0)),0);
DRAWTEXTEX(DYNAINFO(7),1,20,300,'■ 上扫单: '+NUMTOSTR(上扫单,0)),LINETHICK2,colorFF;
DRAWTEXTEX(DYNAINFO(7),1,20,360,'■ 下扫单: '+NUMTOSTR(下扫单,0)),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,420,'■ 买卖差: '+NUMTOSTR(买卖差,0)),LINETHICK2,colorFF00;
TST:=OPENMINUTES(TIME);
CLOSE=DYNAINFO(7);
总量:=SUM(VOL,TST);
总额:=SUM(AMOUNT,TST);
均价:总额/(总量*100),LINETHICK0;
次数:COUNT(CLOSE>均价,TT),LINETHICK0;
占比:次数/TST*100,LINETHICK0;
分时强势:DRAWICON(CROSS(CLOSE,均价) AND CLOSE>均价 AND 占比>80 AND TST>5,CLOSE*0.99,10);
PK:=VOL*(OPEN+CLOSE+HIGH+LOW)/4;
PK1:=IF(VOL>0,PK/VOL,(OPEN+CLOSE+HIGH+LOW)/4);
C11:=PK1;
A01:=(C11-LLV(C11,75))/(HHV(C11,75)-LLV(C11,75));
A11:=SMA(A01,13,1);
A21:=SMA(A11,13,1);
A31:=3*A11-2*A21;
A41:=2*A31-0.5;
ZS:DYNAINFO(3)*0.92;
K1:=IF(1,C11*(1-(A41-A21)/40),0);
K2:=CROSS(C11,K1) AND CLOSE/REF(CLOSE,1)<1.03 AND SUM(BUYVOL,5)>=3000 AND 主动买入>主动卖出*1.15;
K3:IF(K2,ZS*1.03,ZS),colorFF00;
LB:=SUM(VOL,0)*240/DYNAINFO(38)/BARSCOUNT(CLOSE);
PK:=IF(TIME>=93100,BUYVOL,0);
A1:=CLOSE>=REF(HHV(HIGH,100),1);
A2:=BUYVOL>260 AND SUM(BUYVOL,6)>3600;
A3:=TIME>94000 AND TIME<145000;
A4:=CLOSE/REF(LLV(LOW,1200),1)<=1.07 AND CLOSE>=OPEN;
A5:=BUYVOL>REF(HHV(PK,100),1);
A6:=主动买入>主动卖出*1.18;
DRAWTEXT(LB<3 AND A1 AND A2 AND A3 AND A4 AND A5 AND A6,CLOSE*1.99,'一箭封喉');

飞狐白沙抓涨停指标公式

 

相关文章