在线检测未来函数

通达信自用波段极品指标公式

来源:Internet,编辑:股旁网,2013-10-11

DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);
VAR1:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR2:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
VAR3:=REF(CLOSE,1);
VAR4:((SMA(MAX((CLOSE - VAR3),0),6,1) / SMA(ABS((CLOSE - VAR3)),6,1)) * 100);
VAR5:MAX(VAR4,5);
VAR6:MAX(VAR5,10);
VAR7:MAX(VAR6,20);
VAR8:MAX(VAR7,30);
VAR9:MAX(VAR8,60),COLORGREEN;
VAR10:MAX(VAR9,90);
粘合加速:=CROSS(VAR4,60)*30;
DRAWTEXT(ISLASTBAR,VAR10,' 顶'),COLORYELLOW;
大底:VAR5<VAR6 AND VAR4<5,STICK,COLORRED,LINETHICK2;
DRAWTEXT(大底 ,10,'大'),COLORRED;
DRAWTEXT(大底 ,5,'底'),COLORRED;
中底:VAR6<VAR7 AND VAR4<20 AND VAR4>10,STICK,COLORYELLOW,LINETHICK2;
DRAWTEXT(中底 ,20,'中'),COLORYELLOW;
DRAWTEXT(中底 ,10,'底'),COLORYELLOW;
短底:VAR7<VAR8 AND VAR4<30 AND VAR4>20,STICK,COLORYELLOW,LINETHICK2;
DRAWTEXT(短底 ,30,'短'),COLORYELLOW;
DRAWTEXT(短底 ,20,'底'),COLORYELLOW;
{小底:VAR8<VAR9 AND VAR4<40 AND VAR4>30 AND C>O,STICK,COLORGREEN,LINETHICK2;
DRAWTEXT(小底 ,40,'小'),COLORGREEN;
DRAWTEXT(小底 ,30,'底'),COLORGREEN;}
IF((VAR4=VAR5),VAR5,DRAWNULL),COLORGREEN,LINETHICK2;
IF((VAR4=VAR6),VAR6,DRAWNULL),COLORWHITE,LINETHICK2;
IF((VAR4=VAR7),VAR7,DRAWNULL),COLORYELLOW,LINETHICK2;
IF((VAR4=VAR8),VAR7,DRAWNULL),COLORRED,LINETHICK2;
IF((VAR4=VAR9),VAR9,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF((VAR4=VAR10),VAR10,DRAWNULL),COLORBLUE,LINETHICK2;
TT:=VAR4-REF(VAR4,1);
粘合加速2:(CROSS(VAR4,60) AND TT>15 AND VAR9>60)*30,LINETHICK2,COLORGREEN;
加速:(CROSS(VAR4,80) AND TT>17 )*20,COLORMAGENTA,LINETHICK2;
风险:=CROSS(VAR4,90);
STICKLINE( 风险,风险,20,3,0),COLORFF5500;
STICKLINE( 风险,风险,30,2,0),COLORFF8800;
STICKLINE( 风险,风险,30,1,0),COLORFFAA00;
STICKLINE( 风险,风险,30,0.5,0),COLORFFCC00;
DRAWTEXT(风险,35,'风险'),COLORYELLOW;
顶2:=VAR8<90 AND VAR10<REF(VAR10,1);
DRAWICON(顶2,95,2);
STICKLINE( 顶2,顶2,20,3,0),COLORFF5500;
STICKLINE( 顶2,顶2,30,2,0),COLORFF8800;
STICKLINE( 顶2,顶2,30,1,0),COLORFFAA00;
STICKLINE( 顶2,顶2,30,0.5,0),COLORFFCC00;
DRAWICON(顶2,95,2);
DRAWICON(顶2,10,2);
DRAWTEXT(顶2,35,'清仓'),COLORYELLOW;

通达信自用波段极品指标公式

 

相关文章