在线检测未来函数

通达信波段暴涨主图指标公式

来源:Internet,编辑:股旁网,2013-10-11

N:=20;
M1:=30;
P1:=80;
P2:=100;
VAR11:=(C+H+O+L)/4;
MA1:(REF(CLOSE,2)+REF(CLOSE,1)+O)/3;
卖出:XMA(VAR11,N)*(1+P1/1000),COLORGREEN,LINETHICK2;
买入:XMA(VAR11,M1)*(1-P2/1000),COLORMAGENTA,LINETHICK2;
幅度:100*(卖出-买入)/买入,NODRAW;
MA11:=MA(VAR11,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORMAGENTA;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;
STICKLINE(买入>HIGH,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
中轨:MA(CLOSE,20),COLOR0080FF,LINETHICK2;
反弹: EMA(EMA(EMA(HIGH,5),5),5)*0.95,LINETHICK1;
超跌: EMA(EMA(EMA(HIGH,5),5),5)*0.9,COLORBLUE,LINETHICK1;
XG:=CROSS(买入,反弹);
DRAWICON(XG,OPEN-0.6,9);
DRAWTEXT(XG,(LOW -0.6),'暴涨' ),COLORRED;
XG1:=CROSS(买入,超跌);
DRAWTEXT(XG1,反弹*0.98,'小涨' ),COLORRED;
DRAWTEXT( REF(C,1)>REF(MA1,1) AND C<MA1,C*0.98,'小心' );

通达信波段暴涨主图指标公式

 

相关文章