在线检测未来函数

飞狐分形判势主图指标公式

来源:Internet,编辑:股旁网,2013-10-14

现价:C,POINTDOT,colorffff00;
现量:vol,linethick0,colorgreen;
Var1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
Var2:=CROSS(Var1,0.9);
Var3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
Var4:=CROSS(Var3,0.9);
STICKLINE(Var2,HIGH,HIGH*1.01,5,0),Color00E40E;
STICKLINE(Var4,LOW,LOW*0.99,5,0),Color00E40E;
Var5:=IF(Var2,HIGH,IF(Var4,LOW,0));
POLYLINE(Var5,Var5),Colorff00ff;
Var6:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
Var7:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
Var8:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
Var9:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
VarA:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
VarB:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
坚定:STICKLINE(CROSS(Var6,0.9),HIGH,HIGH*1.01,5,0),Color0000FF;
STICKLINE(CROSS(Var9,0.9),LOW,LOW*0.99,5,0),Color0000FF;
犹豫: STICKLINE(CROSS(Var7,0.9),HIGH,HIGH*1.01,5,0),Color00E5E9;
STICKLINE(CROSS(VarA,0.9),LOW,LOW*0.99,5,0),Color00E5E9;
等待: STICKLINE(CROSS(Var8,0.9),HIGH,HIGH*1.01,5,0),ColorFF4100;
STICKLINE(CROSS(VarB,0.9),LOW,LOW*0.99,5,0),ColorFF4100;
压力: REF(HIGH,BARSLAST(Var2)), POINTDOT,ColorEA91B5;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(Var2)),REF(HIGH,BARSLAST(Var2)),5,0),colorgreen;
支撑: REF(LOW,BARSLAST(Var4)), POINTDOT,Color3791B5;
STICKLINE(CLOSE,REF(LOW,BARSLAST(Var4)),REF(LOW,BARSLAST(Var4)),5,0),coloryellow;
DRAWTEXT(var2,h+0.0818,'压力');DRAWTEXT(var4,l-0.0818,'支撑');

飞狐分形判势主图指标公式

 

相关文章