在线检测未来函数

通达信成交量回调买主图指标公式

来源:Internet,编辑:股旁网,2013-10-15

EMA30:EMA(CLOSE,30),COLORBROWN;
EMA5:=EMA(CLOSE,5);
X2:=EMA5;
X3:=EMA30;
主升:=C>X2 AND C>X3;
主跌:=C<X3;
回调:=C<X2 AND C>X3;
反弹:=C>X2 AND C<X3;
STICKLINE(主升,CLOSE,O,4.8,0),COLOR0000BB;
STICKLINE(主升,CLOSE,O,3,0),COLOR0000CC;
STICKLINE(主升,CLOSE,O,1.5,0),COLOR0000DD;
STICKLINE(主升,CLOSE,O,1,0),COLOR0000EE;
STICKLINE(主升,CLOSE,O,0.5,0),COLOR0000FF;
STICKLINE(主升,H,L,0,0),COLOR0000FF;
STICKLINE(主跌,CLOSE,O,4.8,0),COLOR555500;
STICKLINE(主跌,CLOSE,O,3,0),COLOR888800;
STICKLINE(主跌,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(主跌,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(主跌,CLOSE,O,0.5,0),COLOREEEE00;
STICKLINE(主跌,H,L,0,0),COLOREEEE00;
STICKLINE(回调,O,C,4.8,0),COLORBB4400;
STICKLINE(回调,O,C,3,0),COLORCC5500;
STICKLINE(回调,O,C,1.5,0),COLORDD6600;
STICKLINE(回调,O,C,1,0),COLOREE7700;
STICKLINE(回调,O,C,0.5,0),COLORFF8800;
STICKLINE(回调,H,L,0,0),COLORFF8800;
STICKLINE(反弹,O,C,4.8,0),COLOR0077BB;
STICKLINE(反弹,O,C,3,0),COLOR0099CC;
STICKLINE(反弹,O,C,1.5,0),COLOR00BBDD;
STICKLINE(反弹,O,C,1,0),COLOR00DDEE;
STICKLINE(反弹,O,C,0.5,0),COLOR00FFFF;
STICKLINE(反弹,H,L,0,0),COLOR00FFFF;
DRAWTEXT_FIX(C>0,0,0,0,'【█】涨势'),COLOR0000AA;
DRAWTEXT_FIX(C>0,0,0.05,0,'【█】回调'),COLORDD6600;
DRAWTEXT_FIX(C>0,0,0.10,0,'【█】跌势'),COLORAAAA00;
DRAWTEXT_FIX(C>0,0,0.15,0,'【█】反弹'),COLOR00BBDD;
均价线:=AMOUNT/V/100;
C2:=REF(C,1);
AA1:MA(C,4);
卖出:IF(AA1<=REF(AA1,1),AA1,DRAWNULL)COLORGREEN,LINETHICK2;
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
STICKLINE(涨停,OPEN,CLOSE,4.6,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,3.5,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
B1:='┄┄┄┄';
DRAWTEXT(均价线 AND 涨停,均价线,B1),COLORGREEN;
B3:='┄┄┄┄';
DRAWTEXT((O+C)/2 AND 涨停,(O+C)/2 ,B3),COLORMAGENTA;
B2:='┄┄┄┄';
DRAWTEXT(涨停,L,B2),COLORGRAY;
DRAWTEXT(涨停,H*0.988,'---涨停'),COLORYELLOW;
买进:DRAWTEXT(CROSS(AA1,X3*0.998-0.018),L*0.97,'★-买进- '),COLORFFFF00,COLORYELLOW;
买进1:DRAWTEXT(CROSS(L,X3*0.9998+0.018) AND C>REF(C,1),L*0.97,'★-买进 '),COLORFFFF00,COLORYELLOW;
HH:=COUNT(涨停,15)>=1;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
震仓线:=45;
震仓线2:=50;
逃命线:=80;
抄底线:=20;
绝底线:=5;
PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;
A:=SMA(L,4,3) ;
STICKLINE(A AND REF(PP,1) AND HH ,A*0.998,A*0.996,5,0);
DRAWICON(A AND REF(PP,1) AND HH,L*0.98,1);
DRAWICON(A AND REF(PP,1) AND HH,L*0.96,23);
STICKLINE(A AND REF(PP3,1) AND HH ,A*0.998,A*0.996,5,0);
DRAWICON(A AND REF(PP3,1) AND HH,L*0.98,1);
牛:DRAWICON(A AND REF(PP3,1) AND HH,L*0.97,23);
追牛:DRAWTEXT(牛,L*0.96,'★-追牛- '),COLORFF00FF;
理想通:=EMA((C-LLV(L,5))/(HHV(H,6)-LLV(L,6)),2)*100,COLORYELLOW,LINETHICK1;
VARB1:=SMA(SMA(理想通,2,1),2,1);
VARB2:=(VARB1/2+36.8)*1;
VARB3:=SMA(VARB2,2,1)+2.2,COLORFFFF00;
VARB4:=SMA(VARB2,2,1)-35.08,COLOR00FF00,LINETHICK1;
卖出1:DRAWTEXT(CROSS(VARB3,理想通*0.9998+0.0018) AND VARB3>67 ,H*1.0012,'-卖出-★ '),COLOR00FF00;
卖出2:DRAWTEXT(CROSS(VARB3,理想通*0.9998+0.0018) AND VARB3>67 ,H*1.0112,' '),COLOR00FF00;
加仓:DRAWTEXT(CROSS(理想通,VARB4*0.9998+0.0018),L*0.986,'★-加仓- '),COLOR0000FF;

通达信成交量回调买主图指标公式

 

相关文章