在线检测未来函数

大智慧新一代DMI指标公式

来源:Internet,编辑:股旁网,2013-10-16

N:=14;
M:=6;
TR := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI: DMP*100/TR,LINETHICK2,Color424BFF;
MDI: DMM*100/TR,LINETHICK2,Color47FC5E;
FILLRGN(PDI,MDI,PDI>=MDI),LINETHICK2,Color0000BB;
FILLRGN(PDI,MDI,PDI<MDI),LINETHICK2,Color47FC5E;
ADX: SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLORFFD700,LINETHICK2;
ADXR:(ADX+REF(ADX,M))/2,LINETHICK2,COLORYELLOW;

大智慧新一代DMI指标公式

 

相关文章