在线检测未来函数

通达信持仓K线趋势主图指标公式

来源:Internet,编辑:股旁网,2013-10-16

A:=DRAWLINE(LOW<=LLV(LOW,120),LOW,HHV(H,6)<=HHV(H,10),LLV(LOW,6),1), COLORBLUE ,LINETHICK2;
TY:=C;
成本:=(MA(CLOSE,60)+MA(CLOSE,70)+MA(CLOSE,90)+MA(CLOSE,108))/4,COLORRED,LINETHICK2;
MA0:MA(C,0)COLORYELLOW,LINETHICK2;
K:=(C+H+L)/3;
D:=MA(K,4);
阻力:=HHV(D,55),COLORYELLOW,LINETHICK2;
顶部:=HHV(H*0.98,55)COLORFFFFFF,LINETHICK2;
DRAWTEXT(REF(C,1)<D AND C>D AND D<REF(D,1),L*0.98, 'D'),COLORYELLOW,LINETHICK2 ;
{均线}
TYP:= (HIGH + LOW +2* C)/4;
均线:=EMA(TYP,3),LINETHICK2,COLORWHITE;
均线上轨:=HHV(均线,14),LINETHICK2,COLORYELLOW;
均线下轨:=LLV(均线,14),LINETHICK2,COLORGREEN;
角度:=ATAN((均线/REF(均线,1)-1)*100)*180/3.1416;
{K线优化}
STICKLINE(角度>0,O ,C ,0.5,0 ),COLORRED;
STICKLINE(角度<0,O ,C,0.5 ,0 ),COLORCYAN;
STICKLINE(角度<0,O,C,3,0),COLORFF6600;{蓝K线持币}
STICKLINE(角度<0,O,C,2,0),COLORFF9900;
STICKLINE(角度<0,O,C,1.2,0),COLORFFCC00;
STICKLINE(角度<0,O,C,0.2,0),COLORCYAN;
STICKLINE(角度>0,O,C,3,0),COLOR000099;
STICKLINE(角度>0,O,C,2,0),COLOR0000CC;{红K线持股}
STICKLINE(角度>0,O,C,1.3,0),COLOR0000FF;
STICKLINE(角度>0,O,C,0.3,0),COLORCC66FF;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(X,13);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWICON(FILTER(买=1,5),L*0.97,23);
EMA5:EMA(C,5);EMA34:EMA(C,34);
KS:=(1-C/SMA(C,13,1))*100;RKS:=REF(KS,1);
MLS:=RKS/KS>1.23 AND RKS>10 AND C/REF(C,1)>1.02;
超跌:STICKLINE(KS>=10,H,L,0,1),COLORWHITE,LINETHICK2;
反弹:STICKLINE(MLS=1,H,L,0,1),COLORMAGENTA,LINETHICK2;
牛线:EMA(C,13)COLORRED,LINETHICK2;
熊线:EMA(KS*C/100+牛线,3)COLORBLUE,LINETHICK2;

通达信持仓K线趋势主图指标公式

 

相关文章