在线检测未来函数

通达信笑口常开主图指标公式

来源:Internet,编辑:股旁网,2013-10-17

W:=55;
MID:=13;
{ASI};
LC:=REF(CLOSE,1);
AA:=ABS(HIGH-LC);
BB:=ABS(LOW-LC);
CC:=ABS(HIGH-REF(LOW,1));
DD:=ABS(LC-REF(OPEN,1));
R:=IF(AA>BB AND AA>CC,AA+BB/2+DD/4,IF(BB>CC AND BB>AA,BB+AA/2+DD/4,CC+DD/4));
X:=(CLOSE-LC+(CLOSE-OPEN)/2+LC-REF(OPEN,1));
SI:=8*X/R*MAX(AA,BB);
ASI:=SUM(SI,0);
{线性回归斜率};
TP:=(O+H+L+C)/4;
长:EMA(SLOPE(TP,13)*1+TP,W),POINTDOT,COLORCYAN;
压力轨道:长+2*STD(TP,W),COLORLIGRAY,CROSSDOT;
支撑轨道:长-2*STD(TP,W),COLORLIGRAY,CROSSDOT;
IF(长>REF(长,1),长,DRAWNULL),POINTDOT,COLORMAGENTA;
{ RSI & MACD };
RLC:=REF(TP,1);
RSI1:=SMA(MAX(TP-RLC,0),8,1)/SMA(ABS(TP-RLC),8,1)*100;
DIF0:=EMA(ASI,21)-EMA(ASI,34);
DEA0:=EMA(DIF0,MID);
MACD0:=DIF0-DEA0;
DRAWICON(EXIST(RSI1<20,3) AND MACD0>REF(MACD0,1),H*1.01,5);

通达信笑口常开主图指标公式

 

相关文章